summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Kustov <ktrace@yandex.ru>2022-04-18 21:45:04 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-05-02 15:08:36 +0300
commit1590184db7716ffb12bfec6409448a93ff4873b2 (patch)
tree04f3b48e6e12b994d47099fdc0bffce35422f3a2
parentnet-misc/dropbox: drop 144.4.4491, 145.4.4921, 146.4.4836 (diff)
downloadgentoo-1590184d.tar.gz
gentoo-1590184d.tar.bz2
gentoo-1590184d.zip
dev-embedded/ponyprog: bump version to 3.1.3
- bump version to 3.1.3, qhexedit to 0.8.9 - fix build system Signed-off-by: Victor Kustov <ktrace@yandex.ru> Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-embedded/ponyprog/Manifest1
-rw-r--r--dev-embedded/ponyprog/files/ponyprog-3.1.3-fix-build-system.patch79
-rw-r--r--dev-embedded/ponyprog/ponyprog-3.1.3.ebuild41
3 files changed, 121 insertions, 0 deletions
diff --git a/dev-embedded/ponyprog/Manifest b/dev-embedded/ponyprog/Manifest
index 6b7e11298f29..dfd8d4148d94 100644
--- a/dev-embedded/ponyprog/Manifest
+++ b/dev-embedded/ponyprog/Manifest
@@ -1 +1,2 @@
DIST ponyprog-3.1.2.tar.gz 1364636 BLAKE2B a913903278791d937266da50fcd5b5bda892dcc316011117816e37fc4ef03becce893b597fb34f2a6ef05b5692bb375e4ba10b04c079a63eb735aa0ddadb5ab9 SHA512 697c6fdc775629086a1c01ad94f291fda550a9ad6065e5fdff9db9fb035b8270ed9058894db7ca17d0daf2a26cc5e431415c160d61f65214677eae2109d87603
+DIST ponyprog-3.1.3.tar.gz 11479313 BLAKE2B 56704b28877687c356c72b1f28f28115cb11f40c701e207f5d3ec4aa4fa7194991162f0940400016d9ee5d42ff0a7e7da5b252f9b76417d0d8272638989fedec SHA512 09e702f3f98e65799e8c59b9c8eca6f477db3f36a2648a1fab3797f91d56c7c4e9533e32bef1fe4c641512e31828a39df4d3d83639b7541714a3cc9050cd4e67
diff --git a/dev-embedded/ponyprog/files/ponyprog-3.1.3-fix-build-system.patch b/dev-embedded/ponyprog/files/ponyprog-3.1.3-fix-build-system.patch
new file mode 100644
index 000000000000..acff26538cd4
--- /dev/null
+++ b/dev-embedded/ponyprog/files/ponyprog-3.1.3-fix-build-system.patch
@@ -0,0 +1,79 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 99e6ff1..d80dcc8 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,7 +1,7 @@
+ PROJECT(ponyprog)
+
+ # Configure CMake ...
+-CMAKE_MINIMUM_REQUIRED(VERSION 2.8 FATAL_ERROR)
++CMAKE_MINIMUM_REQUIRED(VERSION 2.8.12 FATAL_ERROR)
+ # CMAKE_POLICY(SET CMP0003 OLD)
+ # CMAKE_POLICY(SET CMP0015 OLD)
+
+@@ -46,14 +46,7 @@ OPTION (USE_DEBUGGER "Include in binary file debug information" OFF)
+ OPTION (USE_PROFILER "Include in binary file profiling information" OFF)
+
+
+-IF(${USE_DEBUGGER})
+- SET(CMAKE_BUILD_TYPE Debug)
+- SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS_DEBUG} -Wall")
+-ELSE()
+- SET(CMAKE_BUILD_TYPE Release)
+- SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS_RELEASE} -Wall")
+-ENDIF()
+-
++ADD_COMPILE_OPTIONS("-Wall")
+ MESSAGE(STATUS "CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS}")
+
+ INCLUDE(CheckIncludeFile)
+@@ -239,11 +232,12 @@ SET ( MOC_DIR temp )
+ SET ( UI_HEADERS_DIR temp )
+ SET ( UI_SOURCES_DIR temp )
+
+-ADD_SUBDIRECTORY(qhexedit2/src)
+ ADD_SUBDIRECTORY(SrcPony)
+
+-INCLUDE_DIRECTORIES( ${CMAKE_CURRENT_SOURCE_DIR}/qhexedit2/src/ ${CMAKE_CURRENT_SOURCE_DIR}/SrcPony/ )
++find_library(QHexEdit_LIBRARY NAMES qhexedit)
++set(QHexEdit_LIBRARIES "${QHexEdit_LIBRARY}")
+
++INCLUDE_DIRECTORIES( ${CMAKE_CURRENT_SOURCE_DIR}/SrcPony/ )
+
+ IF(${USE_QT_VERSION} MATCHES "4")
+ # QT4_ADD_TRANSLATION(APP_TRANSLATIONS ${TRANSLATION})
+@@ -312,7 +306,7 @@ ELSE()
+ ENDIF()
+
+ #TARGET_LINK_LIBRARIES(${CMAKE_PROJECT_NAME} ${LIBFTDI_LIBRARIES} )
+-TARGET_LINK_LIBRARIES(${CMAKE_PROJECT_NAME} ${LIBFTDIPP_LIBRARY} ${LIBFTDI_LIBRARY} ${LIBUSB_LIBRARIES})
++TARGET_LINK_LIBRARIES(${CMAKE_PROJECT_NAME} ${LIBFTDIPP_LIBRARY} ${LIBFTDI_LIBRARY} ${LIBUSB_LIBRARIES} ${QHexEdit_LIBRARIES})
+
+ ADD_CUSTOM_TARGET (tags
+ COMMAND ctags -R -f tags ${CMAKE_SOURCE_DIR}/SrcPony
+diff --git a/SrcPony/e2cmdw.cpp b/SrcPony/e2cmdw.cpp
+index 252c730..cec93cc 100644
+--- a/SrcPony/e2cmdw.cpp
++++ b/SrcPony/e2cmdw.cpp
+@@ -44,7 +44,7 @@
+ #include <QMessageBox>
+ #include <QDesktopServices>
+
+-#include "qhexedit.h"
++#include <qhexedit.h>
+
+ #include "version.h"
+ #include "e2profil.h"
+diff --git a/SrcPony/e2cmdw.h b/SrcPony/e2cmdw.h
+index c349bf3..df47206 100644
+--- a/SrcPony/e2cmdw.h
++++ b/SrcPony/e2cmdw.h
+@@ -57,7 +57,7 @@
+
+
+ #include "ui_mainwindow.h"
+-#include "qhexedit.h"
++#include <qhexedit.h>
+
+
+
diff --git a/dev-embedded/ponyprog/ponyprog-3.1.3.ebuild b/dev-embedded/ponyprog/ponyprog-3.1.3.ebuild
new file mode 100644
index 000000000000..7445c12350a5
--- /dev/null
+++ b/dev-embedded/ponyprog/ponyprog-3.1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="EEPROM and microcontroller programmer/flasher"
+HOMEPAGE="https://github.com/lancos/ponyprog/"
+SRC_URI="https://github.com/lancos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ >app-editors/qhexedit2-0.8.8_p20200625
+ dev-embedded/libftdi:1[cxx]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ virtual/libusb:1
+"
+# blocker on libftdi-1.5-r2: see #775116
+RDEPEND="${DEPEND}
+ !=dev-embedded/libftdi-1.5-r2
+"
+
+PATCHES=( "${FILESDIR}"/${P}-fix-build-system.patch )
+
+pkg_postinst() {
+ elog "To use the COM port in user mode (not as root), you need to"
+ elog "be in the 'uucp' group."
+ elog
+ elog "To use the LPT port in user mode (not as root) you need a kernel with"
+ elog "ppdev, parport and parport_pc compiled in or as modules. You need the"
+ elog "rights to write to /dev/parport? devices."
+}