summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-01 05:53:41 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-01 08:53:48 +0200
commit159aa42e6462c062ab8c39b906668e928743ee0b (patch)
treedacdf51b83698e2bdfff4bed77669f0e8eb43771
parentdev-python/boto3: Bump to 1.24.21 (diff)
downloadgentoo-159aa42e6462c062ab8c39b906668e928743ee0b.tar.gz
gentoo-159aa42e6462c062ab8c39b906668e928743ee0b.tar.bz2
gentoo-159aa42e6462c062ab8c39b906668e928743ee0b.zip
app-admin/awscli: Bump to 1.25.21
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.25.21.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index bd229580894a..7b1c4b5a593b 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,3 +1,4 @@
DIST aws-cli-1.25.12.gh.tar.gz 2224456 BLAKE2B d6425983b09fc3942727108e188e184f48399388704ada03df1d65ddb9adffc9597a217b863766a862e96b59c03fdb3202e694289b54ee9298fe7e547639ecc3 SHA512 a77e0d082a8dacecadbd2fa6cc1143fa5148e075894565fe9a552e9d1a27fd068c72ae57eb5c628129bb024267111b76722cf2c40dc9f719db8d96232302b918
DIST aws-cli-1.25.17.gh.tar.gz 2226115 BLAKE2B d07a9c7a8e13019fd728489d27465497ba31f53087ef09e5f816792267bcb58158fa0a7f71fc499d3e343b5b3a0da45cc3632f8c69345b8cd93ebc735f645672 SHA512 1a7f90e28d6702f9e73fe3a93e0d91e2c4ea3d93574f21a3ecde1148445fe6b5f98f217e2e61a1cbba50a07590f0ab0abd00390fb04cbb3db74dfff698224997
DIST aws-cli-1.25.20.gh.tar.gz 2227422 BLAKE2B 7dfeb6266578fc61a4fa54f39bbaaabcc8c53fc133f1993669a3cda0398fa67a6e54f122b6a103474a0b6a31c7a259237cf4a759995eab727d8f103a8649163a SHA512 0179487b9dbc9864eeb066e9f4f30c67b17dec589c5860b476cbc7798d1b163080d7d3caeae18367afdd89d299f508bfbbb2150d4795aaa85efdeb5b61030663
+DIST aws-cli-1.25.21.gh.tar.gz 2228274 BLAKE2B 3246bcc1607fa7a43cb081192176345c189b8e19c197e22f27396d3dd72f7e55436820010f9245375ddbf4cfc24f13d2fc47864ad34a5dca1529669e91b6bff1 SHA512 26a97d632206016cfba2a8a51949ad623677a04a6582d1f7f28191c02adb39bf8f4b42e22796c3c97c29ae2dc36007803fc25f442111a67f93f3cc8880e50759
diff --git a/app-admin/awscli/awscli-1.25.21.ebuild b/app-admin/awscli/awscli-1.25.21.ebuild
new file mode 100644
index 000000000000..9f176fa05cc8
--- /dev/null
+++ b/app-admin/awscli/awscli-1.25.21.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}