summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-10-22 09:26:58 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-10-22 10:21:14 +0200
commit15a4dc4f16bc10323188f9f0a684557eb1edb4b9 (patch)
tree24b90b300520ea6a03aca7c545d799abc21cc162
parentmedia-video/acidrip: Port to EAPI 8 (diff)
downloadgentoo-15a4dc4f16bc10323188f9f0a684557eb1edb4b9.tar.gz
gentoo-15a4dc4f16bc10323188f9f0a684557eb1edb4b9.tar.bz2
gentoo-15a4dc4f16bc10323188f9f0a684557eb1edb4b9.zip
media-video/mpgtx: Port to EAPI 8
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--media-video/mpgtx/files/mpgtx-1.3.1-configure.patch4
-rw-r--r--media-video/mpgtx/files/mpgtx-1.3.1-dont-ignore-cxx-flags.patch4
-rw-r--r--media-video/mpgtx/mpgtx-1.3.1-r2.ebuild30
3 files changed, 18 insertions, 20 deletions
diff --git a/media-video/mpgtx/files/mpgtx-1.3.1-configure.patch b/media-video/mpgtx/files/mpgtx-1.3.1-configure.patch
index ec36e76ba641..bfac4c5a016f 100644
--- a/media-video/mpgtx/files/mpgtx-1.3.1-configure.patch
+++ b/media-video/mpgtx/files/mpgtx-1.3.1-configure.patch
@@ -1,5 +1,5 @@
---- configure.old 2006-12-07 19:51:08.000000000 +0100
-+++ configure 2006-12-07 19:51:02.000000000 +0100
+--- a/configure
++++ b/configure
@@ -9,7 +9,6 @@
prefix="/usr/local"
manprefix='$(PREFIX)'
diff --git a/media-video/mpgtx/files/mpgtx-1.3.1-dont-ignore-cxx-flags.patch b/media-video/mpgtx/files/mpgtx-1.3.1-dont-ignore-cxx-flags.patch
index 3a7f5da67458..7d6004f1e0ea 100644
--- a/media-video/mpgtx/files/mpgtx-1.3.1-dont-ignore-cxx-flags.patch
+++ b/media-video/mpgtx/files/mpgtx-1.3.1-dont-ignore-cxx-flags.patch
@@ -1,5 +1,5 @@
---- mpgtx-1.3.1/configure.old 2006-12-09 00:26:18.000000000 +0100
-+++ mpgtx-1.3.1/configure 2006-12-09 00:28:52.000000000 +0100
+--- a/configure
++++ b/configure
@@ -11,7 +11,7 @@
#compiler flags
common_cflags="-Wall"
diff --git a/media-video/mpgtx/mpgtx-1.3.1-r2.ebuild b/media-video/mpgtx/mpgtx-1.3.1-r2.ebuild
index 11bb99459f44..5068956f28e9 100644
--- a/media-video/mpgtx/mpgtx-1.3.1-r2.ebuild
+++ b/media-video/mpgtx/mpgtx-1.3.1-r2.ebuild
@@ -1,27 +1,25 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit epatch toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Command line MPEG audio/video/system file toolbox"
SRC_URI="mirror://sourceforge/mpgtx/${P}.tar.gz"
HOMEPAGE="http://mpgtx.sourceforge.net/"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-IUSE=""
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-configure.patch \
- "${FILESDIR}"/${P}-dont-ignore-cxx-flags.patch
- tc-export CXX
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-configure.patch
+ "${FILESDIR}"/${P}-dont-ignore-cxx-flags.patch
+)
src_configure() {
+ tc-export CXX
./configure --parachute || die
}
@@ -37,11 +35,11 @@ src_install() {
doman man/mpgtx.1 man/tagmp3.1
- dosym /usr/share/man/man1/mpgtx.1 /usr/share/man/man1/mpgcat.1
- dosym /usr/share/man/man1/mpgtx.1 /usr/share/man/man1/mpgjoin.1
- dosym /usr/share/man/man1/mpgtx.1 /usr/share/man/man1/mpginfo.1
- dosym /usr/share/man/man1/mpgtx.1 /usr/share/man/man1/mpgsplit.1
- dosym /usr/share/man/man1/mpgtx.1 /usr/share/man/man1/mpgdemux.1
+ dosym mpgtx.1 /usr/share/man/man1/mpgcat.1
+ dosym mpgtx.1 /usr/share/man/man1/mpgjoin.1
+ dosym mpgtx.1 /usr/share/man/man1/mpginfo.1
+ dosym mpgtx.1 /usr/share/man/man1/mpgsplit.1
+ dosym mpgtx.1 /usr/share/man/man1/mpgdemux.1
- dodoc AUTHORS ChangeLog README TODO
+ einstalldocs
}