summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-11-04 21:44:38 +0100
committerUlrich Müller <ulm@gentoo.org>2020-11-04 21:46:11 +0100
commit15b47b709ef9abb8837093941eb79a15016dd513 (patch)
tree23ac80f24c367b948a47bbf6efa736e978b52850
parentsci-visualization/gnuplot: Remove old. (diff)
downloadgentoo-15b47b709ef9abb8837093941eb79a15016dd513.tar.gz
gentoo-15b47b709ef9abb8837093941eb79a15016dd513.tar.bz2
gentoo-15b47b709ef9abb8837093941eb79a15016dd513.zip
sci-visualization/gnuplot: Update live ebuild.
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--sci-visualization/gnuplot/gnuplot-5.5.9999.ebuild (renamed from sci-visualization/gnuplot/gnuplot-5.3.9999.ebuild)52
1 files changed, 28 insertions, 24 deletions
diff --git a/sci-visualization/gnuplot/gnuplot-5.3.9999.ebuild b/sci-visualization/gnuplot/gnuplot-5.5.9999.ebuild
index aa399503dd8b..697da1fe7672 100644
--- a/sci-visualization/gnuplot/gnuplot-5.3.9999.ebuild
+++ b/sci-visualization/gnuplot/gnuplot-5.5.9999.ebuild
@@ -20,9 +20,11 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
fi
+S="${WORKDIR}/${MY_P}"
+
LICENSE="gnuplot"
SLOT="0"
-IUSE="aqua bitmap cairo doc examples +gd ggi latex libcaca libcerf lua qt5 readline wxwidgets X"
+IUSE="aqua bitmap cairo doc examples +gd ggi latex libcaca libcerf lua qt5 readline regis wxwidgets X"
RDEPEND="
cairo? (
@@ -47,10 +49,10 @@ RDEPEND="
readline? ( sys-libs/readline:0= )
libcerf? ( sci-libs/libcerf )
wxwidgets? (
- x11-libs/wxGTK:3.0[X]
+ x11-libs/wxGTK:3.0-gtk3[X]
x11-libs/cairo
x11-libs/pango
- x11-libs/gtk+:2 )
+ x11-libs/gtk+:3 )
X? ( x11-libs/libXaw )"
DEPEND="${RDEPEND}"
@@ -60,21 +62,23 @@ BDEPEND="
doc? (
virtual/latex-base
dev-texlive/texlive-latexextra
+ dev-texlive/texlive-langgreek
app-text/ghostscript-gpl )
qt5? ( dev-qt/linguist-tools:5 )"
-S="${WORKDIR}/${MY_P}"
-
GP_VERSION="${PV%.*}"
E_SITEFILE="lisp/50${PN}-gentoo.el"
TEXMF="${EPREFIX}/usr/share/texmf-site"
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.0.1-fix-underlinking.patch
+ "${FILESDIR}"/${PN}-5.0.6-no-picins.patch
+)
+
src_prepare() {
- eapply "${FILESDIR}"/${PN}-5.0.1-fix-underlinking.patch
- eapply "${FILESDIR}"/${PN}-5.0.6-no-picins.patch
- eapply_user
+ default
- if [[ -z ${PV%%*9999} ]]; then
+ if [[ ${PV##*.} = 9999 ]]; then
local dir
for dir in config demo m4 term tutorial; do
emake -C "$dir" -f Makefile.am.in Makefile.am
@@ -85,14 +89,6 @@ src_prepare() {
# of the gnuplot license
sed -i -e "1s/.*/& (Gentoo revision ${PR})/" PATCHLEVEL || die
- DOC_CONTENTS='Gnuplot no longer links against pdflib, see the ChangeLog
- for details. You can use the "pdfcairo" terminal for PDF output.'
- use cairo || DOC_CONTENTS+=' It is available with USE="cairo".'
- use gd && DOC_CONTENTS+="\n\nFor font support in png/jpeg/gif output,
- you may have to set the GDFONTPATH and GNUPLOT_DEFAULT_GDFONT
- environment variables. See the FAQ file in /usr/share/doc/${PF}/
- for more information."
-
eautoreconf
# Make sure we don't mix build & host flags.
@@ -110,7 +106,7 @@ src_configure() {
fi
if use wxwidgets; then
- WX_GTK_VER="3.0"
+ WX_GTK_VER="3.0-gtk3"
setup-wxwidgets
fi
@@ -125,12 +121,12 @@ src_configure() {
--with-readline=$(usex readline gnu builtin) \
$(use_with bitmap bitmap-terminals) \
$(use_with cairo) \
- $(use_with doc tutorial) \
$(use_with gd) \
"$(use_with ggi ggi "${EPREFIX}/usr/$(get_libdir)")" \
"$(use_with libcaca caca "${EPREFIX}/usr/$(get_libdir)")" \
$(use_with libcerf) \
$(use_with lua) \
+ $(use_with regis) \
$(use_with X x) \
--enable-stats \
$(use_with qt5 qt qt5) \
@@ -156,17 +152,24 @@ src_compile() {
emake -C docs pdf_nofig
mv docs/nofigures.pdf docs/gnuplot.pdf || die
fi
- emake -C tutorial pdf
fi
}
src_install() {
emake DESTDIR="${D}" install
- dodoc BUGS NEWS PGPKEYS README* RELEASE_NOTES TODO
+ dodoc BUGS NEWS PGPKEYS README* RELEASE_NOTES
newdoc term/PostScript/README README-ps
newdoc term/js/README README-js
use lua && newdoc term/lua/README README-lua
+
+ local DOC_CONTENTS='Gnuplot no longer links against pdflib. You can
+ use the "pdfcairo" terminal for PDF output.'
+ use cairo || DOC_CONTENTS+=' It is available with USE="cairo".'
+ use gd && DOC_CONTENTS+="\n\nFor font support in png/jpeg/gif output,
+ you may have to set the GDFONTPATH and GNUPLOT_DEFAULT_GDFONT
+ environment variables. See the FAQ file in /usr/share/doc/${PF}/
+ for more information."
readme.gentoo_create_doc
if use examples; then
@@ -178,8 +181,8 @@ src_install() {
fi
if use doc; then
- # Manual, tutorial, FAQ
- dodoc docs/gnuplot.pdf tutorial/{tutorial.dvi,tutorial.pdf} FAQ.pdf
+ # Manual, FAQ
+ dodoc docs/gnuplot.pdf #FAQ.pdf
# Documentation for making PostScript files
docinto psdoc
dodoc docs/psdoc/{*.doc,*.tex,*.ps,*.gpi,README}
@@ -187,7 +190,8 @@ src_install() {
}
src_test() {
- GNUTERM="unknown" default_src_test
+ #GNUTERM="unknown" emake check # spiderplot and isosurface tests fail
+ GNUTERM="dumb" emake check
}
pkg_postinst() {