summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-08 21:32:28 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-08 22:06:55 +0200
commit15d5eb463d41eb5d732741c47caeb001f5e666c1 (patch)
treead1e2bd1e07235b00b0f2429113a9de05dde469c
parentdev-python/django-auth-ldap: Bump to 4.5.0 (diff)
downloadgentoo-15d5eb463d41eb5d732741c47caeb001f5e666c1.tar.gz
gentoo-15d5eb463d41eb5d732741c47caeb001f5e666c1.tar.bz2
gentoo-15d5eb463d41eb5d732741c47caeb001f5e666c1.zip
dev-python/tox: Bump to 4.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/tox/Manifest1
-rw-r--r--dev-python/tox/tox-4.7.0.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index 7a1183c6377b..704b8aa77bbc 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -6,3 +6,4 @@ DIST tox-4.6.1.tar.gz 172090 BLAKE2B ee86b8972ee273f07ab0197ab2f0b6ce4505206eebc
DIST tox-4.6.2.tar.gz 172333 BLAKE2B 0fa9e7782eb18b525ff7f226b0fa9b8001f69f8b620b86a19bc2c19c349b2c8c7440a1de220387bccaa7a9044796db57ae63d16851c98a73ced2c495a01b5f3e SHA512 3e4663972f8c51a634f00c57c8b9b6704a628e912ef2e1854a8dfbd7bce13e44822984af9f69cb5b8a306ede545a565044cfeb8803cff41a530de7958fc07878
DIST tox-4.6.3.tar.gz 172585 BLAKE2B 14d895a516fdb1b767c922633185b31904149e7fea9d1ae3faaac343bfd481fc843dcb4784168c89fb6d3f5503f4ff8fb35680ed197b5df2dde1f124be1df8ea SHA512 6261998bb753556a24e869db18955eea9b26063e0b67503028571e62085c2da535dc60552192c69ba07366150c4f3a3ce6bd36dd62d2fe6f24d7b466dccf2e76
DIST tox-4.6.4.tar.gz 172650 BLAKE2B 84164dbb02002d398e779b0c5e4617213fbfc711ded95faddde93711549eab9e69675f0a459ce60ba8357baf4e7d361f86b4cb85818972e5d018a61db179ba1a SHA512 b6a4673ea58e21b5e8b3d1330244d46ac7a36563a089b2e03cfcd7039386ab6afc437ebf4c516bbe373133a7beb54ebb380d39ab126be69f3601226f2273f3c2
+DIST tox-4.7.0.tar.gz 172893 BLAKE2B 9611cbff7937e859ad923d40978804eede6eb372868c7af85597644a3568e775627361faa64587aa44c9e1e3bcf565fb4c6956d73fe973c258c90f005f5e5b14 SHA512 17c010af1dd402dd1dff86dca9154be16212bdbdafa4d83f6337e5c4ebd6f7256b7cf813ac8bb22d755873c89179caeecbaeed05c7e6dd6903251c3548fa8042
diff --git a/dev-python/tox/tox-4.7.0.ebuild b/dev-python/tox/tox-4.7.0.ebuild
new file mode 100644
index 000000000000..2882a504edbf
--- /dev/null
+++ b/dev-python/tox/tox-4.7.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="virtualenv-based automation of test activities"
+HOMEPAGE="
+ https://tox.readthedocs.io/
+ https://github.com/tox-dev/tox/
+ https://pypi.org/project/tox/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/cachetools-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/chardet-5.1[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.12.2[${PYTHON_USEDEP}]
+ >=dev-python/packaging-23.1[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-3.9.1[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-1.2[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-api-1.5.3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+ >=dev-python/virtualenv-20.24.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/hatch-vcs-0.3[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/build-0.10[${PYTHON_USEDEP}]
+ >=dev-python/distlib-0.3.6[${PYTHON_USEDEP}]
+ >=dev-python/flaky-3.7[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.9.5[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.11.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.3.1[${PYTHON_USEDEP}]
+ >=dev-python/re-assert-1.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/time-machine-2.10[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # devpi_process is not packaged, and has lots of dependencies
+ cat > "${T}"/devpi_process.py <<-EOF || die
+ def IndexServer(*args, **kwargs): raise NotImplementedError()
+ EOF
+
+ local -x PYTHONPATH=${T}:${PYTHONPATH}
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/tox_env/python/virtual_env/package/test_package_cmd_builder.py::test_build_wheel_external
+ )
+ local EPYTEST_IGNORE=(
+ # requires devpi*
+ tests/test_provision.py
+ )
+
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[explicit-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[constraints-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[explicit+requirements-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements_indirect-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements_constraints_indirect-True-True]'
+ )
+
+ epytest
+}