summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-03 04:40:26 +0100
committerSam James <sam@gentoo.org>2022-04-03 04:41:14 +0100
commit15e6dffa3680104216b0158e3f8ef477100a7f46 (patch)
tree850544068fed032cd76385892fd5ae777136c9a8
parentdev-libs/libfido2: add 1.10.0 (diff)
downloadgentoo-15e6dffa.tar.gz
gentoo-15e6dffa.tar.bz2
gentoo-15e6dffa.zip
sys-apps/gsmartcontrol: add 1.1.4
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/gsmartcontrol/Manifest1
-rw-r--r--sys-apps/gsmartcontrol/gsmartcontrol-1.1.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/sys-apps/gsmartcontrol/Manifest b/sys-apps/gsmartcontrol/Manifest
index 53cbcb9a1493..671bd3bb3382 100644
--- a/sys-apps/gsmartcontrol/Manifest
+++ b/sys-apps/gsmartcontrol/Manifest
@@ -1 +1,2 @@
DIST gsmartcontrol-1.1.3.tar.bz2 677998 BLAKE2B f444dd29602f6934b440650e57d5d981a3b9823a905ce3c178109b230e6536edd4f38ed0762872b38186774127a164feb7363bb45cbd80e9c0b34398c1a06092 SHA512 7a8bb79875a53d742923fc8ff8336d7fbbdaf2e1b1f64296840557997125d4dcfea9a93a5e8a834003d592083a180ee85ca0e29d3aecf0eb475a3d4fed460456
+DIST gsmartcontrol-1.1.4.tar.bz2 691155 BLAKE2B 484452b85e848ca9d0539f9fb9e63fc60f837d5e5de1d85d6ef6340fba194ea52cb2026682b263b1391a59eee4ee846dad3863dc1f0bd00296015ddcf86dda9a SHA512 a59147f7adb76fa1cfc55198d175b38f7840c0ec07563bc020757d7609891c8f67953b87a867235821f90c52bc3c8e40a8d8a57a1429e4b75a3afb3a2ada42f1
diff --git a/sys-apps/gsmartcontrol/gsmartcontrol-1.1.4.ebuild b/sys-apps/gsmartcontrol/gsmartcontrol-1.1.4.ebuild
new file mode 100644
index 000000000000..2dc9c0c0ebad
--- /dev/null
+++ b/sys-apps/gsmartcontrol/gsmartcontrol-1.1.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic xdg
+
+DESCRIPTION="Hard disk drive health inspection tool"
+HOMEPAGE="https://gsmartcontrol.sourceforge.io/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 GPL-3 ) Boost-1.0 BSD Unlicense ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-cpp/gtkmm:3.0
+ dev-libs/libpcre:3
+ sys-apps/smartmontools"
+RDEPEND="${DEPEND}
+ x11-apps/xmessage"
+BDEPEND="virtual/pkgconfig
+ test? ( dev-util/gtk-builder-convert )"
+
+DOCS=( TODO ) # See 'dist_doc_DATA' value in Makefile.am
+
+src_configure() {
+ append-cxxflags -std=c++11
+
+ econf $(use test tests)
+}
+
+src_install() {
+ default
+
+ rm "${ED}"/usr/share/doc/${PF}/LICENSE_* || die
+}