summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-25 04:51:20 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-25 05:07:28 +0100
commit15efb9cfc033dc55012ac0889b93f7f6d21a17f4 (patch)
tree9213540fb1288518ef3668d3f5408b73dc309402
parentdev-python/pytest-httpserver: Bump to 1.0.10 (diff)
downloadgentoo-15efb9cfc033dc55012ac0889b93f7f6d21a17f4.tar.gz
gentoo-15efb9cfc033dc55012ac0889b93f7f6d21a17f4.tar.bz2
gentoo-15efb9cfc033dc55012ac0889b93f7f6d21a17f4.zip
dev-python/rq: Bump to 1.16.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rq/Manifest1
-rw-r--r--dev-python/rq/rq-1.16.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/rq/Manifest b/dev-python/rq/Manifest
index 22cd23663130..54952fd9bd41 100644
--- a/dev-python/rq/Manifest
+++ b/dev-python/rq/Manifest
@@ -1 +1,2 @@
DIST rq-1.15.1.gh.tar.gz 633531 BLAKE2B e1cf463e54533a1a56fab98a66f4cfe2ef73da48ab965a10066b84050aa1ac72373328246236fbd45bdf3d026ffc355aa117a21047dce1cef16b18c6e96a0f3f SHA512 75228f037c5c731f7788bb18654f2e07a9af39f8980900166e07145887f7cbed06fbd7fb5513a770cee791d07a49d85a544b83f347cce6726d7745f8396e3aac
+DIST rq-1.16.0.tar.gz 627998 BLAKE2B cff296147f92d234a29f3e1c0f762bcaf873aabebc3cea816e8a772586e41ca850bba600d1e6e974ebfe1da4286ee4b15a5326cb0fee1a082b7bc632005b3ef5 SHA512 8746bed4d9fccd2f74ceb3ba026268f3c7441f278348e2823e6dbaf95326ff396f76564f3622c94440fef4b0a49b5fadc5680b1abdb3cfaacfa1118aa85c8457
diff --git a/dev-python/rq/rq-1.16.0.ebuild b/dev-python/rq/rq-1.16.0.ebuild
new file mode 100644
index 000000000000..ac48b2056812
--- /dev/null
+++ b/dev-python/rq/rq-1.16.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple, lightweight library for creating and processing background jobs"
+HOMEPAGE="
+ https://python-rq.org/
+ https://github.com/rq/rq/
+ https://pypi.org/project/rq/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/click-5.0[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/sentry-sdk[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+ local redis_test_config="daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ "
+
+ # Spawn Redis itself for testing purposes
+ # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
+ # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ /usr/sbin/redis-server - <<< "${redis_test_config}" || die
+
+ # Run the actual tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}