summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2023-06-15 18:17:24 -0500
committerMatthias Maier <tamiko@gentoo.org>2023-06-16 20:03:18 -0500
commit161fc86a9bdc9277f26b023de5e422bb5d56c2b8 (patch)
tree2ed0d1fd2a01216f282337029f14619cc4872afc
parentkde-misc/tellico: Stabilize 3.5 amd64, #908606 (diff)
downloadgentoo-161fc86a9bdc9277f26b023de5e422bb5d56c2b8.tar.gz
gentoo-161fc86a9bdc9277f26b023de5e422bb5d56c2b8.tar.bz2
gentoo-161fc86a9bdc9277f26b023de5e422bb5d56c2b8.zip
sci-libs/arborx: fix libdir
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
-rw-r--r--sci-libs/arborx/arborx-1.4.1-r1.ebuild (renamed from sci-libs/arborx/arborx-1.4.1.ebuild)8
1 files changed, 8 insertions, 0 deletions
diff --git a/sci-libs/arborx/arborx-1.4.1.ebuild b/sci-libs/arborx/arborx-1.4.1-r1.ebuild
index c27f694b4071..d0d4cf0e2ed2 100644
--- a/sci-libs/arborx/arborx-1.4.1.ebuild
+++ b/sci-libs/arborx/arborx-1.4.1-r1.ebuild
@@ -24,6 +24,14 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}"/ArborX-${PV}
+src_prepare() {
+ default
+ cmake_src_prepare
+
+ # replace hardcoded "lib/" directory:
+ sed -i -e "s#lib/#$(get_libdir)/#g" CMakeLists.txt || die "sed failed"
+}
+
src_configure() {
local mycmakeargs=(
-DARBORX_ENABLE_MPI="$(usex mpi)"