summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-12 23:15:29 -0400
committerSam James <sam@gentoo.org>2024-03-13 21:04:03 +0000
commit16238c265bc2c444c5d10b5f27698e178f94af7e (patch)
tree5a1a8b45b2754dc233501b01daba0a6fe653c224
parentsci-visualization/dash: enable py3.12 (diff)
downloadgentoo-16238c265bc2c444c5d10b5f27698e178f94af7e.tar.gz
gentoo-16238c265bc2c444c5d10b5f27698e178f94af7e.tar.bz2
gentoo-16238c265bc2c444c5d10b5f27698e178f94af7e.zip
media-libs/libreplaygain: add 483
Upgrade to latest revision upstream, from 2013-10-21. Contains one effective change, that being the one that led to having a custom src_install() function. Reroll the patch as well (we don't care about COMPONENTS but it made the hunk be rejected). Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/libreplaygain/Manifest1
-rw-r--r--media-libs/libreplaygain/files/libreplaygain-483-static-libs.patch30
-rw-r--r--media-libs/libreplaygain/libreplaygain-483.ebuild25
3 files changed, 56 insertions, 0 deletions
diff --git a/media-libs/libreplaygain/Manifest b/media-libs/libreplaygain/Manifest
index 01ec7d4bfcf0..777f05a329d7 100644
--- a/media-libs/libreplaygain/Manifest
+++ b/media-libs/libreplaygain/Manifest
@@ -1 +1,2 @@
DIST libreplaygain-477.tar.xz 8272 BLAKE2B 6382984643aad155b3e5e0dac8a7ca698320068c62fa87ac7f466e34e850f05df1e823d87f7cb477bd22f59c97f7e5ac8757e9bd6f59c2f5f1852efe9f083d72 SHA512 9e81deb237e35e63d67efabcbfe40f5a6fd34f4a6b0239a21e6ab8ba3c9ca172297cf323fbc4ada749dcfcdf0b711c354e39f12af9a9576900384c441657ff8e
+DIST libreplaygain-483.tar.xz 8312 BLAKE2B 24f0ff6c772dd1bafd1212db7b886756c1a8ada6bf7583fa3e2950adae48c2524c82646a989f8c92b4c92024c60f0fb1f5e5f53b27d88748e5c59fdbc400f0e6 SHA512 90b2030f8e48946788c5a5cefb72048335e4d9b60d05594d9bcd0fd46f242872176f5c9061ff1b51ea29fbfb86f8311bedcc60706242aac08327121c85e91071
diff --git a/media-libs/libreplaygain/files/libreplaygain-483-static-libs.patch b/media-libs/libreplaygain/files/libreplaygain-483-static-libs.patch
new file mode 100644
index 000000000000..b85b4a29725e
--- /dev/null
+++ b/media-libs/libreplaygain/files/libreplaygain-483-static-libs.patch
@@ -0,0 +1,30 @@
+From 6873ea2e2f90d772f72264c4cbaa450b6fa1c827 Mon Sep 17 00:00:00 2001
+From: Jakov Smolic <jakov.smolic@sartura.hr>
+Date: Sun, 20 Sep 2020 22:10:37 +0200
+Subject: [PATCH] src: CMakeLists: disable static libs
+
+Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr>
+---
+ src/CMakeLists.txt | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 9ce9aae..2f51d2b 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -1,11 +1,8 @@
+ include_directories(${libreplaygain_SOURCE_DIR}/include)
+
+-add_library(replaygain-static STATIC gain_analysis)
+-set_target_properties(replaygain-static PROPERTIES OUTPUT_NAME replaygain CLEAN_DIRECT_OUTPUT 1)
+-
+ add_library(replaygain-shared SHARED gain_analysis)
+ set_target_properties(replaygain-shared PROPERTIES OUTPUT_NAME replaygain CLEAN_DIRECT_OUTPUT 1 VERSION 1.0.0 SOVERSION 1)
+
+-install(TARGETS replaygain-static replaygain-shared LIBRARY DESTINATION "lib${LIB_SUFFIX}" ARCHIVE DESTINATION "lib${LIB_SUFFIX}" COMPONENT libraries)
++install(TARGETS replaygain-shared LIBRARY DESTINATION "lib${LIB_SUFFIX}" ARCHIVE DESTINATION "lib${LIB_SUFFIX}" COMPONENT libraries)
+
+ install(FILES ${libreplaygain_SOURCE_DIR}/include/replaygain/gain_analysis.h DESTINATION include/replaygain COMPONENT headers)
+--
+2.43.2
+
diff --git a/media-libs/libreplaygain/libreplaygain-483.ebuild b/media-libs/libreplaygain/libreplaygain-483.ebuild
new file mode 100644
index 000000000000..577348b1e2b3
--- /dev/null
+++ b/media-libs/libreplaygain/libreplaygain-483.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+# svn export http://svn.musepack.net/libreplaygain@${PV} libreplaygain-${PV}
+# tar -cJf libreplaygain-${PV}.tar.xz libreplaygain-${PV}
+
+DESCRIPTION="Replay Gain library from Musepack"
+HOMEPAGE="https://www.musepack.net/"
+SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+PATCHES=( "${FILESDIR}"/${P}-static-libs.patch )
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -i -e '/CMAKE_C_FLAGS/d' CMakeLists.txt || die
+}