summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-06-21 12:37:32 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-06-21 12:37:32 -0500
commit162bc03c1b72368ba5613b74afa4cef02d710f0b (patch)
tree7f49fd9855fa5354aecb56395648407319d67730
parenttoolchain-binutils.eclass: [QA] Remove USE=multislot, #584610 (diff)
downloadgentoo-162bc03c1b72368ba5613b74afa4cef02d710f0b.tar.gz
gentoo-162bc03c1b72368ba5613b74afa4cef02d710f0b.tar.bz2
gentoo-162bc03c1b72368ba5613b74afa4cef02d710f0b.zip
www-apps/icingaweb2: bup
Package-Manager: portage-2.2.28
-rw-r--r--www-apps/icingaweb2/Manifest1
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.3.4.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/www-apps/icingaweb2/Manifest b/www-apps/icingaweb2/Manifest
index 353356fba567..6392a0049c4a 100644
--- a/www-apps/icingaweb2/Manifest
+++ b/www-apps/icingaweb2/Manifest
@@ -1,3 +1,4 @@
DIST icingaweb2-2.2.0.tar.gz 9803668 SHA256 f240b35a4082b4835127608d0b11a27a4bf53bb0c88857344255225ce9611201 SHA512 e07948e284e59ac16f94191607d9da88b06e9e311af9f79b3fb19e1a7d943144515d4122dae4b01d09927b586ae4ccf15cce54e47e0e784882a422d6eb434f59 WHIRLPOOL 32734309b65e4ed0d04b060fadeef617ec9f7da7c227c563d76ede12e5839305b3a384f0b355aa8bc6a62d1220f4bf78f2299cddcbedcc7a9f2c1b1972dc5059
DIST icingaweb2-2.3.2.tar.gz 9812433 SHA256 89abfec58726cadc0380897880190ece84f74f34152b1146ee7b24244337b76d SHA512 9cdea22df385e385077321ce482662b8e6529d0eef7be64880f695718431cf80de33e9dd40d480f3f284911aa58ef0d9d50a7ed52328d63612777569f9576052 WHIRLPOOL 98549205b00105e8b4516cbb3a51862eb710ef2b88506d9ff259ff9fb35c844be42efa21ad9acd657261a7e651ab386feed77295f787ca9cfc8eea2fb6f75d96
DIST icingaweb2-2.3.3.tar.gz 9822506 SHA256 4f315f4a2099ab9562b2076e8f3e7e14562644b6cb62c9aa24adefc76b3f8f77 SHA512 864dc6c466c77413ef1674a60edc621f68ab1c72030b832391d457a19417278f7812f6e6fb0424862ebf6bc37ff1562521987a1d05b01b090a8994a1c61907fe WHIRLPOOL 671f3e14982f1618a91d4c029ebf4133ea3fc56b8bafb3fb2350b7feb1c885aae54db06fe0de7864674a6862cc0bd63fc26bd7d3d62b62e18e2c37e07ec3df81
+DIST icingaweb2-2.3.4.tar.gz 9822451 SHA256 31b7a4b7a40587d18f7eb743686e8b1ccaee95a0b5c58baee2ea8f29b57e64ab SHA512 abfb556f6b27982524db9a6283af4fe7d5d6c559b4d15309477721d372760723c29588214c8147288c81784af75c2254d2b90563739cd68b9c9109326f9ed128 WHIRLPOOL 384a52d5f499c5e2befee78dd26a700682297ab24eeddc634849701745dcdbc88b0421a2574d4d11fc613c72b3f5146074c6395ac99aae488f2d150e42a05d67
diff --git a/www-apps/icingaweb2/icingaweb2-2.3.4.ebuild b/www-apps/icingaweb2/icingaweb2-2.3.4.ebuild
new file mode 100644
index 000000000000..4b582b6fc85d
--- /dev/null
+++ b/www-apps/icingaweb2/icingaweb2-2.3.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit depend.apache eutils multilib user
+
+DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
+HOMEPAGE="http://www.icinga.org/"
+SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="apache2 ldap mysql nginx postgres"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ || (
+ dev-lang/php:5.6[apache2?,cli,gd,json,intl,ldap?,mysql?,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.0[apache2?,cli,gd,json,intl,ldap?,mysql?,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ dev-php/pecl-imagick
+ apache2? ( >=www-servers/apache-2.4.0 )
+ nginx? ( >=www-servers/nginx-1.7.0:* )"
+RDEPEND="${DEPEND}"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+
+ enewgroup icingaweb2
+ enewgroup icingacmd
+ use nginx && usermod -a -G icingacmd,icingaweb2 nginx
+ use apache2 && usermod -a -G icingacmd,icingaweb2 apache2
+}
+
+pkg_config() {
+ if [[ -d /etc/icingaweb2 ]] ; then
+ einfo "Updating existing installation ..."
+ else
+ einfo "Running first time setup ..."
+ einfo "Creating configuration directory ..."
+ /usr/share/${PN}/bin/icingacli setup config directory
+ einfo "Creating authentication token for web setup ..."
+ /usr/share/${PN}/bin/icingacli setup token create
+ if use apache2 ; then
+ einfo "The following might be useful for your Apache2 configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
+ fi
+ if use nginx ; then
+ einfo "The following might be useful for your NGinx configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
+ fi
+ fi
+ einfo "All done."
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r "${S}"/*
+ fperms -R a+rX "/usr/share/${PN}/public/"
+ fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
+}
+
+pkg_postinst() {
+ einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
+}