summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-04 05:29:47 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-04 05:50:33 +0100
commit163534fad9403927e25a55c5473a06a118ce0087 (patch)
tree029e6ab983fde1df98ed3d6866e16baae02a9521
parentdev-libs/flatbuffers: Bump to 23.3.3 (diff)
downloadgentoo-163534fa.tar.gz
gentoo-163534fa.tar.bz2
gentoo-163534fa.zip
dev-python/flatbuffers: Bump to 23.3.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/flatbuffers/Manifest1
-rw-r--r--dev-python/flatbuffers/flatbuffers-23.3.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/flatbuffers/Manifest b/dev-python/flatbuffers/Manifest
index 31a16b3b3200..df91f01b98c5 100644
--- a/dev-python/flatbuffers/Manifest
+++ b/dev-python/flatbuffers/Manifest
@@ -1 +1,2 @@
DIST flatbuffers-23.1.21.gh.tar.gz 2181861 BLAKE2B 6368358c21e677feb466245a746b86cebb6d6a4058bb6d593de81bf3c32ddfb9fd475e4bb225d4529ea106253456a5ed1ee6d024b1e2521e02efef171750f428 SHA512 fa62188f773ad044644a58caf1e25bef417dfdea47c9da8a2ea7f997154b4f3976019e32e73cc533696a3d4e45ec4a8402b6df140878dfa2ff078740d61b4b0f
+DIST flatbuffers-23.3.3.gh.tar.gz 2197401 BLAKE2B be5e3c8ea81ce4b6f2e2c1b2f22e1172434c435f096fa7dade060578c506cff0310e3e2ef0627e26ce2be44f740652eb9a8e1b63578c18f430f7925820f04e66 SHA512 4066c94f2473c7ea16917d29a613e16f840a329089c88e0bdbdb999aef3442ba00abfd2aa92266fa9c067e399dc88e6f0ccac40dc151378857e665638e78bbf0
diff --git a/dev-python/flatbuffers/flatbuffers-23.3.3.ebuild b/dev-python/flatbuffers/flatbuffers-23.3.3.ebuild
new file mode 100644
index 000000000000..a7b6485ad67b
--- /dev/null
+++ b/dev-python/flatbuffers/flatbuffers-23.3.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="RFC 7049 - Concise Binary Object Representation"
+HOMEPAGE="
+ https://github.com/google/flatbuffers/
+ https://pypi.org/project/flatbuffers/
+"
+SRC_URI="
+ https://github.com/google/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${P}/python
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ cd "${WORKDIR}/${P}/tests" || die
+ # zeroes means without benchmarks
+ "${EPYTHON}" py_test.py 0 0 0 false || die
+ "${EPYTHON}" py_flexbuffers_test.py -v || die
+}