summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-03-31 07:41:36 +0200
committerHans de Graaff <graaff@gentoo.org>2022-03-31 07:41:36 +0200
commit16465ca062f1b891be679d22400956220901c195 (patch)
treeed72521fc4247f72cef0a53328120b659d5b4e01
parentdev-ruby/connection_pool: drop 2.2.2 (diff)
downloadgentoo-16465ca0.tar.gz
gentoo-16465ca0.tar.bz2
gentoo-16465ca0.zip
www-servers/puma: drop 5.4.0, 5.6.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--www-servers/puma/Manifest2
-rw-r--r--www-servers/puma/puma-5.4.0.ebuild59
-rw-r--r--www-servers/puma/puma-5.6.1.ebuild59
3 files changed, 0 insertions, 120 deletions
diff --git a/www-servers/puma/Manifest b/www-servers/puma/Manifest
index 5d46b5458a3e..7f1978fba022 100644
--- a/www-servers/puma/Manifest
+++ b/www-servers/puma/Manifest
@@ -1,4 +1,2 @@
-DIST puma-5.4.0.tar.gz 298525 BLAKE2B d93231582cd83519c258093fd9ac5e2b06398133e82e2d350103e7438a4ed1fd9b36f627739dbbad86e839211850c5387be57d5d114835e7e4d99940e842b128 SHA512 032a507d852c555393f401d4e72c358cf8c49d1c93ff7a559969f3d1f84c0b49180cbcee975bb6fea621d034a00874268ff05ae76f91775cc24089de0b4560da
DIST puma-5.5.2.tar.gz 302778 BLAKE2B 5911accde19aaed34cffecc71eb2db02f0d9f9ea7b57437ff7cf7580b0b51245ed68b254778cbdc11bea624b9f192aef0bfa7e24acde73b77290d780ab177933 SHA512 9887b465c6ed2a8e551b15fd161f19a9d2baa96b8eb8e247f13c98df9d34f6097bce81a52e8f88d69088d9b5f8477137af9110b7546afabc53767f337ad00ef8
-DIST puma-5.6.1.tar.gz 308896 BLAKE2B 0fa28fee64da577965c16fa564275760fbb3ebd04ed3eff583e53733b2f674ec6d29c20d2734bd16cb83aca8747ff5049e86d692bb5dd70fa5112a7a2c64ebf4 SHA512 262f17343668f5bf68842664eb6445208755385428151354fdb4039411e339c5c686f684bdb32c974516add3ca86af5693d1e169cf2bf74a8614be3cc06eccb0
DIST puma-5.6.2.tar.gz 309057 BLAKE2B 21a8c02f5fdfd23863a525987b55fbdb5c6b42d550cd8bb4580a78faf0206db42ee9b98409ce7b881dfad43bf5d31d202e228e3a62f0327083f043e22de32b3a SHA512 e08ebb968cb139136d11cfb12f7ebef7f4cafcbf3f26cf229c063aa0e55769ba8c4bc1df1dd9e04a4969d6f423cae1a09ce87e154315c9df80d61ec56b6f96e7
diff --git a/www-servers/puma/puma-5.4.0.ebuild b/www-servers/puma/puma-5.4.0.ebuild
deleted file mode 100644
index 055f299b4a41..000000000000
--- a/www-servers/puma/puma-5.4.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_GEMSPEC="puma.gemspec"
-
-RUBY_FAKEGEM_EXTENSIONS=(ext/puma_http11/extconf.rb)
-RUBY_FAKEGEM_EXTENSION_LIBDIR=lib/puma
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack"
-HOMEPAGE="https://puma.io/"
-SRC_URI="https://github.com/puma/puma/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="3"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE=""
-
-DEPEND+=" dev-libs/openssl:0 test? ( net-misc/curl )"
-RDEPEND+=" dev-libs/openssl:0="
-
-ruby_add_bdepend "virtual/ruby-ssl
- test? ( dev-ruby/rack >=dev-ruby/minitest-5.9:5 >=dev-ruby/test-unit-3.0:2 )"
-
-ruby_add_rdepend "dev-ruby/nio4r:2"
-
-all_ruby_prepare() {
- sed -e '/bundler/ s:^:#:' \
- -e '/prove/ s:^:#:' \
- -e '/stub_const/ s:^:#:' \
- -i test/helper.rb || die
-
- # Avoid tests failing inconsistently
- sed -i -e '/test_bad_client/askip "inconsistent results"' test/test_web_server.rb || die
-
- # Avoid launcher tests since they make assumptions about bundler use
- rm -f test/test_launcher.rb test/test_worker_gem_independence.rb || die
-
- # Skip integration tests since they make a lot of assumptions about
- # the environment
- rm -f test/test_integration_* test/test_preserve_bundler_env.rb|| die
-
- # Avoid test that uses unpackaged stub_const
- sed -i -e '/test_shutdown_with_grace/,/^ end/ s:^:#:' test/test_thread_pool.rb || die
-
- sed -e 's/git ls-files --/find/' \
- -e 's:_relative ": "./:' \
- -i ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-each_ruby_test() {
- einfo "Running test suite"
- ${RUBY} -Ilib:.:test -e "gem 'minitest', '~>5.9'; gem 'test-unit', '~>3.0'; require 'minitest/autorun'; Dir['test/**/*test_*.rb'].each{|f| require f}" || die
-}
diff --git a/www-servers/puma/puma-5.6.1.ebuild b/www-servers/puma/puma-5.6.1.ebuild
deleted file mode 100644
index 808b8fced84f..000000000000
--- a/www-servers/puma/puma-5.6.1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_GEMSPEC="puma.gemspec"
-
-RUBY_FAKEGEM_EXTENSIONS=(ext/puma_http11/extconf.rb)
-RUBY_FAKEGEM_EXTENSION_LIBDIR=lib/puma
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack"
-HOMEPAGE="https://puma.io/"
-SRC_URI="https://github.com/puma/puma/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="3"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-DEPEND+=" dev-libs/openssl:0 test? ( net-misc/curl )"
-RDEPEND+=" dev-libs/openssl:0="
-
-ruby_add_bdepend "virtual/ruby-ssl
- test? ( dev-ruby/localhost dev-ruby/rack >=dev-ruby/minitest-5.9:5 >=dev-ruby/test-unit-3.0:2 )"
-
-ruby_add_rdepend "dev-ruby/nio4r:2"
-
-all_ruby_prepare() {
- sed -e '/bundler/ s:^:#:' \
- -e '/prove/ s:^:#:' \
- -e '/stub_const/ s:^:#:' \
- -i test/helper.rb || die
-
- # Avoid tests failing inconsistently
- sed -i -e '/test_bad_client/askip "inconsistent results"' test/test_web_server.rb || die
-
- # Avoid launcher tests since they make assumptions about bundler use
- rm -f test/test_launcher.rb test/test_worker_gem_independence.rb || die
-
- # Skip integration tests since they make a lot of assumptions about
- # the environment
- rm -f test/test_integration_* test/test_preserve_bundler_env.rb|| die
-
- # Avoid test that uses unpackaged stub_const
- sed -i -e '/test_shutdown_with_grace/,/^ end/ s:^:#:' test/test_thread_pool.rb || die
-
- sed -e 's/git ls-files --/find/' \
- -e 's:_relative ": "./:' \
- -i ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-each_ruby_test() {
- einfo "Running test suite"
- ${RUBY} -Ilib:.:test -e "gem 'minitest', '~>5.9'; gem 'test-unit', '~>3.0'; require 'minitest/autorun'; Dir['test/**/*test_*.rb'].each{|f| require f}" || die
-}