summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-11-08 11:23:55 -0500
committerMatt Turner <mattst88@gentoo.org>2020-11-08 11:26:09 -0500
commit16484703032dce5bd38936631aad4f2f779a8479 (patch)
treefa0cc43370473807c9c79dba59cdb26b390fdfa1
parentdev-libs/satyr: Drop stable keywords (diff)
downloadgentoo-16484703032dce5bd38936631aad4f2f779a8479.tar.gz
gentoo-16484703032dce5bd38936631aad4f2f779a8479.tar.bz2
gentoo-16484703032dce5bd38936631aad4f2f779a8479.zip
dev-libs/satyr: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-libs/satyr/Manifest2
-rw-r--r--dev-libs/satyr/satyr-0.27.ebuild45
-rw-r--r--dev-libs/satyr/satyr-0.30.ebuild99
3 files changed, 0 insertions, 146 deletions
diff --git a/dev-libs/satyr/Manifest b/dev-libs/satyr/Manifest
index 69fd94868088..b78f27a448fc 100644
--- a/dev-libs/satyr/Manifest
+++ b/dev-libs/satyr/Manifest
@@ -1,3 +1 @@
-DIST satyr-0.27.tar.gz 435341 BLAKE2B ade40bc6a1c48e6fc0af7913ff94ed044c63fdb63b8d86ba010bebcfd2098831bc6c7361d116851aee88f49c640d1457dd8953becad60b6ff6dc32deec6c7942 SHA512 7b01cf16489644fbfbe2150477279a94c6fa9b3310edebc84b83bab58d1058df0be478ab6bf4c6910b4168122721dde10d573711abb983b0eb5ccda09cb80710
-DIST satyr-0.30.tar.gz 427940 BLAKE2B 97fedef59cc77b2ae81857c491532552c352a272658d02564d2661d06a4ccc99c18bcd57e5e68e5a612e9e65c5878f19b2f18bbe74066874a7295e2f65d64149 SHA512 ebc6e9c0fd8cd130cf1701573c8ecdadf73fe54efa563759a47f990a91b217cf1dec01045be624d15cfa96b1370ddf2412b0537e57ed628dc27e860be46e21cf
DIST satyr-0.31.tar.gz 428719 BLAKE2B 23c6ea53db261fee366566101c2b0f1e23cf530728332fe752897ee982ffac057b98de3d9a52dbfc64932cdb73aaff7e35c976e7a55e30b4417f3880782f9125 SHA512 a5aafa1ca5f85a0a817c6fa9a3b428672c9f4f529fb7d73a3e819cc836b78c01a0ca44b47317fcdd4a40dc6386688a450bd78564b6e466091cdc9a2c730c3fda
diff --git a/dev-libs/satyr/satyr-0.27.ebuild b/dev-libs/satyr/satyr-0.27.ebuild
deleted file mode 100644
index 8293ade15b76..000000000000
--- a/dev-libs/satyr/satyr-0.27.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit autotools python-r1 toolchain-funcs
-
-DESCRIPTION="Satyr is a collection of low-level algorithms for program failure processing"
-HOMEPAGE="https://github.com/abrt/satyr"
-SRC_URI="https://github.com/abrt/${PN}/archive/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0/3"
-
-IUSE="python"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="python? ( ${PYTHON_DEPS} )
- >=dev-libs/elfutils-0.158
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-src_prepare() {
- default
- ./gen-version || die # Needs to be run before full autoreconf
- eautoreconf
- use python && python_copy_sources
-}
-
-src_configure() {
- local myargs=(
- --localstatedir="${EPREFIX}/var"
- --without-rpm
- # Build breaks without and we aren't supporting Python2 anyway
- --without-python2
- $(usex python "--with-python3" "--without-python3")
- )
-
- econf "${myargs[@]}"
-}
diff --git a/dev-libs/satyr/satyr-0.30.ebuild b/dev-libs/satyr/satyr-0.30.ebuild
deleted file mode 100644
index f654d70e26bb..000000000000
--- a/dev-libs/satyr/satyr-0.30.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit autotools multiprocessing python-r1
-
-DESCRIPTION="Satyr is a collection of low-level algorithms for program failure processing"
-HOMEPAGE="https://github.com/abrt/satyr"
-SRC_URI="https://github.com/abrt/${PN}/archive/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0/4"
-
-IUSE="python"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="python? ( ${PYTHON_DEPS} )
- >=dev-libs/elfutils-0.158
- dev-libs/json-c:=
- dev-libs/nettle:=
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- dev-util/gperf
-"
-
-src_prepare() {
- default
- ./gen-version || die # Needs to be run before full autoreconf
- eautoreconf
- use python && python_copy_sources
-}
-
-src_configure() {
- use python && python_setup
-
- local myargs=(
- --localstatedir="${EPREFIX}/var"
- --without-rpm
- $(usex python "--with-python3" "--without-python3")
- )
-
- if use python; then
- python_configure() {
- econf "${myargs[@]}"
- }
- python_foreach_impl run_in_build_dir python_configure
- else
- econf "${myargs[@]}"
- fi
-}
-
-src_compile() {
- if use python; then
- python_foreach_impl run_in_build_dir default
- else
- default
- fi
-
-}
-
-src_test() {
- local extra_args
-
- # In order to pass --jobs to the test runner
- run_tests() {
- cd tests || die
- emake testsuite
- ./testsuite --jobs=$(makeopts_jobs) ${extra_args[@]} $@
-
- # Only run the python bindings tests for other python impls
- extra_args=('-k' 'python3_bindings.*')
- }
-
- if use python; then
- python_foreach_impl run_in_build_dir run_tests
- else
- run_tests SKIP_PYTHON3=yes
- fi
-}
-
-src_install() {
- if use python; then
- python_install() {
- default
- python_optimize
- }
- python_foreach_impl run_in_build_dir python_install
- else
- default
- fi
-
- find "${D}" -name '*.la' -type f -delete || die
-}