summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-05-03 21:51:26 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-05-03 21:51:38 +0200
commit1656b3dd41e04eaeccb6e5e31a1b721001c911cd (patch)
treee14ab082f03772a068e3c25075c32eda2a3684b1
parentsys-fs/dd-rescue: use sys/random.h for getrandom() decl if present (diff)
downloadgentoo-1656b3dd41e04eaeccb6e5e31a1b721001c911cd.tar.gz
gentoo-1656b3dd41e04eaeccb6e5e31a1b721001c911cd.tar.bz2
gentoo-1656b3dd41e04eaeccb6e5e31a1b721001c911cd.zip
sys-fs/dd-rescue: drop old
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--sys-fs/dd-rescue/Manifest1
-rw-r--r--sys-fs/dd-rescue/dd-rescue-1.46.ebuild83
2 files changed, 0 insertions, 84 deletions
diff --git a/sys-fs/dd-rescue/Manifest b/sys-fs/dd-rescue/Manifest
index fd1c556fc066..380ebad15a86 100644
--- a/sys-fs/dd-rescue/Manifest
+++ b/sys-fs/dd-rescue/Manifest
@@ -1,2 +1 @@
-DIST dd_rescue-1.46.tar.gz 126790 BLAKE2B 027d509349e77fa020757b826184b4a2206c3f5923c797c294ca8caf210cf6af20afa1d518d826413989612295a4365c480d7aa4293686824ee96394cbbe9851 SHA512 efd1bf5d80d4bafa6e6971caa84205dc5df4456a29a9fa3bb56aa984d68675ae3418e8ba3a355906f491f0f2e750c38fd695e37dbd193e554cd41afec3841e28
DIST dd_rescue-1.99.8.tar.bz2 174594 BLAKE2B 51e62989bf6318cb5926f30bc1db746bddd41fb49aab15dc2b1c67e0af079469161d390ba4e1e109d195249b3aace3aa830a3aec14ba534eb47f38c0136f910c SHA512 a230e1df4532671ea631036012dd1e38614e45bed58b00757f0017b0ea60f14ac3bdac07777d175aa4929def593b3c8485e463b1fc25b5067adf4cf3f3ac040d
diff --git a/sys-fs/dd-rescue/dd-rescue-1.46.ebuild b/sys-fs/dd-rescue/dd-rescue-1.46.ebuild
deleted file mode 100644
index 70f8a57d7af3..000000000000
--- a/sys-fs/dd-rescue/dd-rescue-1.46.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit toolchain-funcs flag-o-matic multilib autotools
-
-MY_PN=${PN/-/_}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Similar to dd but can copy from source with errors"
-HOMEPAGE="http://www.garloff.de/kurt/linux/ddrescue/"
-SRC_URI="http://www.garloff.de/kurt/linux/ddrescue/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~mips ppc ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="cpu_flags_x86_avx2 lzo cpu_flags_x86_sse4_2 static xattr"
-
-RDEPEND="lzo? ( dev-libs/lzo )
- xattr? ( sys-apps/attr )"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${MY_PN}
-
-src_prepare() {
- sed -i \
- -e 's:-ldl:$(LDFLAGS) -ldl:' \
- -e 's:-shared:$(CFLAGS) $(LDFLAGS) -shared:' \
- Makefile
- eautoreconf
-}
-
-src_configure() {
- use static && append-ldflags -static
- # OpenSSL is only used by a random helper tool we don't install.
- ac_cv_header_attr_xattr_h=$(usex xattr) \
- ac_cv_header_openssl_evp_h=no \
- ac_cv_lib_lzo2_lzo1x_1_compress=$(usex lzo) \
- econf
-}
-
-_emake() {
- local arch
- case ${ARCH} in
- x86) arch=i386;;
- amd64) arch=x86_64;;
- arm) arch=arm;;
- arm64) arch=aarch64;;
- esac
-
- local os=$(usex kernel_linux Linux IDK)
-
- # The Makefile is a mess. Override a few vars rather than patch it.
- emake \
- MACH="${arch}" \
- OS="${os}" \
- HAVE_SSE42=$(usex cpu_flags_x86_sse4_2 1 0) \
- HAVE_AVX2=$(usex cpu_flags_x86_avx2 1 0) \
- RPM_OPT_FLAGS="${CFLAGS} ${CPPFLAGS}" \
- CFLAGS_OPT='$(CFLAGS)' \
- LDFLAGS="${LDFLAGS} -Wl,-rpath,${EPREFIX}/usr/$(get_libdir)/${PN}" \
- CC="$(tc-getCC)" \
- "$@"
-}
-
-src_compile() {
- _emake
-}
-
-src_test() {
- _emake check
-}
-
-src_install() {
- # easier to install by hand than trying to make sense of the Makefile.
- dobin dd_rescue
- dodir /usr/$(get_libdir)/${PN}
- cp -pPR libddr_*.so "${ED}"/usr/$(get_libdir)/${PN}/ || die
- dodoc README.dd_rescue
- doman dd_rescue.1
- use lzo && doman ddr_lzo.1
-}