summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-18 08:42:33 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-18 08:53:39 +0200
commit1657a539b1cd15462f8995e7fa1eb978409b49d1 (patch)
treec0755a4556a120e32b5e9cf7e121cd7a9828cfbd
parentsys-libs/libunwind: Add release candidate for testing (only) on riscv (diff)
downloadgentoo-1657a539b1cd15462f8995e7fa1eb978409b49d1.tar.gz
gentoo-1657a539b1cd15462f8995e7fa1eb978409b49d1.tar.bz2
gentoo-1657a539b1cd15462f8995e7fa1eb978409b49d1.zip
dev-python/rope: Bump to 0.20.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rope/Manifest1
-rw-r--r--dev-python/rope/rope-0.20.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/rope/Manifest b/dev-python/rope/Manifest
index cb27bf182134..0398fbd3bcde 100644
--- a/dev-python/rope/Manifest
+++ b/dev-python/rope/Manifest
@@ -1 +1,2 @@
DIST rope-0.19.0.tar.gz 252902 BLAKE2B 41760dc29d26558bdf5f296238b7d59ca949530826953fe5592b763b8d24fb49a90a56b9c7d0e3475daf145185987116a7dd0cbfba74829abfa4bf6a57c79937 SHA512 fd41777d76861837479bf0777ea42cc052eed7ba396bc4531a0c7f101b05b1c5a57c300950b7a3c8a2902e28ff049d146646f83f8a8a447ab9ccd7cd8aa48110
+DIST rope-0.20.0.tar.gz 257356 BLAKE2B 054ab1fd1b8ede2576c83eada588fb04827cfef570b2cd30461e1b12b3a42d601aa1e60bf1428a54b4d74127a561fce3f34f064b8018943fd1e6fe5c03764a5a SHA512 d84e2da66712da927b6dcf0ea40c50627002baebfd93585dbecda32e6ce0682fdf13577769b12890d31c4f1022795ab98c2dba25aa23a8b434762dbbcab974b8
diff --git a/dev-python/rope/rope-0.20.0.ebuild b/dev-python/rope/rope-0.20.0.ebuild
new file mode 100644
index 000000000000..b734b2e0002c
--- /dev/null
+++ b/dev-python/rope/rope-0.20.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="https://github.com/python-rope/rope"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+# Dependency for docbuild documentation which is not noted in
+# setup.py, using standard docutils builds docs successfully.
+BDEPEND="
+ doc? ( dev-python/docutils[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest-timeout[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_compile_all() {
+ if use doc; then
+ pushd docs > /dev/null || die
+ mkdir build || die
+ local i
+ for i in ./*.rst; do
+ rst2html.py $i > ./build/${i/rst/html} || die
+ done
+ popd > /dev/null || die
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/. )
+ distutils-r1_python_install_all
+}