summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-06-04 09:00:58 +0200
committerPatrice Clement <monsieurp@gentoo.org>2020-06-04 09:01:01 +0200
commit165a96a564bc5f7cee0719084da76359ce66cc90 (patch)
tree7c4cbdf32b1763219c0b2f6a037c5f5212e0b485
parentsys-apps/crazydiskinfo: clean up old. (diff)
downloadgentoo-165a96a5.tar.gz
gentoo-165a96a5.tar.bz2
gentoo-165a96a5.zip
dev-lang/micropython: honor CFLAGS and LDFLAGS.
Closes: https://bugs.gentoo.org/726902 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--dev-lang/micropython/micropython-1.11.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-lang/micropython/micropython-1.11.ebuild b/dev-lang/micropython/micropython-1.11.ebuild
index a7361e69166f..e0c69a12c7ab 100644
--- a/dev-lang/micropython/micropython-1.11.ebuild
+++ b/dev-lang/micropython/micropython-1.11.ebuild
@@ -31,18 +31,18 @@ src_compile() {
-e 's#\/usr\/local#\/usr#g;' \
Makefile || die
- emake CC="$(tc-getCC)" axtls
- emake CC="$(tc-getCC)"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" axtls
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
}
src_test() {
cd ports/unix || die
- emake CC="$(tc-getCC)" test
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" test
}
src_install() {
pushd ports/unix > /dev/null || die
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" DESTDIR="${D}" install
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" DESTDIR="${D}" install
popd > /dev/null || die
# remove .git files