summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-07-15 08:53:24 +0200
committerHans de Graaff <graaff@gentoo.org>2022-07-15 10:09:19 +0200
commit1668f679eb4842cc4886fbf1e1fa80fc40b8c827 (patch)
treeb6242d75f43596e9dfe14f3576b2d5eac0f0cc3c
parentdev-ruby/coercible: drop 1.0.0-r1 (diff)
downloadgentoo-1668f679eb4842cc4886fbf1e1fa80fc40b8c827.tar.gz
gentoo-1668f679eb4842cc4886fbf1e1fa80fc40b8c827.tar.bz2
gentoo-1668f679eb4842cc4886fbf1e1fa80fc40b8c827.zip
dev-ruby/loquacious: EAPI 7 -> 8, add ruby30, ruby31
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/loquacious/loquacious-1.9.1-r4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/loquacious/loquacious-1.9.1-r4.ebuild b/dev-ruby/loquacious/loquacious-1.9.1-r4.ebuild
new file mode 100644
index 000000000000..63f45cc4568d
--- /dev/null
+++ b/dev-ruby/loquacious/loquacious-1.9.1-r4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Descriptive configuration files for Ruby written in Ruby"
+HOMEPAGE="https://github.com/TwP/loquacious"
+
+IUSE=""
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+all_ruby_prepare() {
+ sed -i -e 's/be_true/be true/' -e 's/be_false/be false/' spec/*_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+}