summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-06 09:22:44 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-06 09:41:14 +0200
commit166c3dfd15e0f5b7083da6425caa22d2edaf213d (patch)
tree32f9d6f3a9e7503df09bb1af2e1fce740bfd4349
parentdev-lang/cfortran: add bug tags (diff)
downloadgentoo-166c3dfd15e0f5b7083da6425caa22d2edaf213d.tar.gz
gentoo-166c3dfd15e0f5b7083da6425caa22d2edaf213d.tar.bz2
gentoo-166c3dfd15e0f5b7083da6425caa22d2edaf213d.zip
dev-util/stripe-mock: Bump to 0.126.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-util/stripe-mock/Manifest1
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.126.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/Manifest b/dev-util/stripe-mock/Manifest
index 8464a07aed39..5820b163dd40 100644
--- a/dev-util/stripe-mock/Manifest
+++ b/dev-util/stripe-mock/Manifest
@@ -1,2 +1,3 @@
DIST stripe-mock-0.124.0.tar.gz 519495 BLAKE2B 66bd344a112bad3793490f3b5f08728db1a6f1d80cbe85562c121a92ee3c3d5e54f7145e5d6d4efeecb079cc6efde4d3c0d9e7009e9e800f3566511b3be04ed3 SHA512 347633be263bfef5a744a46d53c4218491752960acd59447006caba0ae40f8c1a7d17f754c4b6b2d08506f4c98b19fc3b8b49ef3e0d7c2869a92984be67b7a7f
DIST stripe-mock-0.125.0.tar.gz 528175 BLAKE2B cb58d9eb14faa6957a9d0ddc8eadb4175eefc139e6071bfc9c21d9fb6ed18091f5a6622fd43cfee98df43c5c745d24c820d1ac9e03fb0a7f0f8aabe3b516faf7 SHA512 bba161df4f6e5a6f69811682af3bd53b1cfdbce55077c1fe5b2d4474c4f5c7bca4f86a71a058ba2808338048a215ecba54334697699ad2b5adea4faf2f4c83e6
+DIST stripe-mock-0.126.0.tar.gz 543235 BLAKE2B 4bf4a121f3077dd657b7cb2c5bd909c84a0f14cb716c8f9d4b3119b2143ca709f0b9adc3fecc90e0517515ac1422bfae8f1646d7d4d23ebd74bac811800c65fc SHA512 60e459617278a6bf5688667d5bbd64f6f645838f39504e518c68683d9d5acfe2239be98daaf657f23e09bc5043967a6273838d801d688373765734858e8274ae
diff --git a/dev-util/stripe-mock/stripe-mock-0.126.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.126.0.ebuild
new file mode 100644
index 000000000000..586567a061dc
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.126.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ emake build
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin stripe-mock
+ einstalldocs
+}