summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-12 14:38:00 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-12 15:05:27 +0200
commit167f5996f7d796f4bc002e7114f93a9e83f4ab54 (patch)
tree4106566e7ec5262afca97e5f12ced4342dfb62c7
parentdev-python/cramjam: Run cargo test as well (diff)
downloadgentoo-167f5996f7d796f4bc002e7114f93a9e83f4ab54.tar.gz
gentoo-167f5996f7d796f4bc002e7114f93a9e83f4ab54.tar.bz2
gentoo-167f5996f7d796f4bc002e7114f93a9e83f4ab54.zip
dev-python/jellyfish: Run cargo test as well
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jellyfish/jellyfish-1.0.3.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/jellyfish/jellyfish-1.0.3.ebuild b/dev-python/jellyfish/jellyfish-1.0.3.ebuild
index 210b729bc9d2..78234653506d 100644
--- a/dev-python/jellyfish/jellyfish-1.0.3.ebuild
+++ b/dev-python/jellyfish/jellyfish-1.0.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -83,3 +83,7 @@ KEYWORDS="amd64 arm64 ~ppc64 ~riscv x86"
QA_FLAGS_IGNORED="usr/lib.*/py.*/site-packages/jellyfish/_rustyfish.*.so"
distutils_enable_tests pytest
+
+python_test_all() {
+ cargo_src_test
+}