summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-09-12 09:56:59 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-09-12 10:04:18 +0200
commit16a09ec399ce0d27f5335b4cc2cc8d7449bb9242 (patch)
treefaa767f9c625ecef80b293418f1a855538b6b93d
parentapp-benchmarks/acovea-gtk: Remove last-rited pkg (diff)
downloadgentoo-16a09ec399ce0d27f5335b4cc2cc8d7449bb9242.tar.gz
gentoo-16a09ec399ce0d27f5335b4cc2cc8d7449bb9242.tar.bz2
gentoo-16a09ec399ce0d27f5335b4cc2cc8d7449bb9242.zip
app-benchmarks/acovea: Remove last-rited pkg
Closes: https://bugs.gentoo.org/626668 Closes: https://bugs.gentoo.org/626666 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--app-benchmarks/acovea/Manifest1
-rw-r--r--app-benchmarks/acovea/acovea-5.1.1-r2.ebuild45
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-asneeded.patch16
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-free-fix.patch12
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-gcc44.patch14
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-glibc-212.patch12
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-libevocosm.patch119
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-underlinking.patch10
-rw-r--r--app-benchmarks/acovea/metadata.xml5
-rw-r--r--profiles/package.mask1
10 files changed, 0 insertions, 235 deletions
diff --git a/app-benchmarks/acovea/Manifest b/app-benchmarks/acovea/Manifest
deleted file mode 100644
index fd1337d7ba7c..000000000000
--- a/app-benchmarks/acovea/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST libacovea-5.1.1.tar.gz 363048 BLAKE2B 61f894e99f3678f3b676e0926ff6d7a6bd376a654ad109d5b7f676d7053e4b975d90e0ac01d820b8498a6992db1cbd2fb5443fbe3871ef3f86bee280fd808352 SHA512 47ac88d713004ccdbf31c29bd5ead3e9d869eee262f2c12e12bf9aa7ec177d2c1e175908704cd5463b314752692edcd98d69408dbeb5873caff1745535a3a365
diff --git a/app-benchmarks/acovea/acovea-5.1.1-r2.ebuild b/app-benchmarks/acovea/acovea-5.1.1-r2.ebuild
deleted file mode 100644
index d00773301c07..000000000000
--- a/app-benchmarks/acovea/acovea-5.1.1-r2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-
-DESCRIPTION="Analysis of Compiler Options via Evolutionary Algorithm"
-HOMEPAGE="http://www.coyotegulch.com/products/acovea/"
-SRC_URI="http://www.coyotegulch.com/distfiles/lib${P}.tar.gz"
-S="${WORKDIR}/lib${P}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-
-RDEPEND="
- >=dev-libs/libcoyotl-3.1.0:=
- >=dev-libs/libevocosm-3.3.0:=
- dev-libs/expat:="
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-asneeded.patch
- "${FILESDIR}"/${P}-free-fix.patch
- "${FILESDIR}"/${P}-gcc44.patch
- "${FILESDIR}"/${P}-glibc-212.patch
- "${FILESDIR}"/${P}-underlinking.patch
- "${FILESDIR}"/${P}-libevocosm.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf --disable-static
-}
-
-src_install() {
- default
-
- find "${ED}" -name '*.la' -delete || die
-}
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-asneeded.patch b/app-benchmarks/acovea/files/acovea-5.1.1-asneeded.patch
deleted file mode 100644
index 3a887c15888c..000000000000
--- a/app-benchmarks/acovea/files/acovea-5.1.1-asneeded.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/cmdline/Makefile.am
-+++ b/cmdline/Makefile.am
-@@ -7,4 +7,4 @@
-
- runacovea_SOURCES = runacovea.cpp
-
--LIBS = -L../libacovea -lacovea -lcoyotl -levocosm -lexpat
-+LIBS = -L../libacovea -lacovea -lcoyotl -levocosm
---- a/libacovea/Makefile.am
-+++ b/libacovea/Makefile.am
-@@ -16,3 +16,5 @@
- library_include_HEADERS = $(h_sources)
-
- DEFS=-I. -I$(srcdir)
-+
-+LIBS = -lexpat
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-free-fix.patch b/app-benchmarks/acovea/files/acovea-5.1.1-free-fix.patch
deleted file mode 100644
index e20bfa3eb98f..000000000000
--- a/app-benchmarks/acovea/files/acovea-5.1.1-free-fix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/benchmarks/treebench.c
-+++ b/benchmarks/treebench.c
-@@ -201,8 +201,8 @@
- if (page->m_links[n] != NULL)
- recursive_destroy_page(page->m_links[n]);
-
-- free(page);
- }
-+ free(page);
- }
-
- static void free_btree(btree * btree)
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-gcc44.patch b/app-benchmarks/acovea/files/acovea-5.1.1-gcc44.patch
deleted file mode 100644
index 2207f4616426..000000000000
--- a/app-benchmarks/acovea/files/acovea-5.1.1-gcc44.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/libacovea/acovea.cpp
-+++ b/libacovea/acovea.cpp
-@@ -44,10 +44,11 @@
- #include <unistd.h>
- #include <sys/types.h>
- #include <sys/wait.h>
-
- #include <vector>
-+#include <cstdio>
- #include <cstring>
- #include <sstream>
- #include <iostream>
- #include <iomanip>
- #include <stdexcept>
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-glibc-212.patch b/app-benchmarks/acovea/files/acovea-5.1.1-glibc-212.patch
deleted file mode 100644
index 996cb5ebc82e..000000000000
--- a/app-benchmarks/acovea/files/acovea-5.1.1-glibc-212.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-http://bugs.gentoo.org/336260
-
---- a/libacovea/acovea.cpp
-+++ b/libacovea/acovea.cpp
-@@ -44,6 +44,7 @@
- #include <unistd.h>
- #include <sys/types.h>
- #include <sys/wait.h>
-+#include <sys/stat.h>
-
- #include <vector>
- #include <cstring>
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-libevocosm.patch b/app-benchmarks/acovea/files/acovea-5.1.1-libevocosm.patch
deleted file mode 100644
index 46ddb5fe4d97..000000000000
--- a/app-benchmarks/acovea/files/acovea-5.1.1-libevocosm.patch
+++ /dev/null
@@ -1,119 +0,0 @@
---- a/libacovea/acovea.cpp
-+++ b/libacovea/acovea.cpp
-@@ -86,7 +86,7 @@
- // randomize settings of this option
- void option::randomize()
- {
-- m_enabled = (g_random.get_rand_real2() < 0.5);
-+ m_enabled = (g_random.get_real() < 0.5);
- }
-
- // mutate this option
-@@ -246,7 +246,7 @@
- m_step = 1;
-
- // possibly adjust value to randomize populations
-- size_t choice = g_random.get_rand_index(3);
-+ size_t choice = g_random.get_index(3);
-
- switch (choice)
- {
-@@ -304,12 +304,12 @@
- void tuning_option::mutate()
- {
- // select our mutation
-- if (g_random.get_rand_real2() < 0.5)
-+ if (g_random.get_real() < 0.5)
- option::mutate();
- else
- {
- // mutate value of this option, up or down randomly
-- if (g_random.get_rand_real2() < 0.5)
-+ if (g_random.get_real() < 0.5)
- m_value -= m_step;
- else
- m_value += m_step;
-@@ -335,7 +335,7 @@
- enum_option::enum_option(const vector<string> & a_choices, bool a_enabled)
- : option(a_enabled),
- m_choices(a_choices),
-- m_setting(g_random.get_rand_index(a_choices.size()))
-+ m_setting(g_random.get_index(a_choices.size()))
- {
- // nada
- }
-@@ -344,7 +344,7 @@
- enum_option::enum_option(const char ** a_choices, size_t a_num_choices, bool a_enabled)
- : option(a_enabled),
- m_choices(),
-- m_setting(g_random.get_rand_index(a_num_choices))
-+ m_setting(g_random.get_index(a_num_choices))
- {
- for (int n = 0; n < a_num_choices; ++n)
- m_choices.push_back(string(a_choices[n]));
-@@ -369,7 +369,7 @@
- token = strtok(NULL,"|");
- }
-
-- m_setting = g_random.get_rand_index(m_choices.size());
-+ m_setting = g_random.get_index(m_choices.size());
-
- free(choices);
- }
-@@ -407,17 +407,17 @@
- void enum_option::randomize()
- {
- // randomize enabled
-- m_enabled = (g_random.get_rand_real2() < 0.5);
-+ m_enabled = (g_random.get_real() < 0.5);
-
- // randomize setting
-- m_setting = g_random.get_rand_index(m_choices.size());
-+ m_setting = g_random.get_index(m_choices.size());
- }
-
- // mutate this option
- void enum_option::mutate()
- {
- // select our mutation
-- if (g_random.get_rand() & 1)
-+ if (g_random.get_real() < 0.5)
- option::mutate();
- else
- {
-@@ -435,7 +435,7 @@
-
- // find a different setting
- while (new_setting == m_setting)
-- new_setting = g_random.get_rand_index(m_choices.size());
-+ new_setting = g_random.get_index(m_choices.size());
-
- m_setting = new_setting;
- }
-@@ -915,7 +915,7 @@
- // randomly pick an option from one of the parents
- for (int n = 0; n < a_parent1.size(); ++n)
- {
-- if (g_random.get_rand() & 1)
-+ if (g_random.get_real() < 0.5)
- child.push_back(a_parent1[n]->clone());
- else
- child.push_back(a_parent2[n]->clone());
-@@ -931,7 +931,7 @@
- {
- for (int n = 0; n < a_options.size(); ++n)
- {
-- if (g_random.get_rand_real2() < a_mutation_chance)
-+ if (g_random.get_real() < a_mutation_chance)
- a_options[n]->mutate();
- }
- }
-@@ -1096,7 +1096,7 @@
- acovea_organism * child;
-
- // do we crossover?
-- if (g_random.get_rand_real2() <= m_crossover_rate)
-+ if (g_random.get_real() <= m_crossover_rate)
- {
- // select a second parent
- size_t second_index = first_index;
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-underlinking.patch b/app-benchmarks/acovea/files/acovea-5.1.1-underlinking.patch
deleted file mode 100644
index 06ef410b6cc6..000000000000
--- a/app-benchmarks/acovea/files/acovea-5.1.1-underlinking.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff --git a/cmdline/Makefile.am b/cmdline/Makefile.am
-index f3c763e..8e18d9c 100644
---- a/cmdline/Makefile.am
-+++ b/cmdline/Makefile.am
-@@ -7,4 +7,4 @@ bin_PROGRAMS = runacovea
-
- runacovea_SOURCES = runacovea.cpp
-
--LIBS = -L../libacovea -lacovea -lcoyotl -levocosm
-+LIBS = -L../libacovea -lacovea -lcoyotl -levocosm -lbrahe
diff --git a/app-benchmarks/acovea/metadata.xml b/app-benchmarks/acovea/metadata.xml
deleted file mode 100644
index 115e9d64a669..000000000000
--- a/app-benchmarks/acovea/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 3bd29f091366..82d892175f3c 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -212,7 +212,6 @@ dev-perl/Perlbal-XS-HTTPHeaders
dev-libs/libbrahe
dev-libs/libcoyotl
dev-libs/libevocosm
-app-benchmarks/acovea
# David Seifert <soap@gentoo.org> (2021-08-04)
# Last release over 4 years ago, upstream pretty much dead, the