summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 18:46:21 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 18:59:46 +0100
commit16a7696469ab327f66a8ad66a513e6299b5380bb (patch)
treebb3d67e2642e22121710b7abd74a6a64458826a1
parentdev-python/django-debug-toolbar: Migrate to PEP517 build (diff)
downloadgentoo-16a76964.tar.gz
gentoo-16a76964.tar.bz2
gentoo-16a76964.zip
dev-python/django-otp: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/django-otp/Manifest2
-rw-r--r--dev-python/django-otp/django-otp-1.1.1.ebuild35
-rw-r--r--dev-python/django-otp/django-otp-1.1.2.ebuild35
3 files changed, 0 insertions, 72 deletions
diff --git a/dev-python/django-otp/Manifest b/dev-python/django-otp/Manifest
index cc553fd76403..e91895f1c7ed 100644
--- a/dev-python/django-otp/Manifest
+++ b/dev-python/django-otp/Manifest
@@ -1,3 +1 @@
-DIST django-otp-1.1.1.gh.tar.gz 71526 BLAKE2B d68c0fe99c5437d08a8a0a433b4d6f41f0068047e3899efbb24234696c3494a064982aabc02d2788662d516235413bfc804f76cf5ffa1c608d3aa61927e2fad3 SHA512 5946cd64fd0f52dac5ef9fb192f8ecf78e99c96fe7e3223b41c68d96e249f6727149ef58a2dbf48024452e078f5f93c1f9edb9db2a25def5cbb3992c16aac18c
-DIST django-otp-1.1.2.gh.tar.gz 72639 BLAKE2B ba30e8d6c9982010dd9a627a810b9bc36474c571cbb6eb756d45b617338f18b7ceb024f88baeb7ceb6dbd76b3f5cf9ed53ebabd9dba435b6ab6cc3bdba092fa4 SHA512 85b34f9a36632ca44e4f7a3f11d1fd795bf65f909c0b6e4735afd56f06d754f7f28b43ccc851cb86c7330919978d3e2cb793111e50030273056da0231ee0e3ca
DIST django-otp-1.1.3.gh.tar.gz 72736 BLAKE2B 1dc0570d65f0ac8de417260ce2fb895dbae7f5f2cd106b0dd969bc04df207cd4aa9ccf8be2bfc74475bb3ec6abcd451b7fa1c32fd0f7f0d3b27afca212f3b8ed SHA512 4e8b38c393fe29b2fa91e3f1f70abd2cc671dcf760e2e2bf8f738e04fc43a6e7f54229f298f7f2611988dffc40b4450ed1ab910ce9e9995b205dff1b3c90a977
diff --git a/dev-python/django-otp/django-otp-1.1.1.ebuild b/dev-python/django-otp/django-otp-1.1.1.ebuild
deleted file mode 100644
index 892604810582..000000000000
--- a/dev-python/django-otp/django-otp-1.1.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
-HOMEPAGE="https://github.com/django-otp/django-otp/"
-SRC_URI="
- https://github.com/django-otp/django-otp/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/django-2.2[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- $(python_gen_impl_dep sqlite)
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/qrcode[${PYTHON_USEDEP}]
- ${RDEPEND}
- )"
-
-python_test() {
- local -x PYTHONPATH=test:${PYTHONPATH}
- local -x DJANGO_SETTINGS_MODULE=test_project.settings
- django-admin test -v 2 django_otp || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/django-otp/django-otp-1.1.2.ebuild b/dev-python/django-otp/django-otp-1.1.2.ebuild
deleted file mode 100644
index 892604810582..000000000000
--- a/dev-python/django-otp/django-otp-1.1.2.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
-HOMEPAGE="https://github.com/django-otp/django-otp/"
-SRC_URI="
- https://github.com/django-otp/django-otp/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/django-2.2[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- $(python_gen_impl_dep sqlite)
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/qrcode[${PYTHON_USEDEP}]
- ${RDEPEND}
- )"
-
-python_test() {
- local -x PYTHONPATH=test:${PYTHONPATH}
- local -x DJANGO_SETTINGS_MODULE=test_project.settings
- django-admin test -v 2 django_otp || die "Tests fail with ${EPYTHON}"
-}