summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 13:13:24 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 13:17:41 +0100
commit16c0ec578be4810a2aae44ae8f81d3a56a3d6c72 (patch)
tree758e80636601818ffa16b5ef05285dbdcbfe8d7e
parentdev-python/oslotest: Migrate to PEP517 build (diff)
downloadgentoo-16c0ec57.tar.gz
gentoo-16c0ec57.tar.bz2
gentoo-16c0ec57.zip
dev-python/nbsphinx: Migrate to PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/nbsphinx/nbsphinx-0.8.8-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/nbsphinx/nbsphinx-0.8.8-r1.ebuild b/dev-python/nbsphinx/nbsphinx-0.8.8-r1.ebuild
new file mode 100644
index 000000000000..841a5816068f
--- /dev/null
+++ b/dev-python/nbsphinx/nbsphinx-0.8.8-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Notebook Tools for Sphinx"
+HOMEPAGE="https://github.com/spatialaudio/nbsphinx/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.8[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"