summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-03-26 19:58:22 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-03-26 20:45:19 +0100
commit16c80013a85ac637a60c6512f62e9c1706bf5599 (patch)
tree469726c68d72c9d2228212ee3554ee1226cb2eec
parentmedia-video/mpv: drop old version (diff)
downloadgentoo-16c80013a85ac637a60c6512f62e9c1706bf5599.tar.gz
gentoo-16c80013a85ac637a60c6512f62e9c1706bf5599.tar.bz2
gentoo-16c80013a85ac637a60c6512f62e9c1706bf5599.zip
dev-lua/lgi: drop old version
Dropping old version, which does not support slotted lua. Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-lua/lgi/lgi-0.9.2.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-lua/lgi/lgi-0.9.2.ebuild b/dev-lua/lgi/lgi-0.9.2.ebuild
deleted file mode 100644
index aa535b2deae0..000000000000
--- a/dev-lua/lgi/lgi-0.9.2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-VIRTUALX_REQUIRED="manual"
-
-inherit eutils toolchain-funcs flag-o-matic virtualx
-
-DESCRIPTION="Lua bindings using gobject-introspection"
-HOMEPAGE="https://github.com/pavouk/lgi"
-SRC_URI="https://github.com/pavouk/lgi/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm ppc ppc64 x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="virtual/pkgconfig"
-RDEPEND=">=dev-lang/lua-5.1:0=
- dev-libs/gobject-introspection
- dev-libs/glib
- dev-libs/libffi:0="
-DEPEND="${RDEPEND}
- test? (
- x11-libs/cairo[glib]
- x11-libs/gtk+[introspection]
- ${VIRTUALX_DEPEND}
- )"
-
-src_prepare() {
- default
-
- sed -i \
- -e "s:^LUA_LIBDIR.*$:LUA_LIBDIR = $($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua):" \
- -e "s:^LUA_SHAREDIR.*$:LUA_SHAREDIR = $($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua):" \
- "${S}"/lgi/Makefile || die "sed failed"
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" COPTFLAGS="-Wall -Wextra ${CFLAGS}" LIBFLAG="-shared ${LDFLAGS}"
-}
-
-src_test() {
- virtx emake CC="$(tc-getCC)" COPTFLAGS="-Wall -Wextra ${CFLAGS}" LIBFLAG="-shared ${LDFLAGS}" check
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- docompress -x /usr/share/doc/${PF}
- dodoc README.md
- dodoc -r docs/*
- if use examples; then
- dodoc -r samples
- fi
-}