summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2020-02-12 19:15:10 +0100
committerTupone Alfredo <tupone@gentoo.org>2020-02-12 19:15:10 +0100
commit16ede39343aeead19a64b86967da3401faf66018 (patch)
treeaf37b0aeb3d4730ac311f3cfefbe7a37f5643c4e
parentx11-themes/gnustep-neos-theme: [QA] inherit vcs-clean.eclass directly (diff)
downloadgentoo-16ede393.tar.gz
gentoo-16ede393.tar.bz2
gentoo-16ede393.zip
app-misc/geneweb: fix build with ocaml-4.09
Bugs: https://bugs.gentoo.org/707312 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--app-misc/geneweb/Manifest1
-rw-r--r--app-misc/geneweb/files/geneweb-6.08.01-gentoo.patch30
-rw-r--r--app-misc/geneweb/geneweb-6.08.01.ebuild79
3 files changed, 110 insertions, 0 deletions
diff --git a/app-misc/geneweb/Manifest b/app-misc/geneweb/Manifest
index ce02b368b59e..70d8a86db7c0 100644
--- a/app-misc/geneweb/Manifest
+++ b/app-misc/geneweb/Manifest
@@ -1,2 +1,3 @@
DIST geneweb-6.08-ocaml-4.patch.gz 22259 BLAKE2B c3471b44bae06db04f51f4fbfacaf5d93388f79673686d0fdd988df482f836bd49f853c5acb3b94c39f890b7d9bd8d118b4042100c466a06a2e57227da9eee3b SHA512 333a9ca899bf454e1c534f6c890b5cbe842821573b39e9d0e432cfbdf30dbe3a495a5ecb5a9b4a00882ee51bbb3ec1ca4b417e34050a7f84e434d0424c126def
+DIST geneweb-6.08.01.tar.gz 1796215 BLAKE2B 4b7d05126d244984b62ebadda3419ba8cf97326ac3103c73ca5433a8f9edeab8acd968d05942d299e70127bcf75efe5cb9a9af9f7d97ec08fd9a8a6a5aae100d SHA512 54e1ed05e540f1de167c66dee46976a8324a37ca36a9dfd6ab03105fe925053c570842e1a263499fd8bd7aecfebac8f9596b1573fcec1e104e3892337376f84d
DIST geneweb-6.08.tar.gz 1791450 BLAKE2B 35fcd0a4087892b992b87dd4fb54b458be0e300042a237458fdeea9a4a9b8649f93261d896d6b7ad19b681b95b343013d99d99027d86b1796f74cab916178d32 SHA512 7f1d552342e8a5b05961be75c1afb768853f22cc7eb4477fa63d6a3af29ea852862ce043ae89cd1589ede20fe561ad7d77ab757cc1ecb26ce1473f0e3621b835
diff --git a/app-misc/geneweb/files/geneweb-6.08.01-gentoo.patch b/app-misc/geneweb/files/geneweb-6.08.01-gentoo.patch
new file mode 100644
index 000000000000..0226a05904a6
--- /dev/null
+++ b/app-misc/geneweb/files/geneweb-6.08.01-gentoo.patch
@@ -0,0 +1,30 @@
+--- a/setup/setup.ml 2007-08-07 19:25:13.000000000 +0200
++++ b/setup/setup.ml 2007-08-07 19:24:59.000000000 +0200
+@@ -5,8 +5,8 @@
+
+ value port = ref 2316;
+ value default_lang = ref "en";
+-value setup_dir = ref ".";
+-value bin_dir = ref "";
++value setup_dir = ref "/usr/share/geneweb";
++value bin_dir = ref "/usr/bin";
+ value lang_param = ref "";
+ value only_file = ref "";
+
+--- a/tools/Makefile.inc.unix 2017-03-06 08:15:45.334667626 +0100
++++ b/tools/Makefile.inc.unix 2017-03-06 08:16:10.162223399 +0100
+@@ -6,11 +6,11 @@
+ CAMLP5F=-DUNIX
+ CAMLP5D=+camlp5
+ LIBUNIX=-cclib -lunix
+-OCAMLC=ocamlc.opt -w -3 -warn-error +a-52 -safe-string
+-OCAMLOPT=ocamlopt.opt -w -3 -warn-error +a-52 -safe-string
++OCAMLC=ocamlc.opt -w -3 -safe-string
++OCAMLOPT=ocamlopt.opt -w -3 -safe-string
+ OCAMLI=
+ OCAMLD=
+-STRIP=strip
++STRIP=true
+ RM=/bin/rm -f
+ EXE=
+ STATIC=-ccopt -static
diff --git a/app-misc/geneweb/geneweb-6.08.01.ebuild b/app-misc/geneweb/geneweb-6.08.01.ebuild
new file mode 100644
index 000000000000..70389b658f0a
--- /dev/null
+++ b/app-misc/geneweb/geneweb-6.08.01.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils
+
+GITID=9641e494cd85fb1b7baba32412d120da38234ba2
+
+DESCRIPTION="Genealogy software program with a Web interface"
+HOMEPAGE="https://github.com/geneanet/geneweb"
+SRC_URI="https://github.com/geneweb/geneweb/archive/${GITID}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+RESTRICT="strip"
+
+RDEPEND="dev-lang/ocaml[ocamlopt?]
+ dev-ml/camlp5[ocamlopt?]
+ acct-user/geneweb
+ acct-group/geneweb"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${PN}-6.08-parallellbuild.patch )
+
+S="${WORKDIR}"/${PN}-${GITID}
+
+src_compile() {
+ if use ocamlopt; then
+ emake
+ else
+ emake OCAMLC=ocamlc OCAMLOPT=ocamlopt out
+ # If using bytecode we dont want to strip the binary as it would remove
+ # the bytecode and only leave ocamlrun...
+ fi
+}
+
+src_install() {
+ dodoc ICHANGES
+ emake new_distrib
+ emake wrappers
+ # Install doc
+ cd distribution
+ dodoc CHANGES.txt
+ # Install binaries
+ cd gw
+ dobin gwc gwc1 gwc2 consang gwd gwu update_nldb ged2gwb ged2gwb2 gwb2ged gwsetup
+ insinto /usr/lib/${PN}
+ doins -r gwtp_tmp/*
+ dodoc a.gwf
+ insinto /usr/share/${PN}
+ doins -r etc images lang setup gwd.arg only.txt
+
+ cd ../..
+
+ # Install binaries
+ dobin src/check_base
+ # Install manpages
+ doman man/*
+
+ # Install doc
+ dodoc -r contrib
+ docompress -x /usr/share/doc/${PF}/contrib
+
+ newinitd "${FILESDIR}/geneweb.initd" geneweb
+ newconfd "${FILESDIR}/geneweb.confd" geneweb
+}
+
+pkg_postinst() {
+ einfo "A CGI program has been installed in /usr/lib/${PN}. Follow the"
+ einfo "instructions on the README in that directory to use it"
+ einfo "For 64 bits architecture you need to rebuild the database"
+ einfo "\"gwu foo > foo.gw \" will save the database (use the previous"
+ einfo "version to do that). \"gwc2 foo.gw -o bar \" will restore it "
+ einfo "(using the current package)"
+}