summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-02 11:32:20 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-02 11:35:15 +0300
commit16fa82a934fa51587b98093dc68c2069d719cc89 (patch)
tree4dab4a85e048aedb1dd7a706cb726614cb9835b2
parentdev-python/flask-migrate: add 3.1.0, enable py3.10, fix tests (diff)
downloadgentoo-16fa82a9.tar.gz
gentoo-16fa82a9.tar.bz2
gentoo-16fa82a9.zip
dev-python/flask-principal: EAPI=8, enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/flask-principal/flask-principal-0.4.0-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/flask-principal/flask-principal-0.4.0-r2.ebuild b/dev-python/flask-principal/flask-principal-0.4.0-r2.ebuild
new file mode 100644
index 000000000000..2e383cb425ed
--- /dev/null
+++ b/dev-python/flask-principal/flask-principal-0.4.0-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Identity management for flask"
+HOMEPAGE="https://pythonhosted.org/Flask-Principal/ https://pypi.org/project/Flask-Principal/"
+SRC_URI="
+ https://github.com/mattupstate/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+# pypi tarball is missing tests
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest