summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-04 04:25:27 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-04 04:41:52 +0200
commit170e5dbf1e9eff17d79428e509accc26dcf6a971 (patch)
treedf40bd8d13ff1e8fa773d61971dff7e19305a51a
parentdev-python/zeroconf: Bump to 0.74.0 (diff)
downloadgentoo-170e5dbf1e9eff17d79428e509accc26dcf6a971.tar.gz
gentoo-170e5dbf1e9eff17d79428e509accc26dcf6a971.tar.bz2
gentoo-170e5dbf1e9eff17d79428e509accc26dcf6a971.zip
dev-util/stripe-mock: Bump to 0.169.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-util/stripe-mock/Manifest1
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.169.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/Manifest b/dev-util/stripe-mock/Manifest
index 8ba62f2a9426..c2fe5763b2e9 100644
--- a/dev-util/stripe-mock/Manifest
+++ b/dev-util/stripe-mock/Manifest
@@ -1 +1,2 @@
DIST stripe-mock-0.168.0.tar.gz 1290778 BLAKE2B a8d9ad32ecccb6ced1c45c34174a6a9c5319c38f698ba4226f707ab13121dd44d446f34471916194c3085f6e59a56f1094ad75895ad9c23f009d000c70078f09 SHA512 474e0bba603e060d778e873796572718d58fc3e3ff3f77608ea0b06840af5a47319e79748dafb40ec7e6e0e6f66135a30974026ab8c0a2737781620266cb7c78
+DIST stripe-mock-0.169.0.tar.gz 1290637 BLAKE2B e9e5e8861a23760830b6161fb69a55082457d370bd67811cb12d8ab3689eea915ceaa47f7954fd341cf8487d403b31b6e90c034d7fcd535014b7ba249c5eb7f0 SHA512 0ff65570c8327a929b132684dbed7858f62fe63d1ba6d6a41f355e5260d87433b1b5c0efe38e103f7ae814ae5d008f3f41683f46ae4bef295e28589cf2e3cc16
diff --git a/dev-util/stripe-mock/stripe-mock-0.169.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.169.0.ebuild
new file mode 100644
index 000000000000..ca0f4e60efa7
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.169.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock/"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ emake build
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin stripe-mock
+ einstalldocs
+}