summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-20 15:56:32 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-20 17:02:30 +0200
commit17312c0282ab88880cfc6badd83a507f51b0861a (patch)
treeb7da01015ffbd8237be49a416a912c91ac1d6711
parentnet-dialup/rp-pppoe: Added missing rdep on sys-apps/iproute2 (diff)
downloadgentoo-17312c0282ab88880cfc6badd83a507f51b0861a.tar.gz
gentoo-17312c0282ab88880cfc6badd83a507f51b0861a.tar.bz2
gentoo-17312c0282ab88880cfc6badd83a507f51b0861a.zip
dev-python/stdio-mgr: import from ::guru
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/stdio-mgr/Manifest1
-rw-r--r--dev-python/stdio-mgr/metadata.xml22
-rw-r--r--dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild32
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/stdio-mgr/Manifest b/dev-python/stdio-mgr/Manifest
new file mode 100644
index 000000000000..59da72d82f9b
--- /dev/null
+++ b/dev-python/stdio-mgr/Manifest
@@ -0,0 +1 @@
+DIST stdio-mgr-1.0.1.tar.gz 8447 BLAKE2B 72038ea34177829d77ac239585775557b5a0a253879c027b2aad64045ec8bafbfdc250d94fe61cde96f06616f774edf42b384bfef7fbf69af442b0a9b703cf9a SHA512 2d18e5d65faa7a73373b56fdac3893768a65a36bed17f017b647e71431a6bff44ce1d39022f1dbbd31ddc9c0e704743a164f4b7610fb62d75aa34ecb53331366
diff --git a/dev-python/stdio-mgr/metadata.xml b/dev-python/stdio-mgr/metadata.xml
new file mode 100644
index 000000000000..cfe2eacab93b
--- /dev/null
+++ b/dev-python/stdio-mgr/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <longdescription lang="en">
+Have a CLI Python application?
+
+Want to automate testing of the actual console input &amp; output of your user-facing components?
+
+stdio Manager can help.
+
+While some functionality here is more or less duplicative of redirect_stdout and redirect_stderr in contextlib within the standard library, it provides (i) a much more concise way to mock both stdout and stderr at the same time, and (ii) a mechanism for mocking stdin, which is not available in contextlib.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">bskinn/stdio-mgr</remote-id>
+ <remote-id type="pypi">stdio-mgr</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild b/dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild
new file mode 100644
index 000000000000..4c032aa553ed
--- /dev/null
+++ b/dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Context manager for mocking/wrapping stdin/stdout/stderr"
+HOMEPAGE="
+ https://github.com/bskinn/stdio-mgr/
+ https://pypi.org/project/stdio-mgr/
+"
+SRC_URI="https://github.com/bskinn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND=">=dev-python/attrs-17.1[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+# doc directory is not included in the release tarball for some reason
+#distutils_enable_sphinx doc \
+# dev-python/sphinxcontrib-programoutput \
+# dev-python/sphinx_rtd_theme
+
+python_test() {
+ # skip the doctests
+ epytest tests
+}