summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <jchelmert3@posteo.net>2020-10-04 19:09:13 +0200
committerDavid Seifert <soap@gentoo.org>2020-10-04 19:09:13 +0200
commit173810552f074b83f9d0bdee1e50e5691904b9d9 (patch)
tree64e71c2240690969c166065114acbf1b1196c3a1
parentwww-servers/uwsgi: Stabilize 2.0.19.1 amd64, #738954 (diff)
downloadgentoo-173810552f074b83f9d0bdee1e50e5691904b9d9.tar.gz
gentoo-173810552f074b83f9d0bdee1e50e5691904b9d9.tar.bz2
gentoo-173810552f074b83f9d0bdee1e50e5691904b9d9.zip
media-gfx/sam2p: Security bump
Bug: https://bugs.gentoo.org/631636 Bug: https://bugs.gentoo.org/636876 Bug: https://bugs.gentoo.org/649750 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: John Helmert III <jchelmert3@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/16286 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--media-gfx/sam2p/Manifest1
-rw-r--r--media-gfx/sam2p/files/sam2p-configure-strip.patch30
-rw-r--r--media-gfx/sam2p/sam2p-0.49.4_p20190718.ebuild62
3 files changed, 93 insertions, 0 deletions
diff --git a/media-gfx/sam2p/Manifest b/media-gfx/sam2p/Manifest
index b141a11da737..d8df300a1fd2 100644
--- a/media-gfx/sam2p/Manifest
+++ b/media-gfx/sam2p/Manifest
@@ -1 +1,2 @@
DIST sam2p-0.49.3.tar.gz 2184864 BLAKE2B 47d3ce6384c344f66e564ea9f70e89e311540c1bbaf640a70cec2830347b3767aa79d525d25c12cfc2aecc61aca676239b99b345fc7e6bb2edfac7c60bd8d674 SHA512 9e9c91a2cd692e49bf73e7c197a0fcbe7df96c685636d1d00456eb8b4b847de3f4848d9bb3d9246340c479c62900ddd4e0a248257aa5e6ec6e16683c5dad54f8
+DIST sam2p-0.49.4_p20190718.tar.gz 1816309 BLAKE2B 3d97e00c2bd6b6c292c051d4eb6b73549d1c82a5bd7be3d6b718d8e9d2e96b47657c184af43fa57c0ca4b2b8c26904fb42508d17f7dda715def7d2082affa8b6 SHA512 1c6074fabca6146e51fe0d5a10c912ec679cf122e10aab7bead9e35e3d007e79773aedb1f627572b1b88cacefe0e7edf72efd71d32c47731723b910667220c51
diff --git a/media-gfx/sam2p/files/sam2p-configure-strip.patch b/media-gfx/sam2p/files/sam2p-configure-strip.patch
new file mode 100644
index 000000000000..be78fad0f736
--- /dev/null
+++ b/media-gfx/sam2p/files/sam2p-configure-strip.patch
@@ -0,0 +1,30 @@
+diff --git a/Makefile b/Makefile
+index 1433167..b662e33 100644
+--- a/Makefile
++++ b/Makefile
+@@ -28,12 +28,13 @@ ifeq ($(MAKECMDGOALS),Makedep.force)
+ MAKE_DIST=000
+ endif
+
++GCC_STRIP ?= -s
+ BASH=bash
+ PERL_BADLANG=x
+ export PERL_BADLANG
+
+ CXXX=$(CXD_assert)
+-LDALL=$(LDXX) -s $(LDFLAGS) $(LIBS)
++LDALL=$(LDXX) $(GCC_STRIP) $(LDFLAGS) $(LIBS)
+ ifeq ($(ENABLE_DEBUG), no)
+ CXXX=$(CXD_no)
+ endif
+@@ -101,8 +102,8 @@ IDE_MODES := release debug
+ IDE_TARGETS_debug := $(patsubst %,%.yes, $(TARGETS))
+ IDE_TARGETS_release := $(TARGETS)
+
+-CXD_assert =$(CXX) -s -O2
+-CXD_no =$(CXX) -s -DNDEBUG -O3
++CXD_assert =$(CXX) $(GCC_STRIP) $(CXXFLAGS)
++CXD_no =$(CXX) $(GCC_STRIP) $(CXXFLAGS)
+ # CXD_yes =$(CXX) $(GFLAG) -lefence
+ CXD_yes =$(CXX) $(GFLAG)
+ CXD_checker=checkerg++ $(GFLAG)
diff --git a/media-gfx/sam2p/sam2p-0.49.4_p20190718.ebuild b/media-gfx/sam2p/sam2p-0.49.4_p20190718.ebuild
new file mode 100644
index 000000000000..2460983318f6
--- /dev/null
+++ b/media-gfx/sam2p/sam2p-0.49.4_p20190718.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+COMMIT="b953f63307c4a83fa4615a4863e3fb250205cd98"
+
+DESCRIPTION="Utility to convert raster images to EPS, PDF and many others"
+HOMEPAGE="https://github.com/pts/sam2p"
+SRC_URI="https://github.com/pts/sam2p/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="examples gif"
+RESTRICT="test"
+
+BDEPEND="dev-lang/perl"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+PATCHES=( "${FILESDIR}"/${PN}-configure-strip.patch )
+
+src_prepare() {
+ default
+
+ # configure.in files are deprecated
+ mv configure.{in,ac} || die
+
+ # upstream thinks they're being helpful by running configure with `make`
+ sed -i '/Makedep/s/ .\/configure.*//' Makefile || die
+
+ # eautoreconf is still needed or you get bad warnings
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CXX
+
+ econf \
+ --enable-lzw \
+ $(use_enable gif)
+}
+
+src_compile() {
+ emake GCC_STRIP=
+}
+
+src_install() {
+ dobin sam2p
+ einstalldocs
+
+ if use examples; then
+ # clear pre-compressed files
+ rm examples/*.gz || die
+
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}