summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2020-11-11 23:31:46 -0600
committerErik Mackdanz <stasibear@gentoo.org>2020-11-11 23:31:46 -0600
commit17480a839247fab02f29a4d563e1b3f9ef0e401f (patch)
tree5635dabcdcf06b9c27a3e9ae80b0cd81d88a5467
parentnet-libs/libupnpp: Bump to 0.19.4 (diff)
downloadgentoo-17480a839247fab02f29a4d563e1b3f9ef0e401f.tar.gz
gentoo-17480a839247fab02f29a4d563e1b3f9ef0e401f.tar.bz2
gentoo-17480a839247fab02f29a4d563e1b3f9ef0e401f.zip
media-sound/sc2mpd: Bump to 1.1.7
Signed-off-by: Erik Mackdanz <stasibear@gentoo.org> Package-Manager: Portage-3.0.9, Repoman-3.0.2
-rw-r--r--media-sound/sc2mpd/Manifest2
-rw-r--r--media-sound/sc2mpd/files/sc2mpd-1.1.7-python.patch64
-rw-r--r--media-sound/sc2mpd/files/sc2mpd-1.1.7-werror.patch72
-rw-r--r--media-sound/sc2mpd/sc2mpd-1.1.7.ebuild97
4 files changed, 235 insertions, 0 deletions
diff --git a/media-sound/sc2mpd/Manifest b/media-sound/sc2mpd/Manifest
index d35489da42db..285545a43d17 100644
--- a/media-sound/sc2mpd/Manifest
+++ b/media-sound/sc2mpd/Manifest
@@ -3,4 +3,6 @@ DIST ohnet.1dd641.tar.gz 20831753 BLAKE2B 82724b7f2cd5cd0dcaa54786394a2560b965f5
DIST ohnetgenerated.e3edb9.tar.gz 1887473 BLAKE2B 1b878dd743f0b45f69c3eb018ddbd64db60285ee8743bb039f9a794a9e0ecdb516e1138ac622fc7cde3462fe5c3cfc006d71d0b22048496c1bc190cc4f34a906 SHA512 9b48d0ff496acfa4313c1efc90e73f1050fee011b1ab301b9268ba4009fca9a47978cbe2f1f0a1d05d7c939f95b4a38560b9f63464305032c20d36af3ade8811
DIST ohsongcast.3299ea.tar.gz 831313 BLAKE2B aaa5590af288bbf2b358bad613b983418f6648219bba046113a8c712f3a369fee2894c8aa42f96ead16582b96b982d1696b478950e0e3d0ef6c8e3325e5a3214 SHA512 ac1e81166e5b73a943f78c930ef89fc5b71447c7eb8c4cc509c50c686a360a25f75f1651061a653bf995c15377bee4cb98a97665bf27f04f947940a249e12661
DIST ohtopology.cc09c0.tar.gz 118703 BLAKE2B ef5b560cb2a272586e8755117b5021d67562bda962b0c6240072ad42876ae71f21c81611521d31b01212d2175637244b8513332858aec3d7e713546587111ed0 SHA512 46f1e4ba6b7553b81c939c2ae691ab89e0bf9b565820e8c65b14b6534f3a9240580cb9fd69f46568c5f0c8d105da825b6f9abbf61a64289a4f553a47902b38d4
+DIST openhome-sc2-20200704.tar.gz 22352681 BLAKE2B a5131f3b5c3400ff0ca58f0ce9b45c25db6fc13dcf6827ed9e4531effd3b35026d59495adf690ba65c09624c12f7755b9373ec4e4309de73f17fdeb866beeba7 SHA512 04586fbfd8053c7f01d2c3dbf421f75d0d93ac179cf5f58bc7966d364a3477a87985a1a2db1b35018aa5193a07977b7b4be60d317e7c10b275234adf9a2bd5d2
DIST sc2mpd-1.1.5.tar.gz 219031 BLAKE2B ac8a3b4da6caff58db4948c32d643bf9244efa4ad77e29c18aa7e10036715a9a84c9f69478f5a2eabf6769112fb61ea15e1d7e8e613fbae05794cef609f21247 SHA512 8ea47b8bda62b8e97b95b0ddf0ab7979a54ae8bc599c67ef7bdd16ea876254446c8be440fade7355be93742c94c6f20b56e40a5756cc3c0dbe0409612dc3788e
+DIST sc2mpd-1.1.7.tar.gz 238674 BLAKE2B 35fd57797612e3883ad5cc04be3f5328dbf4ec9aedb0461a801fe79566ef20de4026ad653eec6e7d932ffcd0385bb618331a519ec54838fd856d09c20f1971b8 SHA512 0b39e200f013602c851bec1ba41210c40d1a984638c86bd8dd5d61286aff19b315f282182753426e4470c8e6ccb60265b16dc6ba2e5117f59a3d40194464b4b3
diff --git a/media-sound/sc2mpd/files/sc2mpd-1.1.7-python.patch b/media-sound/sc2mpd/files/sc2mpd-1.1.7-python.patch
new file mode 100644
index 000000000000..d4103a522451
--- /dev/null
+++ b/media-sound/sc2mpd/files/sc2mpd-1.1.7-python.patch
@@ -0,0 +1,64 @@
+diff -ur work.orig/ohNet/bundle_binaries.py work/ohNet/bundle_binaries.py
+--- a/openhome/ohNet/bundle_binaries.py 2020-11-10 00:24:29.640122646 -0600
++++ b/openhome/ohNet/bundle_binaries.py 2020-11-10 00:26:38.441470487 -0600
+@@ -121,22 +121,22 @@
+ parser.add_option("-m", "--managed-only", default=False, action="store_true", help="Package only the managed assembly.")
+ options, args = parser.parse_args()
+ if len(args)>0:
+- print "Too many arguments."
++ print("Too many arguments.")
+ sys.exit(1)
+ if options.system not in ALL_SYSTEMS:
+- print "Please specify --system from one of {0}.".format(", ".join(sorted(ALL_SYSTEMS)))
++ print("Please specify --system from one of {0}.".format(", ".join(sorted(ALL_SYSTEMS))))
+ sys.exit(1)
+ if options.architecture not in ALL_ARCHITECTURES:
+- print "Please specify --architecture from one of {0}.".format(", ".join(sorted(set(tgt.architecture for tgt in ALL_TARGETS.keys() if tgt.system == options.system))))
++ print("Please specify --architecture from one of {0}.".format(", ".join(sorted(set(tgt.architecture for tgt in ALL_TARGETS.keys() if tgt.system == options.system)))))
+ sys.exit(1)
+ if options.configuration not in ALL_CONFIGURATIONS:
+- print "Please specify --configuration from one of {0}.".format(", ".join(sorted(ALL_CONFIGURATIONS)))
++ print("Please specify --configuration from one of {0}.".format(", ".join(sorted(ALL_CONFIGURATIONS))))
+ sys.exit(1)
+ target = BuildTarget(options.system, options.architecture, options.configuration)
+ if target not in ALL_TARGETS:
+- print "Unrecognized target combination. Valid combinations are:"
++ print("Unrecognized target combination. Valid combinations are:")
+ for valid_target in sorted(ALL_TARGETS.keys()):
+- print " " + get_target_as_option_string(valid_target)
++ print(" " + get_target_as_option_string(valid_target))
+ sys.exit(1)
+
+ buildinfo = ALL_TARGETS[target]
+diff -ur work.orig/ohNetGenerated/bundle_binaries.py work/ohNetGenerated/bundle_binaries.py
+--- a/openhome/ohNetGenerated/bundle_binaries.py 2020-11-10 00:24:29.847123204 -0600
++++ b/openhome/ohNetGenerated/bundle_binaries.py 2020-11-10 00:26:11.793398395 -0600
+@@ -96,22 +96,22 @@
+ parser.add_option("-m", "--managed-only", default=False, action="store_true", help="Package only the managed assembly.")
+ options, args = parser.parse_args()
+ if len(args)>0:
+- print "Too many arguments."
++ print("Too many arguments.")
+ sys.exit(1)
+ if options.system not in ALL_SYSTEMS:
+- print "Please specify --system from one of {0}.".format(", ".join(sorted(ALL_SYSTEMS)))
++ print("Please specify --system from one of {0}.".format(", ".join(sorted(ALL_SYSTEMS))))
+ sys.exit(1)
+ if options.architecture not in ALL_ARCHITECTURES:
+- print "Please specify --architecture from one of {0}.".format(", ".join(sorted(set(tgt.architecture for tgt in ALL_TARGETS.keys() if tgt.system == options.system))))
++ print("Please specify --architecture from one of {0}.".format(", ".join(sorted(set(tgt.architecture for tgt in ALL_TARGETS.keys() if tgt.system == options.system)))))
+ sys.exit(1)
+ if options.configuration not in ALL_CONFIGURATIONS:
+- print "Please specify --configuration from one of {0}.".format(", ".join(sorted(ALL_CONFIGURATIONS)))
++ print("Please specify --configuration from one of {0}.".format(", ".join(sorted(ALL_CONFIGURATIONS))))
+ sys.exit(1)
+ target = BuildTarget(options.system, options.architecture, options.configuration)
+ if target not in ALL_TARGETS:
+- print "Unrecognized target combination. Valid combinations are:"
++ print("Unrecognized target combination. Valid combinations are:")
+ for valid_target in sorted(ALL_TARGETS.keys()):
+- print " " + get_target_as_option_string(valid_target)
++ print(" " + get_target_as_option_string(valid_target))
+ sys.exit(1)
+
+ buildinfo = ALL_TARGETS[target]
diff --git a/media-sound/sc2mpd/files/sc2mpd-1.1.7-werror.patch b/media-sound/sc2mpd/files/sc2mpd-1.1.7-werror.patch
new file mode 100644
index 000000000000..fd079e26fb8a
--- /dev/null
+++ b/media-sound/sc2mpd/files/sc2mpd-1.1.7-werror.patch
@@ -0,0 +1,72 @@
+diff -ur ohNet/Makefile ohNet/Makefile
+--- a/openhome/ohNet/Makefile 2020-11-09 23:46:21.295605850 -0600
++++ b/openhome/ohNet/Makefile 2020-11-09 23:48:05.977868337 -0600
+@@ -344,13 +344,13 @@
+ cflags_base = -fexceptions -Wall $(version_specific_cflags_third_party) -pipe -D_GNU_SOURCE -D_REENTRANT -DDEFINE_$(endian)_ENDIAN -DDEFINE_TRACE $(debug_specific_cflags) -fvisibility=hidden $(platform_cflags)
+ cflags_third_party = $(cflags_base) -Wno-int-to-pointer-cast
+ ifeq ($(nocpp11), yes)
+- cppflags = $(cflags_base) -Werror
++ cppflags = $(cflags_base)
+ else ifeq ($(platform),IntelMac)
+- cppflags = $(cflags_base) -std=c++11 -Werror
++ cppflags = $(cflags_base) -std=c++11
+ else
+- cppflags = $(cflags_base) -std=c++0x -Werror
++ cppflags = $(cflags_base) -std=c++0x
+ endif
+-cflags = $(cflags_base) -Werror
++cflags = $(cflags_base)
+ inc_build = Build/Include
+ includes = -IBuild/Include/ $(version_specific_includes)
+ bundle_build = Build/Bundles
+@@ -407,7 +407,7 @@
+ jar = $(JAVA_HOME)/bin/jar
+ endif
+
+-java_cflags = -fexceptions -Wall $(platform_java_cflags) $(version_specific_java_cflags) -Werror -pipe -D_GNU_SOURCE -D_REENTRANT -DDEFINE_$(endian)_ENDIAN -DDEFINE_TRACE $(debug_specific_cflags) $(platform_cflags)
++java_cflags = -fexceptions -Wall $(platform_java_cflags) $(version_specific_java_cflags) -pipe -D_GNU_SOURCE -D_REENTRANT -DDEFINE_$(endian)_ENDIAN -DDEFINE_TRACE $(debug_specific_cflags) $(platform_cflags)
+ jarflags = cf
+ dirsep = /
+ prefix = /usr/local
+diff -ur ohNetGenerated/Makefile ohNetGenerated/Makefile
+--- a/openhome/ohNetGenerated/Makefile 2020-11-09 23:46:21.344605971 -0600
++++ b/openhome/ohNetGenerated/Makefile 2020-11-09 23:47:44.656814158 -0600
+@@ -276,13 +276,13 @@
+ cflags_base = -fexceptions -Wall $(version_specific_cflags_third_party) -pipe -D_GNU_SOURCE -D_REENTRANT -DDEFINE_$(endian)_ENDIAN -DDEFINE_TRACE $(debug_specific_cflags) -fvisibility=hidden $(platform_cflags)
+ cflags_third_party = $(cflags_base) -Wno-int-to-pointer-cast
+ ifeq ($(nocpp11), yes)
+- cppflags = $(cflags_base) -Werror
++ cppflags = $(cflags_base)
+ else ifeq ($(platform),IntelMac)
+- cppflags = $(cflags_base) -std=c++11 -Werror
++ cppflags = $(cflags_base) -std=c++11
+ else
+- cppflags = $(cflags_base) -std=c++0x -D__STDC_VERSION__=199901L -Werror
++ cppflags = $(cflags_base) -std=c++0x -D__STDC_VERSION__=199901L
+ endif
+-cflags = $(cflags_base) -Werror
++cflags = $(cflags_base)
+ depsPlatform = ${openhome_system}-${openhome_architecture}
+ header_install = Build/Include
+ inc_build = dependencies/$(depsPlatform)/ohNet-$(depsPlatform)-Release/include/ohnet
+@@ -337,7 +337,7 @@
+ jar = $(JAVA_HOME)/bin/jar
+ endif
+
+-java_cflags = -fexceptions -Wall $(version_specific_java_cflags) -Werror -pipe -D_GNU_SOURCE -D_REENTRANT -DDEFINE_$(endian)_ENDIAN -DDEFINE_TRACE $(debug_specific_cflags) $(platform_cflags)
++java_cflags = -fexceptions -Wall $(version_specific_java_cflags) -pipe -D_GNU_SOURCE -D_REENTRANT -DDEFINE_$(endian)_ENDIAN -DDEFINE_TRACE $(debug_specific_cflags) $(platform_cflags)
+ jarflags = cf
+ dirsep = /
+ prefix = /usr/local
+diff -ur ohSongcast/Makefile ohSongcast/Makefile
+--- a/openhome/ohSongcast/Makefile 2020-11-09 23:46:21.256605754 -0600
++++ b/openhome/ohSongcast/Makefile 2020-11-09 23:47:23.130759816 -0600
+@@ -38,7 +38,7 @@
+ # Macros used by Common.mak
+
+ ar = ${CROSS_COMPILE}ar rc $(objdir)
+-cflags = -fexceptions -Wall -Werror -pipe -std=c++11 -D_GNU_SOURCE -D_REENTRANT -DDEFINE_LITTLE_ENDIAN -DDEFINE_TRACE $(debug_specific_flags) -fvisibility=hidden -DDllImport="__attribute__ ((visibility(\"default\")))" -DDllExport="__attribute__ ((visibility(\"default\")))" -DDllExportClass="__attribute__ ((visibility(\"default\")))" $(platform_cflags)
++cflags = -fexceptions -Wall -pipe -std=c++11 -D_GNU_SOURCE -D_REENTRANT -DDEFINE_LITTLE_ENDIAN -DDEFINE_TRACE $(debug_specific_flags) -fvisibility=hidden -DDllImport="__attribute__ ((visibility(\"default\")))" -DDllExport="__attribute__ ((visibility(\"default\")))" -DDllExportClass="__attribute__ ((visibility(\"default\")))" $(platform_cflags)
+ ohnetdir = ../ohNet/Build/Obj/$(osdir)/$(build_dir)/
+ ohnetgenerateddir = ../ohNetGenerated/Build/Obj/$(osdir)/$(build_dir)/
+ ohtopologydir = ../ohTopology/build/
diff --git a/media-sound/sc2mpd/sc2mpd-1.1.7.ebuild b/media-sound/sc2mpd/sc2mpd-1.1.7.ebuild
new file mode 100644
index 000000000000..161c326eaa39
--- /dev/null
+++ b/media-sound/sc2mpd/sc2mpd-1.1.7.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="Implements the SongCast protocol for use by upmpdcli and mpd"
+HOMEPAGE="https://www.lesbonscomptes.com/upmpdcli/index.html"
+
+openhome_packageversion="20200704"
+
+SRC_URI="
+ https://www.lesbonscomptes.com/upmpdcli/downloads/${P}.tar.gz
+ https://www.lesbonscomptes.com/upmpdcli/downloads/openhome-sc2-${openhome_packageversion}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ media-libs/alsa-lib
+ media-libs/libsamplerate
+ <=net-libs/libmicrohttpd-0.9.70
+"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ mkdir openhome || die "Can't create openhome directory"
+ cd openhome || die "Can't enter openhome directory"
+ unpack openhome-sc2-${openhome_packageversion}.tar.gz
+}
+
+src_prepare() {
+ cd "${WORKDIR}" || die "Couldn't cd to WORKDIR"
+ eapply "${FILESDIR}/${P}-python.patch"
+ eapply "${FILESDIR}/${P}-werror.patch"
+ eapply_user
+}
+
+src_configure() {
+ econf "--with-openhome=${WORKDIR}/openhome"
+}
+
+src_compile() {
+
+ #### Begin ohbuild.sh reverse engineer
+
+ # build_ohNet
+ cd "${WORKDIR}/openhome/ohNet" || die "Couldn't cd to ohNet dir"
+ make native_only=yes || die "ohnet make failed"
+
+ # build_ohNetGenerated
+ cd "${WORKDIR}/openhome/ohNetGenerated" || die "Couldn't cd to ohNetGenerated dir"
+ # TODO: get from environment/make target
+ deps="${WORKDIR}/openhome/ohNetGenerated/dependencies/Linux-x64/ohNet-Linux-x64-Release"
+ mkdir -p $deps/{include/ohnet,lib/{ohnet,t4,ui,PyOhNet}} || die "Couldn't mkdir deps"
+ cd $deps || die "Couldn't cd to deps dir"
+
+ ohnet="${WORKDIR}/openhome/ohNet"
+ find "$ohnet/Build" \( -name '*.a' -o -name '*.so' \) \
+ -exec cp '{}' lib ';' \
+ || die "Couldn't cp binary libs"
+
+ cd "$ohnet/Build/Include" || die "Couldn't cd to include"
+ cp -R * "${deps}/include/ohnet" || die "Couldn't cp include"
+ # cd "$ohnet/Build/Tools" || die "Couldn't cd to tools"
+ # cp -R * "${deps}/lib/t4" || die "Couldn't cp tools"
+ cd "$ohnet/OpenHome/Net/T4/Templates" || die "Couldn't cd to templates"
+ cp -R * "${deps}/lib/t4" || die "Couldn't cp templates"
+ cd "$ohnet/OpenHome/Net/Bindings/Js/ControlPoint" || die "Couldn't cd to ui"
+ cp -R * "${deps}/lib/ui" || die "Couldn't cp ui"
+ cd "$ohnet/OpenHome/Net/Bindings/Python/PyOhNet" || die "Couldn't cd to py"
+ cp -R * "${deps}/lib/PyOhNet" || die "Couldn't cp py"
+
+ cd "${WORKDIR}/openhome/ohNetGenerated" || die "Couldn't cd later to ohNetGenerated dir"
+ make native_only=yes || die "ohnetgenerated make failed"
+
+ cd "Build/Include" || die "Couldn't cd later to include"
+ cp -R * "$ohnet/Build/Include" || die "Couldn't cp generated includes"
+
+ # build_ohTopology
+ cd "${WORKDIR}/openhome/ohTopology" || die "Couldn't cd to ohTopology dir"
+ mkdir -p build/Include/OpenHome/Av || die "Couldn't mkdir av"
+ cp -p OpenHome/Av/*.h build/Include/OpenHome/Av/ || die "Couldn't cp to av"
+
+ # build_ohSongcast
+ cd "${WORKDIR}/openhome/ohSongcast" || die "Couldn't cd to ohSongcast dir"
+ make release=1 library_static || die "Failed to build ohSongcast"
+
+ #### End ohbuild.sh reverse engineer
+
+ cd "${S}" || die "Failed to cd to source directory"
+ make || die "Failed to make sc2mpd"
+}