summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-05-19 21:01:02 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-05-19 21:24:46 +0200
commit17533d1c1c3b5bedd40781995b5407cf4c05a073 (patch)
tree2c545b78b98d7790a7cd850b77a5649a4a1a79f5
parentkde-frameworks/threadweaver: 5.116.0 version bump (diff)
downloadgentoo-17533d1c1c3b5bedd40781995b5407cf4c05a073.tar.gz
gentoo-17533d1c1c3b5bedd40781995b5407cf4c05a073.tar.bz2
gentoo-17533d1c1c3b5bedd40781995b5407cf4c05a073.zip
kde-plasma/kwayland: 5.116.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/kwayland/Manifest1
-rw-r--r--kde-plasma/kwayland/kwayland-5.116.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-plasma/kwayland/Manifest b/kde-plasma/kwayland/Manifest
index fc0af13cac3d..e8d625c8180f 100644
--- a/kde-plasma/kwayland/Manifest
+++ b/kde-plasma/kwayland/Manifest
@@ -1,2 +1,3 @@
DIST kwayland-5.115.0.tar.xz 337404 BLAKE2B f03eb7d0b4ad86733dae5f7488f6f902c4ce0c17ef90a8fcf9df4ca1d5b184bf8b2ad402580c407a2076be4409f81155eff565e2134221ae4ea277d593f1745a SHA512 d4279353a7179001f19bd6962595c321161ec5f5fa24518af4326b21dab56caeed5a86cc82c5335cd8288c0b348feccfb59ec8e3ee0ec0f418972c29d48832ec
+DIST kwayland-5.116.0.tar.xz 337540 BLAKE2B e238af4a122317fde2b207762858fb913005afde60f1b9cf2dfd90163021d8c3d7d9c3b055a4bb3ae26b5d0560e90c9e0d1e1e51480315bf1a5bc5592a231d11 SHA512 48b24c88872a21d237274868fea601120fb9700f888ab0a7531651dc6501db8559af3a70b6131d89d31010e1f32013222d42e9d1244ae91bf9972588494957a9
DIST kwayland-6.0.4.tar.xz 133764 BLAKE2B 118672442b101b6044f2acef55b2f14235abfac37e8098f0d461260eb167b7a3d374ac726ea030ad6e2e844a3950be83535073d232e60a6787bacd3389991848 SHA512 12db8acbd24716ee3321d2e8b47315dfa645dc447224eba7db80095d9f5eb41d61f7d3d8422f38a6d066313d0cc6994085b4bc9bb974e427b574a1aafd20a653
diff --git a/kde-plasma/kwayland/kwayland-5.116.0.ebuild b/kde-plasma/kwayland/kwayland-5.116.0.ebuild
new file mode 100644
index 000000000000..5f362f3d51ea
--- /dev/null
+++ b/kde-plasma/kwayland/kwayland-5.116.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_NONGUI="true"
+ECM_QTHELP="true"
+ECM_TEST="true"
+KFMIN=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm flag-o-matic frameworks.kde.org
+
+DESCRIPTION="Qt-style client and server library wrapper for Wayland libraries"
+HOMEPAGE="https://invent.kde.org/frameworks/kwayland"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# All failing, I guess we need a virtual wayland server
+RESTRICT="test"
+
+# slot ops: includes qpa/qplatformnativeinterface.h, surface_p.h
+RDEPEND="
+ >=dev-libs/wayland-1.15.0
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5=[egl]
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ media-libs/libglvnd
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.9.0
+ >=dev-libs/wayland-protocols-1.15
+ sys-kernel/linux-headers
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ >=dev-util/wayland-scanner-1.19.0
+"
+
+src_configure() {
+ filter-lto # bug 866575
+ ecm_src_configure
+}