summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-09-12 11:04:50 -0700
committerPatrick McLean <chutzpah@gentoo.org>2023-09-12 11:04:50 -0700
commit17662f21c0471dcf20e9548da81e843a3199acd5 (patch)
tree35d6e2a25ee82185f8e90e5e5c17125c5e81e177
parentdev-util/ruff: add 0.0.289, drop 0.0.288 (diff)
downloadgentoo-17662f21c0471dcf20e9548da81e843a3199acd5.tar.gz
gentoo-17662f21c0471dcf20e9548da81e843a3199acd5.tar.bz2
gentoo-17662f21c0471dcf20e9548da81e843a3199acd5.zip
dev-python/pdm: add 2.9.2
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/pdm/Manifest1
-rw-r--r--dev-python/pdm/pdm-2.9.2.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/pdm/Manifest b/dev-python/pdm/Manifest
index ed7c75f290ed..c2939776490a 100644
--- a/dev-python/pdm/Manifest
+++ b/dev-python/pdm/Manifest
@@ -3,3 +3,4 @@ DIST pdm-2.8.1.tar.gz 3014347 BLAKE2B 0dde8e2376065ac6241e06c24a7b1b241e5653f6e2
DIST pdm-2.8.2.tar.gz 3014401 BLAKE2B a541339582944988b7a30d2991066287e0293845d4f15c7f6cb2fef7a8709dba537f190e5493bd3b06e7ef86fca601a9d1aab7af6ca6ae55269b374a7464ca17 SHA512 396e27902f74773070cf49c3857d93702e6678a46221b54dc03e84e2b8ccf211cbba9d24eba6bfc47ff36cbd4eb504ada5bf82071c884347026ba85c123058e9
DIST pdm-2.9.0.tar.gz 3017672 BLAKE2B f0fe08da3fcc3d72e707d11d217b1482b06351eeae47cef3b696100589d0acd15dd860d61c60004d68decafe277d7afd1c79ae5826689be6781120ef8cf3c969 SHA512 1d7f8b6a4403779730117179a4bfd5884afeeff3f6d7f083e5ed50835b3764b19f54dd8509db04968c66e176a34aef8b6a26f1a9423cd23b94a4eb1255962467
DIST pdm-2.9.1.tar.gz 3017895 BLAKE2B 944a1cd9571f7ad2ec6b4212b29db7b6c7c5e8b12591c73dae19f099f9d511f0db3f0698d48e2e42fc81f30c876caa7c9e43467d23eee26876595e6fd6ff197e SHA512 979bf9d078747c7b8dd56555d499053b978ddf289af4bf889b2f2805255049c24bf48607b3704509d914eec59904cbdb9983af396c68ff7211cc216fd4b40118
+DIST pdm-2.9.2.tar.gz 3018730 BLAKE2B 83eeab7b70efe61a515ed262e8bd1de911f111aaa22704fcce2e46824a236be663ba831cce8bb440e612e711b8cf0627b1a416e966b06b51dc6e25feb2e856b0 SHA512 1d3193dc31065a05989e9dc36518fac0d45f86945d68ff2b5e03473b97c70b0f9586849a1e2208e740921927857733c76c44b512213cb17fc6608f9d0d7bcbd9
diff --git a/dev-python/pdm/pdm-2.9.2.ebuild b/dev-python/pdm/pdm-2.9.2.ebuild
new file mode 100644
index 000000000000..c4d9036ca7eb
--- /dev/null
+++ b/dev-python/pdm/pdm-2.9.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python package and dependency manager supporting the latest PEP standards"
+HOMEPAGE="
+ https://pypi.org/project/pdm/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ dev-python/truststore[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/pyproject-hooks[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ >=dev-python/unearth-0.10.0[${PYTHON_USEDEP}]
+ <dev-python/findpython-1[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ dev-python/shellingham[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ >=dev-python/resolvelib-1.0.1[${PYTHON_USEDEP}]
+ dev-python/installer[${PYTHON_USEDEP}]
+ dev-python/cachecontrol[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/tomli[${PYTHON_USEDEP}]' pypy3 python3_10)
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ 'tests/cli/test_build.py::test_build_with_no_isolation[False]'
+ tests/test_project.py::test_access_index_with_auth
+ tests/cli/test_others.py::test_build_distributions
+ 'tests/models/test_candidates.py::test_expand_project_root_in_url[demo @ file:///${PROJECT_ROOT}/tests/fixtures/artifacts/demo-0.0.1.tar.gz]'
+ 'tests/models/test_candidates.py::test_expand_project_root_in_url[-e file:///${PROJECT_ROOT}/tests/fixtures/projects/demo-#-with-hash#egg=demo]'
+ # hangs on interactive keyring prompts
+ tests/cli/test_config.py::test_repository_overwrite_default
+ tests/cli/test_config.py::test_hide_password_in_output_repository
+ tests/cli/test_config.py::test_hide_password_in_output_pypi
+ # junk output, sigh
+ tests/cli/test_others.py::test_info_command_json
+ # why does it try to use python 2.7?!
+ tests/cli/test_run.py::test_import_another_sitecustomize
+ )
+ [[ ${EPYTHON} != python3.10 ]] && EPYTEST_DESELECT+=(
+ # test seems hardcoded to 3.10
+ tests/test_project.py::test_project_packages_path
+ )
+
+ epytest -m "not network and not integration and not path"
+}