summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-06 21:05:13 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-06 21:05:30 +0200
commit177961cdcd855668976a97fb8ba045e3a8201d5f (patch)
tree33e6d7695fc92bd043b3a690dab20134ff24c432
parentdev-python/gmpy: add 2.1.2 (diff)
downloadgentoo-177961cd.tar.gz
gentoo-177961cd.tar.bz2
gentoo-177961cd.zip
dev-python/jaraco-collections: add 3.5.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/jaraco-collections/Manifest1
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-3.5.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/jaraco-collections/Manifest b/dev-python/jaraco-collections/Manifest
index 1267d2de2c85..f87dead2ea13 100644
--- a/dev-python/jaraco-collections/Manifest
+++ b/dev-python/jaraco-collections/Manifest
@@ -1,2 +1,3 @@
DIST jaraco.collections-3.4.0.tar.gz 14887 BLAKE2B 2c1e87b18dc3ca68fb5b849b30cc0284b8a8daed9b6b2b075a753f7ccf91feb487734a38bb7fc88d29020b0b1980346109551a8bba5d0b3a7f4a491c0dcb1615 SHA512 8e427f98dbcfad3f9042d1f080b2bf8012fdaaf084e230f9b46ff078623b047c2d9dab41ed0303df5dd070abce2a25289281113a97e8ab8d819048d30b8d314a
DIST jaraco.collections-3.5.0.tar.gz 15001 BLAKE2B 3ddc63fdc8d9c9cf9f25aee0cfa1c6d10c93b337bb77f7f33527986f58bb80ae35fbcc1dcb21aadebb3303a3ee20122134fe27f95ecd4b17c64b6f5ea6e94ae2 SHA512 cf0646b388beefe1aed26c96ae725b2934b7bd9df63e57c51c9c84ad6c758c135e6bb3487e0a6a68fba149234c54f2b0eacd4b260c945f8ffed632bdcb03d88f
+DIST jaraco.collections-3.5.1.tar.gz 15053 BLAKE2B afba813636464b6776f244eab31a0cd86418410f313e171cff1c8ac64e5d902f4a6c2f88d87c61d55292baa338aee45866d3a459c5b5b73fd4e751278b869316 SHA512 2918be537296ca81e5f78a3966a47451dc9dc2d233d997c3f01461c489b44051c497dab55496f85883ac1b91a28850a9d77ff154a3f5e074da1ed07f3259c246
diff --git a/dev-python/jaraco-collections/jaraco-collections-3.5.1.ebuild b/dev-python/jaraco-collections/jaraco-collections-3.5.1.ebuild
new file mode 100644
index 000000000000..010f9dbceca2
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-3.5.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="https://github.com/jaraco/jaraco.collections"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/jaraco-packaging-3.2' \
+ '>=dev-python/rst-linker-1.9'
+distutils_enable_tests pytest