summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-23 20:14:33 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-23 20:14:33 +0300
commit17894631f03594b399ce6d4f40f3f01b007b1b51 (patch)
tree6e8fa4ac16710cb3cea0a3b9f7a2c29ebf0702fb
parentapp-admin/awscli: add 1.25.57 (diff)
downloadgentoo-17894631.tar.gz
gentoo-17894631.tar.bz2
gentoo-17894631.zip
dev-python/marshmallow: add 3.17.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/marshmallow/Manifest1
-rw-r--r--dev-python/marshmallow/marshmallow-3.17.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index 978fef22a0d1..859ff8808e31 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -1,2 +1,3 @@
DIST marshmallow-3.16.0.tar.gz 180106 BLAKE2B c3d9b9c1645e7df103940b8e637f3de027f23e5da4a6ebd25412fef9d2d61483ec934af5c37f781121928a7b2f98b44793a8671173a5c548936ce0bbd0d2290d SHA512 5d3c7babff9117261afb902090bffcdba4eee2984d13862f4974fc043c6e56420707a6d3aba4a6046d947ef9414386c24895fc9a2538e36e505692e76d70f409
DIST marshmallow-3.17.0.gh.tar.gz 180037 BLAKE2B 17fa577a969d82555312b362b41e6c61c209566ba418c9aa14ef1195b7317477a9e7c7d669e5643bee0d12454fee79bcf35a9eb625ad499347299e6727afb6bc SHA512 3fceb6dcb3df7339d0c002ac90ed9960bdcc174b29ad0fc3222a435d3980b892ae07c1080483b7a5a71455a475ae1086869432cefab898a1008ad33c7efc1f99
+DIST marshmallow-3.17.1.gh.tar.gz 180094 BLAKE2B 7c4dc60923ef95bdd0d77da4d6c643193944ca02115fd12529fa564860acee3ec495f1b402f5bee6b4a90fe6100e766cc0959918aed57b232e9ff2e5d2500602 SHA512 f72f969fba2136cfe288fea93a6db791b99f163f5b5af3498c6dbef9150abd5ce66b9678b1ba6538c3add530272b13c197a57d2e35cf148a5d21bf12feafcdd4
diff --git a/dev-python/marshmallow/marshmallow-3.17.1.ebuild b/dev-python/marshmallow/marshmallow-3.17.1.ebuild
new file mode 100644
index 000000000000..f924d3b5509e
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.17.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for converting to and from native Python datatypes"
+HOMEPAGE="
+ https://github.com/marshmallow-code/marshmallow/
+ https://pypi.org/project/marshmallow/
+"
+SRC_URI="
+ https://github.com/marshmallow-code/marshmallow/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-0.17[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest