summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-15 19:49:26 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-15 19:53:56 +0200
commit1791440f61ede784d6f551dc851e72f81f1d683f (patch)
tree324d4d293b98fc8bdfffe4529096180b2f7d2524
parentdev-python/a2wsgi: Enable py3.13 (diff)
downloadgentoo-1791440f61ede784d6f551dc851e72f81f1d683f.tar.gz
gentoo-1791440f61ede784d6f551dc851e72f81f1d683f.tar.bz2
gentoo-1791440f61ede784d6f551dc851e72f81f1d683f.zip
dev-python/dirty-equals: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/dirty-equals/dirty-equals-0.7.1.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/dev-python/dirty-equals/dirty-equals-0.7.1.ebuild b/dev-python/dirty-equals/dirty-equals-0.7.1.ebuild
index 36c776c91dad..fd70ed6710e3 100644
--- a/dev-python/dirty-equals/dirty-equals-0.7.1.ebuild
+++ b/dev-python/dirty-equals/dirty-equals-0.7.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1
@@ -29,8 +29,10 @@ RDEPEND="
BDEPEND="
test? (
dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/pydantic-2.4.2[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/pydantic-2.4.2[${PYTHON_USEDEP}]
+ ' 3.{10..12})
)
"
@@ -42,6 +44,12 @@ python_test() {
tests/test_docs.py
)
+ if ! has_version "dev-python/pydantic[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/test_other.py
+ )
+ fi
+
local -x TZ=UTC
epytest "${args[@]}"
}