summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-30 19:41:45 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-30 20:57:26 +0300
commit1792159445f5183086255952d462f82ba748cc23 (patch)
tree66842dc7f769432640615cb177cdc92fec16a632
parentdev-python/python-ironicclient: add 4.8.0, enable tests, py3.9 (diff)
downloadgentoo-17921594.tar.gz
gentoo-17921594.tar.bz2
gentoo-17921594.zip
dev-python/python-swiftclient: add 3.12.0, enable py3.9, clean tests
Closes: https://bugs.gentoo.org/812884 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/python-swiftclient/Manifest1
-rw-r--r--dev-python/python-swiftclient/python-swiftclient-3.12.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/python-swiftclient/Manifest b/dev-python/python-swiftclient/Manifest
index 5e85462faff0..e0a9a3ae0671 100644
--- a/dev-python/python-swiftclient/Manifest
+++ b/dev-python/python-swiftclient/Manifest
@@ -1 +1,2 @@
DIST python-swiftclient-3.10.1.tar.gz 199466 BLAKE2B 4230f0fbff0e61a8172344df1cfc32f07628ac0b3784f5b8456d1b43b962e1d8561eec55c530ea94c615d46cd9454963fe0e21c54d1f4097016459e1460795c9 SHA512 f47444243f1968fdbba0643bcb4f05fc10a201b38ad83522e842bbad2221d0893a72147f9fbdc13e7f56469b049bbf11479fd9f41a9706119287543e0587f696
+DIST python-swiftclient-3.12.0.tar.gz 201199 BLAKE2B 36a5bc0ed7855b8ec8df51635ed6a2afba405c73809f3ab17c77e07dc362a2578816e63adf6c8da3b81ba8bfa8973326004c09bf980961b3c90987ecfdf95e30 SHA512 00e2b1b4d950396fba9232c251dbdf6949ea60e1f9de8f633ffcdeaa51339c5487fbccf9d9f337ef7aecba30e504338c592f9ed64d1d5c6798307a35b806f684
diff --git a/dev-python/python-swiftclient/python-swiftclient-3.12.0.ebuild b/dev-python/python-swiftclient/python-swiftclient-3.12.0.ebuild
new file mode 100644
index 000000000000..061cfa612171
--- /dev/null
+++ b/dev-python/python-swiftclient/python-swiftclient-3.12.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to the OpenStack Object Storage API"
+HOMEPAGE="https://launchpad.net/python-swiftclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ dev-python/python-keystoneclient[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/openstacksdk-0.11.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -e 's/test_password_prompt/_&/' -i test/unit/test_shell.py || die
+ distutils-r1_python_prepare_all
+}