summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-05-27 12:18:22 +0200
committerPacho Ramos <pacho@gentoo.org>2022-05-27 12:18:22 +0200
commit17960fb08b9c6b215e151e24f4bf404a8038d725 (patch)
treea00ae47adcba79ece1e575ea244ff9ca375e38e8
parentgnome-extra/evolution-data-server: add 3.44.2 (diff)
downloadgentoo-17960fb0.tar.gz
gentoo-17960fb0.tar.bz2
gentoo-17960fb0.zip
gnome-extra/evolution-ews: add 3.44.2
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--gnome-extra/evolution-ews/Manifest1
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.44.2.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/Manifest b/gnome-extra/evolution-ews/Manifest
index 8d0855081efe..0be12a19a8d7 100644
--- a/gnome-extra/evolution-ews/Manifest
+++ b/gnome-extra/evolution-ews/Manifest
@@ -1,3 +1,4 @@
DIST evolution-ews-3.42.4.tar.xz 686236 BLAKE2B f68a3c4c41419eb5d316ce8271a8c8411217e63b951230fb0151d79fca15e82e36248e3bd676518ae5f8a92d7e1d1dbf6a140bbd63dee6dca97fe48f76d502f9 SHA512 5ce1a228414d8c456962ce944a01efbeefb059bc9ff358c95bb7cec72e74ad29cd9476c9aa396b01df35d7c89fff743837dc2f9763129a5f794cbbd14557c2e3
DIST evolution-ews-3.44.0.tar.xz 688444 BLAKE2B d563137c481dc51f9934fe44a3c563e7204d63ebdac1de7a018da27f8c05cc3d56ddc37848fb57ed909e6bc4d98e2752d401f39e92ccd20b507033404c6b7284 SHA512 0625262e485edf7dc5a0449acae3d65992d4f17dcc64196e449922e3eeb4c8ce57cf0220ecf626bcfcd81b5cea1273ccde18f0dbb9073f56ee923a3cbfb93a83
DIST evolution-ews-3.44.1.tar.xz 688764 BLAKE2B bf3b5785a533721b6100479a6cd409a49d3aa37055d6a24a5b6d8ca1338f051ab4cb9801f24ab624d4c24dcb3c3cba7639001269514206749ef305ce0723063c SHA512 69d60ebd6e65fae505515b5ade626c867d9272e80f906f55933617c58148441da49f3d36a36205cacdb7f4997da4b90a77f3b9011775f20ac627728a41b210b0
+DIST evolution-ews-3.44.2.tar.xz 690680 BLAKE2B 029083bcb29d8c6883105fb3e5648501f620946fb11aa60e87feb79857c3e92247ae9987e3a40c185552dd60887f6b6aab00fec3d47f8340357aabf51dcfd4b7 SHA512 dac8ddfc04993585de0dad8eb34ec7296ab2146806a49db1ef182844abee7f383187f621f5b8beaddf6ffbab431ea7d811ce02ff64b87448fb2ff324d28a3620
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.44.2.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.44.2.ebuild
new file mode 100644
index 000000000000..478c6401b9f3
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.44.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake gnome2 optfeature
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="test"
+
+# libical-glib currently (2020-02-29) oddly behind USE=introspection
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.62:2
+ >=dev-libs/libical-3.0.5:0=[introspection(-)]
+ >=dev-libs/json-glib-1.0.4
+ >=dev-libs/libmspack-0.4
+ dev-libs/libxml2:2
+ >=gnome-extra/evolution-data-server-${PV}:0=
+ >=mail-client/evolution-${PV}:2.0
+ >=net-libs/libsoup-2.58:2.4
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ test? ( net-libs/uhttpmock )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+
+# Unittests fail to find libevolution-ews.so
+RESTRICT="test !test? ( test )"
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
+# call; if needed, set them after cmake_src_prepare call, if that works
+src_prepare() {
+ cmake_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MSPACK=ON
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_test() {
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+}
+
+pkg_postinst() {
+ optfeature "oauth support" gnome-extra/evolution-data-server[oauth]
+}