summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-22 13:44:58 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-20 10:36:26 +0100
commit1799bd53b7a5d2a3e7da6a4b6324eee80fc00171 (patch)
treed5f8f89db51d02e8c2c24df5e43bd8f0e8b7566b
parentdev-python/testpath: Build from pyproject.toml (diff)
downloadgentoo-1799bd53b7a5d2a3e7da6a4b6324eee80fc00171.tar.gz
gentoo-1799bd53b7a5d2a3e7da6a4b6324eee80fc00171.tar.bz2
gentoo-1799bd53b7a5d2a3e7da6a4b6324eee80fc00171.zip
dev-python/sphinxcontrib-github-alt: Build from pyproject.toml
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.1-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.1-r1.ebuild b/dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.1-r1.ebuild
new file mode 100644
index 000000000000..e2c50ac186d1
--- /dev/null
+++ b/dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+MY_PN="sphinxcontrib_github_alt"
+
+DESCRIPTION="Link to GitHub issues, pull requests, commits and users from Sphinx docs"
+HOMEPAGE="https://github.com/jupyter/sphinxcontrib_github_alt"
+SRC_URI="https://github.com/jupyter/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+BDEPEND=${RDEPEND}
+
+S="${WORKDIR}/${MY_PN}-${PV}"