summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-08 22:16:32 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-08 22:44:52 +0100
commit179a8dd43d2c625f4fc6119e4be32a9e028464f0 (patch)
tree9a4a84f96c637449d26936046536cbec9c17cbb7
parentdev-qt/qtimageformats: 5.15.8 version bump (diff)
downloadgentoo-179a8dd43d2c625f4fc6119e4be32a9e028464f0.tar.gz
gentoo-179a8dd43d2c625f4fc6119e4be32a9e028464f0.tar.bz2
gentoo-179a8dd43d2c625f4fc6119e4be32a9e028464f0.zip
dev-qt/qtlocation: 5.15.8 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-qt/qtlocation/Manifest2
-rw-r--r--dev-qt/qtlocation/qtlocation-5.15.8.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index bf991e3b50fa..bd025d62457c 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1,2 +1,4 @@
DIST qtlocation-5.15.7-gentoo-kde-1.tar.xz 3948 BLAKE2B fcbac7c87e8c5f470f523c153b6caec2de66ccb7be6f8b0bdbf042d957a88626b4a46848eb6c6442b8199851b908f91241db72f7762816519ef27327f232927d SHA512 396c31cbf3f80c268ebcbf26de8cbfa2d51a355ef4d7824545f7d2fe98ccb5203b61cca9650cfae2793250006b2a5fa514b9bc19fff5650b86ac38a8ba9b9948
+DIST qtlocation-5.15.8-gentoo-kde-1.tar.xz 3952 BLAKE2B 6084d14533ca2ba44249db817f1f0bb93e526fc14e4f4f32d9c99f7b231e25449b111bf9e08b8dca95928d3ac29f63a8e42cbd51d9cd0700344aad6982dd2ff9 SHA512 868e96a2a84bfb0e068957968c07b3558bef2c12517c5971b11e1b536a92ae80d0ca399355f8fadc0fcef2b272b77e6b30951f96ec7fbe174bb5a053567d2c9e
DIST qtlocation-everywhere-opensource-src-5.15.7.tar.xz 6559220 BLAKE2B 635be1ec133a6dd7dbf071922090b6acfe4c02503275ac2539cd4e099dc518ac43654be54e5fa17d292fcdb9edf88a11a1eeec7e37faa752deb6671bef86abba SHA512 fc4579b14f7f4836ef550d80b867c2655f52da34b0637dce4d83b10f2f7a836530a8f2a6b0f1a41c38e5e391c5d8e2431818e9813fd9d597f67704fcfbfb2f7e
+DIST qtlocation-everywhere-opensource-src-5.15.8.tar.xz 6559180 BLAKE2B 1b8feb5da8d564a6605d9106ec6399aea23a4f0b43f495baf61e14266e90d2d73cd310fb6d8514730867acba1aa26efb3072c213f22f19f72c2f554d76ab281b SHA512 a337fade917150c13fa2ea22ad1949f41541cea4ceb1f732ab53c20c2f19a63dcfc6f9f544ca64fdb5703d3ac8d2ec6e832f1f199a32e73a2f6c51febf53f514
diff --git a/dev-qt/qtlocation/qtlocation-5.15.8.ebuild b/dev-qt/qtlocation/qtlocation-5.15.8.ebuild
new file mode 100644
index 000000000000..44fe4356389d
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.15.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=1
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+inherit qt5-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
+
+IUSE=""
+
+RDEPEND="
+ dev-libs/icu:=
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtdeclarative-${QT5_PV}*
+ =dev-qt/qtgui-${QT5_PV}*
+ =dev-qt/qtnetwork-${QT5_PV}*
+ =dev-qt/qtpositioning-${QT5_PV}*[qml]
+ =dev-qt/qtsql-${QT5_PV}*
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ =dev-qt/qtconcurrent-${QT5_PV}*
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/3rdparty/mapbox-gl-native
+ src/location
+ src/imports/location
+ src/imports/locationlabs
+ src/plugins/geoservices
+)
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ mkdir -p "${QT5_BUILD_DIR}"/src/location || die
+ qt5_qmake "${QT5_BUILD_DIR}"
+ cp "${S}"/src/location/qtlocation-config.pri "${QT5_BUILD_DIR}"/src/location || die
+ qt5-build_src_configure
+}