summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-30 08:02:58 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-30 08:10:02 +0100
commit17a2e8abc8792a556193413a72b5f9cdc693b64a (patch)
tree5ddf379869fa9e61eced18e4d8c134cef04964c1
parentdev-python/humanize: Bump to 4.5.0 (diff)
downloadgentoo-17a2e8ab.tar.gz
gentoo-17a2e8ab.tar.bz2
gentoo-17a2e8ab.zip
dev-python/libtmux: Bump to 0.21.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/libtmux/Manifest1
-rw-r--r--dev-python/libtmux/libtmux-0.21.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/libtmux/Manifest b/dev-python/libtmux/Manifest
index 9f490b261f7d..0ff464843d34 100644
--- a/dev-python/libtmux/Manifest
+++ b/dev-python/libtmux/Manifest
@@ -2,3 +2,4 @@ DIST libtmux-0.15.10.gh.tar.gz 240378 BLAKE2B 81841a25b01bb26d2c612a14cd4518c48b
DIST libtmux-0.18.3.gh.tar.gz 261540 BLAKE2B be98707101d7481b6787694795eb05dbe1070a0eed0b7408af1714be01f4870c51223559d1edc3a3fb7b60e02496a413e92c0734031223bca9d521604cb6e65e SHA512 67173c4f2f45f1236e7a1a5ce0895c53bfd6316aa7017382f97b87f84cbc6a23a6ef0f2574a276b7b064da9e4982804fb2004d31ddb1237f97ca835fafdf9ccb
DIST libtmux-0.19.1.gh.tar.gz 262280 BLAKE2B 9d1a2c74b49011e66df6ed2012096b0df6c6731e258078f8ce2b4fef38d21513488b195e3fdb722478ae5f829ba77bd09c152569d73cab83bfa6e4a360346b39 SHA512 b9f3b29de7c8ca86e8495843aa04e2dedfaea749bd57095a9d7a2f638111de7474500c3dbd892f0c580c613c796fece8da47d6c099b8b78056fbd242451eb129
DIST libtmux-0.20.0.gh.tar.gz 266849 BLAKE2B 51840c4cf5aecb077c7c5205a33e6a620b68aed3f61bf52f4c376b257896c907a0e9117c35f70493464d4a3e136e9bd81e0d2ed6cd8a9f4a7c80276dc1461568 SHA512 1e8b49898aeb622aca6160c9ed99c7714d75f716baae5109e278baf5b70d0211d3ac4ed89c3755823b203add1fe4198ceb9e16ad03941eed2cbd2407fd46f0d2
+DIST libtmux-0.21.0.gh.tar.gz 267484 BLAKE2B 36d7af1bd90ff5a9639587d79f49643eec1e218d3b1839f5febdd9b6b402886e577b15c920cf458ecb14b4e6d532955b6d71ecf932060e6f8ba32193d6bb0162 SHA512 27000581396d79665e34b67a9e59bf639ca0fbd855ada9648750750e41e732cdcde15a05c6548993f08a8637783ddb478de24b75d5c18a198541c36b4b08b9cc
diff --git a/dev-python/libtmux/libtmux-0.21.0.ebuild b/dev-python/libtmux/libtmux-0.21.0.ebuild
new file mode 100644
index 000000000000..499498389f30
--- /dev/null
+++ b/dev-python/libtmux/libtmux-0.21.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python API for tmux"
+HOMEPAGE="
+ https://libtmux.git-pull.com/
+ https://github.com/tmux-python/libtmux/
+ https://pypi.org/project/libtmux/
+"
+SRC_URI="
+ https://github.com/tmux-python/libtmux/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/twine[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ libtmux/pane.py::libtmux.pane.Pane.send_keys
+)
+
+python_prepare_all() {
+ local issues="https://github.com/tmux-python/libtmux/issues/"
+ sed -r -i "s|:issue:\`([[:digit:]]+)\`|\`issue \1 ${issues}\1\`|" CHANGES || die
+ rm requirements/doc.txt || die
+
+ # increase timeouts for tests
+ sed -e 's/0.01/0.1/' -i tests/test_test.py || die
+
+ sed -e '/addopts/s:--doctest-docutils-modules::' \
+ -e '/README\.md/d' \
+ -i setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}