summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2024-01-31 23:32:03 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-06 14:03:13 +0100
commit17aca6a56e9b8b49fd189f1c060083af06565eb1 (patch)
tree142add530c314db3541d1a06b792eaded1f847d1
parentdev-python/sphinxemoji: Bump to 0.3.1 (diff)
downloadgentoo-17aca6a56e9b8b49fd189f1c060083af06565eb1.tar.gz
gentoo-17aca6a56e9b8b49fd189f1c060083af06565eb1.tar.bz2
gentoo-17aca6a56e9b8b49fd189f1c060083af06565eb1.zip
dev-python/leechcorepyc: add 2.16.9
Closes: https://bugs.gentoo.org/922738 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/35123 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/leechcorepyc/Manifest1
-rw-r--r--dev-python/leechcorepyc/files/leechcorepyc-2.16.9-respect-CC.patch30
-rw-r--r--dev-python/leechcorepyc/leechcorepyc-2.16.9.ebuild41
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/leechcorepyc/Manifest b/dev-python/leechcorepyc/Manifest
index 97630a1da22a..a0b88a3f7aca 100644
--- a/dev-python/leechcorepyc/Manifest
+++ b/dev-python/leechcorepyc/Manifest
@@ -1 +1,2 @@
DIST leechcorepyc-2.16.5.tar.gz 177365 BLAKE2B a5193e6e6c3fc2dc63358f62a2240b3a186b2acb37968597c5b5c690fbc94487c17bef55e8123bfdc55df2aa8668f667750a850fe4480b08d85bc311b1d2a95d SHA512 8d9b556d7ebc7de474dc853f9dfa005f91a19e6f7672d4021bc83c48b7d3ab0b6617bdbaf79e79b2fc930b64f448e3b8849d83c735077fd98776b026cff57a30
+DIST leechcorepyc-2.16.9.tar.gz 178656 BLAKE2B 76cefea2d8c30c88ae649da6c95f420b366e6b7ec8a44339cda6bd65b890b02196ff19d3b7d8218c87a73256e079fdd51dcb0499934fef0145e4a404376be7de SHA512 5a5455d0401177d2ae4f6b22a0dbf1f4ddce3458edb4cea04c8a127a6baa7083c83ba79d3d236a6cec15e8a1c05c4a8c747d7053b451dbed9b6a8defa17ec288
diff --git a/dev-python/leechcorepyc/files/leechcorepyc-2.16.9-respect-CC.patch b/dev-python/leechcorepyc/files/leechcorepyc-2.16.9-respect-CC.patch
new file mode 100644
index 000000000000..7ad3aac070ab
--- /dev/null
+++ b/dev-python/leechcorepyc/files/leechcorepyc-2.16.9-respect-CC.patch
@@ -0,0 +1,30 @@
+--- a/leechcore/Makefile
++++ b/leechcore/Makefile
+@@ -1,5 +1,6 @@
+-CC=gcc
+-CFLAGS += -I. -D LINUX -D _GNU_SOURCE -shared -fPIC -fvisibility=hidden -pthread `pkg-config libusb-1.0 --libs --cflags`
++CC?=gcc
++PKG_CONFIG ?= pkg-config
++CFLAGS += -I. -D LINUX -D _GNU_SOURCE -shared -fPIC -fvisibility=hidden -pthread `$(PKG_CONFIG) libusb-1.0 --libs --cflags`
+ # DEBUG FLAGS BELOW
+ # export ASAN_OPTIONS=strict_string_checks=1:detect_stack_use_after_return=1:check_initialization_order=1:strict_init_order=1:detect_invalid_pointer_pairs=2
+ # CFLAGS += -g -O0 -Wextra -Wno-unused-parameter -Wno-cast-function-type
+--- a/leechcore_device_rawtcp/Makefile
++++ b/leechcore_device_rawtcp/Makefile
+@@ -1,4 +1,4 @@
+-CC=gcc
++CC?=gcc
+ CFLAGS += -I. -I../includes -D LINUX -shared -fPIC -fvisibility=hidden
+ LDFLAGS += -g -shared
+ DEPS =
+--- a/leechcore_ft601_driver_linux/Makefile
++++ b/leechcore_ft601_driver_linux/Makefile
+@@ -1,5 +1,6 @@
+-CC=gcc
+-CFLAGS += -I. -D LINUX -shared -fPIC -fvisibility=hidden `pkg-config libusb-1.0 --libs --cflags`
++CC?=gcc
++PKG_CONFIG ?= pkg-config
++CFLAGS += -I. -D LINUX -shared -fPIC -fvisibility=hidden `$(PKG_CONFIG) libusb-1.0 --libs --cflags`
+ LDFLAGS += -g -shared
+ DEPS = leechcore_ft601_driver_linux.h
+ OBJ = fpga_libusb.o leechcore_ft601_driver_linux.o
diff --git a/dev-python/leechcorepyc/leechcorepyc-2.16.9.ebuild b/dev-python/leechcorepyc/leechcorepyc-2.16.9.ebuild
new file mode 100644
index 000000000000..594aa6daeab7
--- /dev/null
+++ b/dev-python/leechcorepyc/leechcorepyc-2.16.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 toolchain-funcs pypi
+
+DESCRIPTION="Python binding for LeechCore Physical Memory Acquisition Library"
+HOMEPAGE="https://github.com/ufrisk/LeechCore"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# leechcorepyc ships with a bundled version of the LeechCore library. So we
+# don't depend on the library here. But we must be aware this module doesn't
+# use the system library.
+DEPEND="virtual/libusb:="
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.16.9-respect-CC.patch"
+)
+
+src_prepare() {
+ default
+
+ # Avoid redefining _FORTIFY_SOURCE. See #893824, #906715.
+ sed -i -e 's/ -D_FORTIFY_SOURCE=2 / /g' leechcore/Makefile || die
+}
+
+src_configure() {
+ tc-export CC
+
+ distutils-r1_src_configure
+}