summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-09-11 16:19:48 -0700
committerPatrick McLean <chutzpah@gentoo.org>2023-09-11 16:19:56 -0700
commit17ad7ca8bf1ae0b708bd147f75660ca4366130e2 (patch)
tree04c338dd23e98a398ef67baa555c46d3bf428e2c
parentapp-misc/yq: add 3.2.3 (diff)
downloadgentoo-17ad7ca8.tar.gz
gentoo-17ad7ca8.tar.bz2
gentoo-17ad7ca8.zip
app-misc/yq: drop 3.1.1, 3.2.1
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--app-misc/yq/Manifest2
-rw-r--r--app-misc/yq/yq-3.1.1.ebuild59
-rw-r--r--app-misc/yq/yq-3.2.1.ebuild56
3 files changed, 0 insertions, 117 deletions
diff --git a/app-misc/yq/Manifest b/app-misc/yq/Manifest
index 17459a30616f..f056242977e2 100644
--- a/app-misc/yq/Manifest
+++ b/app-misc/yq/Manifest
@@ -1,4 +1,2 @@
-DIST yq-3.1.1.tar.gz 30095 BLAKE2B 0f8ed3d23e1c1b65fae0164f34b19ab774308ee8ec9b5c21547c5eddf930c49750cdbee858b6b48bcd92d4146715f7e4c45dd976141dc5837c788e4ae68a51bc SHA512 f6d372fd406179121849330391ab5657e9bac3b6fb4d33673872d4649337fd60344fe01c534d1382cc35416919cd19b62287350d1f0f825f198fb9cc9bc58c1f
-DIST yq-3.2.1.tar.gz 30333 BLAKE2B ead106995dcd03bc729aabd07c20dff37cf42053378f9d73c20739cb10921619999df73852d69f397431c4a382d40735c751aff9676d66ab9edbc5480a5c6807 SHA512 5b696434c9b6520873f4b956370fe598e3ac8df544d8b4ebc0d7fa935d344e58d9b838f2133b02c9e35a8afc5193c309d36b4cd8dc7792aef17918b9704b58e0
DIST yq-3.2.2.tar.gz 30872 BLAKE2B 4386a7972b411159ed909ccdc7c32a878d064ac5101cbddb16b0f1efe37c3791aeefda3b7c18c94e7d79fb01a4a4b43f7fbcc7c55bd275c52e08cc069523c8d3 SHA512 4472006d6997f7d620f71ade53d31e6db4051414c147db4f14cb31e0a16a0d0faf9e5c5a682cec098146bfd4e29f9e62278e4f208487e9e194d317ee82823e60
DIST yq-3.2.3.tar.gz 31952 BLAKE2B b0c4548efa08aecc98b77b5988e5dbf652951ecfab3ab01bfbf9610151cee3c3a0b9c3139434cba3bfc08a2176a617a2c9d19c0fcf47bb8a6d3cc3886fa5de6d SHA512 8b60907536b5f3ae7c18dc157ed8ccf4632f2734803711a18b71111fbd6e6efff24ddc9c2221fb926ca99bf538c3bba14517529e6edb37bc487fb69441ad7928
diff --git a/app-misc/yq/yq-3.1.1.ebuild b/app-misc/yq/yq-3.1.1.ebuild
deleted file mode 100644
index 93a72bf0f774..000000000000
--- a/app-misc/yq/yq-3.1.1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit pypi distutils-r1
-
-DESCRIPTION="Command-line YAML processor - jq wrapper for YAML documents"
-HOMEPAGE="
- https://yq.readthedocs.io/
- https://github.com/kislyuk/yq/
- https://pypi.org/project/yq/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- app-misc/jq
- dev-python/argcomplete[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
- dev-python/xmltodict[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.{8..10})
-"
-DEPEND="
- ${RDEPEND}
- test? (
- dev-python/wheel[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/yq-2.13.0-tests.patch"
- "${FILESDIR}/yq-3.1.1-tomli.patch"
-)
-
-python_prepare_all() {
- sed -e 's:unittest.main():unittest.main(verbosity=2):' \
- -i test/test.py || die
-
- sed -r -e 's:[[:space:]]*"coverage",:: ; s:[[:space:]]*"flake8",::' \
- -i setup.py || die
-
- sed -e '/license_file/ d' -i setup.cfg || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${EPYTHON}" test/test.py </dev/null || die "tests failed under ${EPYTHON}"
-}
diff --git a/app-misc/yq/yq-3.2.1.ebuild b/app-misc/yq/yq-3.2.1.ebuild
deleted file mode 100644
index 01b7d551cff6..000000000000
--- a/app-misc/yq/yq-3.2.1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit pypi distutils-r1
-
-DESCRIPTION="Command-line YAML processor - jq wrapper for YAML documents"
-HOMEPAGE="
- https://yq.readthedocs.io/
- https://github.com/kislyuk/yq/
- https://pypi.org/project/yq/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- app-misc/jq
- dev-python/argcomplete[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
- dev-python/xmltodict[${PYTHON_USEDEP}]
- >=dev-python/tomlkit-0.11.6[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${RDEPEND}
- test? (
- dev-python/wheel[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/yq-2.13.0-tests.patch"
-)
-
-python_prepare_all() {
- sed -e 's:unittest.main():unittest.main(verbosity=2):' \
- -i test/test.py || die
-
- sed -r -e 's:[[:space:]]*"coverage",:: ; s:[[:space:]]*"flake8",::' \
- -i setup.py || die
-
- sed -e '/license_file/ d' -i setup.cfg || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${EPYTHON}" test/test.py </dev/null || die "tests failed under ${EPYTHON}"
-}