summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-14 15:43:23 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-14 15:45:06 -0600
commit17ae35d84179494da590276bdf61784e9226a5d9 (patch)
tree7dc50209e1b03e90224a2eb7a5246537d64a64ed
parentapp-emacs/mldonkey: Fix byte-compilation with Emacs 26. (diff)
downloadgentoo-17ae35d84179494da590276bdf61784e9226a5d9.tar.gz
gentoo-17ae35d84179494da590276bdf61784e9226a5d9.tar.bz2
gentoo-17ae35d84179494da590276bdf61784e9226a5d9.zip
Revert "sys-fs/zfs: make modprobe optional for systemd unit files"
This reverts commit c756381a157ee8c3de2924685791d962eeb3d341.
-rw-r--r--sys-fs/zfs/zfs-9999.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/sys-fs/zfs/zfs-9999.ebuild b/sys-fs/zfs/zfs-9999.ebuild
index 5cfa93fa4c50..7b8d2f94a45c 100644
--- a/sys-fs/zfs/zfs-9999.ebuild
+++ b/sys-fs/zfs/zfs-9999.ebuild
@@ -87,6 +87,12 @@ src_prepare() {
-e "s|/sbin/parted|/usr/sbin/parted|" \
-i scripts/common.sh.in
+ if use kernel-builtin
+ then
+ einfo "kernel-builtin enabled, removing module loading from"
+ einfo "systemd units."
+ sed -i -e '/modprobe\ zfs/d' etc/systemd/system/*.service.in || die
+ fi
autotools-utils_src_prepare
}
@@ -114,6 +120,10 @@ src_configure() {
sed -e "s:@sbindir@:${EPREFIX}/sbin:g" \
-e "s:@sysconfdir@:${EPREFIX}/etc:g" \
> "${T}/zfs-init.sh" || die
+ if use kernel-builtin
+ then
+ sed -i -e '/modprobe\ zfs/d' "${T}/zfs.service" || die
+ fi
}
src_install() {