summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-30 07:26:24 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-30 08:08:11 +0100
commit17b6a24486d0cca2fe20f28562680a3477642c14 (patch)
tree296c68ed4ca2a24a82fa54246b36486f92a0f473
parentapp-admin/awscli: Bump to 1.27.40 (diff)
downloadgentoo-17b6a244.tar.gz
gentoo-17b6a244.tar.bz2
gentoo-17b6a244.zip
dev-python/icalendar: Bump to 5.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/icalendar/Manifest1
-rw-r--r--dev-python/icalendar/icalendar-5.0.4.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/icalendar/Manifest b/dev-python/icalendar/Manifest
index 0a5d8662932a..e9d39d48d487 100644
--- a/dev-python/icalendar/Manifest
+++ b/dev-python/icalendar/Manifest
@@ -1 +1,2 @@
DIST icalendar-5.0.3.tar.gz 101431 BLAKE2B 4c98880f661c5cd8025e7e281dbd392ff9333c3a4c3850d7826cbbb15401d0916e24c1478ac3098c58709a065f3de21b7d8fea56ad7df40aec06b989a77deac5 SHA512 ee278a4776cbac3dfa99e8931fc48be49b06e3354689c8d5132ff53092edb913c24a61a69dac7f5de3defdb929a6b53374209d3f7a8dd5af53f414e5aadfa44f
+DIST icalendar-5.0.4.tar.gz 102093 BLAKE2B 5bb618f8abfa8c96cdf45b0fd85f97ecfbe99361fb2eda08fe6ba43da1d01642e116218bc01353a745f6dc401278887d5ffc616fcf666691360174459c896362 SHA512 5b9b1b770c903bec4d8e5a4dc20b82d8e35eb86e6421d62abad640e65db20ccc71757a939e9ccb051653962ab5725e80dbc024703de158fee2cb0d608b8b5732
diff --git a/dev-python/icalendar/icalendar-5.0.4.ebuild b/dev-python/icalendar/icalendar-5.0.4.ebuild
new file mode 100644
index 000000000000..c68083d1dacb
--- /dev/null
+++ b/dev-python/icalendar/icalendar-5.0.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
+HOMEPAGE="
+ https://github.com/collective/icalendar/
+ https://pypi.org/project/icalendar/
+"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # reset conf.py to not read version from an installed instance
+ sed -e "s:pkg_resources.get_distribution('icalendar').version:'${PV}':" \
+ -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}