summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-14 06:16:44 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-14 07:31:30 +0100
commit17ccb625b73f9bc52ed52c063d863c802bf7c1b4 (patch)
treea53d4d5bd3c856a0238c32f93f2b619e949c2090
parentdev-python/aioresponses: Bump to 0.7.4 (diff)
downloadgentoo-17ccb625.tar.gz
gentoo-17ccb625.tar.bz2
gentoo-17ccb625.zip
dev-python/botocore: Bump to 1.29.29
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.29.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 5b58339ed229..8bbfc595575c 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -9,4 +9,5 @@ DIST botocore-1.29.24.gh.tar.gz 11006663 BLAKE2B 195933b78bd0c5c5881cd697c1c61c6
DIST botocore-1.29.25.gh.tar.gz 11008437 BLAKE2B 5a569d52065c2f448adb8c765e51e8338ce0bc2ae4b13e0f39a98af319aa1a31ef3a1eb4014aae8c497ab68a234dc2d16798a0d8b7c626e0ea81da4d2489ed7a SHA512 274a713d26cc723914824cdaf729d7537b5104957751b6d4b0c974e9f45a54ee09bd1853d1ab89dec2fb3b5a5b74102fa658c1f9478a4b4301b950e44f0f1fd5
DIST botocore-1.29.26.gh.tar.gz 11015382 BLAKE2B b9777a7db931b15bfae0e62a5095b86f8cfbf2f7d37b1111ec46d0add8d46ae5c57d1e74e8c58bd931e0a9b3faf986746d6c48149453f5921d9c084455cb3a3b SHA512 457e858e9648ff78bd1972e0772938dd608511aeeebd1f83e8bfda50bef43374f574d0a0943f6e29d0401be880e2db4e8a47d36a2e95317da58fba4920deae3f
DIST botocore-1.29.27.gh.tar.gz 11015321 BLAKE2B 81bd2269ca5dd5feedb7bd8a45a63e755575e9fb70b15d125beb57c1969259b16838e63660ff5a2f5ab24a52c1bdc21bca6a92e79f9023fa1c57f03250c096a5 SHA512 7fd577773f3fabbf38db8e5d353a27a73869d4249a55428a4d4e6056b9c459268887c264b1386f5170abe793709e4d9f2eb0e3e6daefea56f123fccea9d13cbf
+DIST botocore-1.29.29.gh.tar.gz 11020243 BLAKE2B f576fb0ba73b4a9c8a65eedf387a432b30b18db3f657e25ada7c5f3ad647b00ab1f0a855f19bd3ebd897d8e267a14a6d467c29bacb30809b61e7e92ef464ac1e SHA512 fa6457d811137906b0e46302ccabe9623d60ed5cbb588004bbddd0d28ebdaa3aabad3491641b4b69798ed371ddda3e23ea41b930db4f5856e2fa8242dc170571
DIST botocore-1.29.8.gh.tar.gz 10636661 BLAKE2B 3ebd9e5cb6cc1a9d4ddb877e806e0a845e6a19a4604b4489dbdb9a0f35251201de5d7062f3b0193db3e28f5170d8c3315fdc0b2bec7668a61880ff3e9305d3bc SHA512 c4a1a3993576bd0340de4eeb25e10650219e9d74c21f7e51e5298120bc92a8359143c38d5a991b940316fc5eac483e4e838298881a5c068fa91dc3ebf92a7f5a
diff --git a/dev-python/botocore/botocore-1.29.29.ebuild b/dev-python/botocore/botocore-1.29.29.ebuild
new file mode 100644
index 000000000000..eed342eb3cfa
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.29.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}