summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-07 20:47:11 +0000
committerSam James <sam@gentoo.org>2022-12-07 20:47:19 +0000
commit17cd20efce18f133cfb0977703bd1a5027c6a607 (patch)
treeb0b7a3b58e48e3d98e5f31bc900445c9a3bf333a
parentx11-drivers/nvidia-drivers: adjust fbsimple warning to mention vesa (diff)
downloadgentoo-17cd20efce18f133cfb0977703bd1a5027c6a607.tar.gz
gentoo-17cd20efce18f133cfb0977703bd1a5027c6a607.tar.bz2
gentoo-17cd20efce18f133cfb0977703bd1a5027c6a607.zip
sys-devel/autoconf-wrapper: add 20221207
Closes: https://bugs.gentoo.org/870169 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-devel/autoconf-wrapper/Manifest1
-rw-r--r--sys-devel/autoconf-wrapper/autoconf-wrapper-20221207.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-devel/autoconf-wrapper/Manifest b/sys-devel/autoconf-wrapper/Manifest
index 92ba4e2d8daa..4c4633a50539 100644
--- a/sys-devel/autoconf-wrapper/Manifest
+++ b/sys-devel/autoconf-wrapper/Manifest
@@ -1,2 +1,3 @@
DIST autotools-wrappers-at-20220130.tar.gz 3625 BLAKE2B c587d778a0c3331d14498308ae720dabdbcf27349ef0a3a2d5db56bb0ef597a5b1ab43388f1456e7888b40f043d68b0d89b420ac7404008f9a813ef78ae7e96f SHA512 700204b6024636dc808339aac15fb19bb645b654d4777ba8bf0febded5eb6af98659d04ed23819a8a638b6ee905e62292995bf2f838c30dedacb1a6bc0d04f1a
DIST autotools-wrappers-at-20221118.tar.gz 3625 BLAKE2B 713e4b581baf6b5c0756f8bd026566e113eb6e8f54a594f132aa952277f68c7a9da28c93a191b8ad4279952ebcfcf7a5d679d4bb7a831b14af208ff2172ee15c SHA512 1409c890fa3450195868536bb8c1bdcfb52c11f412ab0b99652e39b7ea4eeec1807611e4fa89c8289c162c7de8ff5c2864a86d6637ea24088b3125f8db895663
+DIST autotools-wrappers-at-20221207.tar.gz 3646 BLAKE2B 82bec40e03ae5ec133252fd3c05c3fed537bb415e800918df9c9d783d48a9d76cbe60c53dd7daf6d94653d79fc52be8c089183dda996e8a72dd03ffa83098613 SHA512 12ea99721e6fc60a3ed7351d6c228aaf6e4eef0bd0444eda8cd742f74fa91150ef07bb52f6bcad4a350269e8032f5d4e204d2f2108b0d9c441ddd7f9755862b7
diff --git a/sys-devel/autoconf-wrapper/autoconf-wrapper-20221207.ebuild b/sys-devel/autoconf-wrapper/autoconf-wrapper-20221207.ebuild
new file mode 100644
index 000000000000..936757448f5b
--- /dev/null
+++ b/sys-devel/autoconf-wrapper/autoconf-wrapper-20221207.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="autotools-wrappers-at-${PV}"
+
+DESCRIPTION="Wrapper for autoconf to manage multiple autoconf versions"
+HOMEPAGE="https://gitweb.gentoo.org/proj/autotools-wrappers.git"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI=" https://anongit.gentoo.org/git/proj/autotools-wrappers.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/autotools-wrappers.git/snapshot/${MY_P}.tar.gz"
+ #SRC_URI="https://dev.gentoo.org/~vapier/dist/${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+src_install() {
+ exeinto /usr/$(get_libdir)/misc
+ newexe ac-wrapper.sh ac-wrapper.sh
+
+ dodir /usr/bin
+ local x=
+ for x in auto{conf,header,m4te,reconf,scan,update} ifnames ; do
+ dosym ../$(get_libdir)/misc/ac-wrapper.sh /usr/bin/${x}
+ done
+}