summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-27 17:50:42 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-27 17:53:35 +0100
commit17d0dc8c7e9b66b69bb48a4114934917972e4db0 (patch)
tree54c55c416aef3f99b536a7ebc9f2574006bdd292
parentpackage.mask: Last rite games-util/xgamer (diff)
downloadgentoo-17d0dc8c.tar.gz
gentoo-17d0dc8c.tar.bz2
gentoo-17d0dc8c.zip
media-gfx/svg2rlg: Use pytest
Closes: https://bugs.gentoo.org/878709 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--media-gfx/svg2rlg/svg2rlg-0.4.0.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/media-gfx/svg2rlg/svg2rlg-0.4.0.ebuild b/media-gfx/svg2rlg/svg2rlg-0.4.0.ebuild
index 0c86b5cb4198..c2e08afe278a 100644
--- a/media-gfx/svg2rlg/svg2rlg-0.4.0.ebuild
+++ b/media-gfx/svg2rlg/svg2rlg-0.4.0.ebuild
@@ -7,7 +7,10 @@ PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Converts SVG files to PDFs or reportlab graphics"
-HOMEPAGE="https://github.com/sarnold/svg2rlg https://pypi.org/project/svg2rlg/"
+HOMEPAGE="
+ https://github.com/sarnold/svg2rlg/
+ https://pypi.org/project/svg2rlg/
+"
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://github.com/sarnold/svg2rlg.git"
@@ -21,10 +24,12 @@ fi
LICENSE="BSD"
SLOT="0"
-RDEPEND="dev-python/reportlab[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/reportlab[${PYTHON_USEDEP}]
+"
-distutils_enable_tests nose
+distutils_enable_tests pytest
python_test() {
- nosetests -sx test_svg2rlg.py || die "Test failed with ${EPYTHON}"
+ epytest test_svg2rlg.py
}