summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2018-02-23 02:02:55 +0100
committerDavide Pesavento <pesa@gentoo.org>2018-02-23 02:02:55 +0100
commit17f1a24c3760af4e3c56aba5d900d50651e5a34d (patch)
tree24d1b4ad76bbf9f915dbf8c3e903f9c2f2984e69
parentdev-qt/qtlockedfile: remove 2.4.1_p20150629-r1 (diff)
downloadgentoo-17f1a24c.tar.gz
gentoo-17f1a24c.tar.bz2
gentoo-17f1a24c.zip
dev-qt/qtsingleapplication: new snapshot
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--dev-qt/qtsingleapplication/Manifest1
-rw-r--r--dev-qt/qtsingleapplication/qtsingleapplication-2.6.1_p20171024.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-qt/qtsingleapplication/Manifest b/dev-qt/qtsingleapplication/Manifest
index 809a7c95df67..a4bc5fdc6e8b 100644
--- a/dev-qt/qtsingleapplication/Manifest
+++ b/dev-qt/qtsingleapplication/Manifest
@@ -1 +1,2 @@
DIST qt-solutions-20150629.tar.xz 710488 BLAKE2B 102829e3b2afa7cb665c09fc259f9b966596a8245e8e8325c6c45e402bc337d205539b20be791e16515754c6d74247a714b278028e9ffbb74f578c9b8b39b094 SHA512 a95ed58f0218cd90d734a40eedd173b896fa0138ad235f3157d7bee538b16c5f385d93bae483fd22267f2984389b9940bb85ba0cd3d25c16124d56abb39568f5
+DIST qt-solutions-20171024.tar.xz 710532 BLAKE2B 365f4c6fc3bee34bf26ac5039984ceac1d90527297b985b0d1b606f3ba67219bab7f7cba40b4adca55446c34e9f4fe218b4449ee255ba6f6409de78f80ccdaec SHA512 4784d88c2f40c88f06abeb728842875fb5e428a630dbf749f71055681b0c631803d2901b60aa8cc95f5f382dcd21da8d739873aa45e3dd3676ee95925f0198da
diff --git a/dev-qt/qtsingleapplication/qtsingleapplication-2.6.1_p20171024.ebuild b/dev-qt/qtsingleapplication/qtsingleapplication-2.6.1_p20171024.ebuild
new file mode 100644
index 000000000000..dace0a999a2d
--- /dev/null
+++ b/dev-qt/qtsingleapplication/qtsingleapplication-2.6.1_p20171024.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils
+
+MY_P=qt-solutions-${PV#*_p}
+
+DESCRIPTION="Qt library to start applications only once per user"
+HOMEPAGE="https://code.qt.io/cgit/qt-solutions/qt-solutions.git/"
+SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="doc X"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtlockedfile[qt5(+)]
+ dev-qt/qtnetwork:5
+ X? (
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}/${PN}"
+
+PATCHES=(
+ "${FILESDIR}/2.6.1_p20130904-unbundle-qtlockedfile.patch"
+ "${FILESDIR}/2.6.1_p20130904-no-gui.patch"
+)
+
+src_prepare() {
+ default
+
+ echo 'SOLUTIONS_LIBRARY = yes' > config.pri
+ use X || echo 'QTSA_NO_GUI = yes' >> config.pri
+
+ sed -i -e "s/-head/-${PV%.*}/" common.pri || die
+ sed -i -e '/SUBDIRS+=examples/d' ${PN}.pro || die
+
+ # to ensure unbundling
+ rm src/qtlockedfile* || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ einstalldocs
+
+ # libraries
+ dolib.so lib/*
+
+ # headers
+ insinto "$(qt5_get_headerdir)"/QtSolutions
+ doins src/qtsinglecoreapplication.h
+ use X && doins src/{QtSingleApplication,${PN}.h}
+
+ # .prf files
+ insinto "$(qt5_get_mkspecsdir)"/features
+ doins "${FILESDIR}"/qtsinglecoreapplication.prf
+ use X && doins "${FILESDIR}"/${PN}.prf
+}