summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-02-11 12:56:50 +0100
committerLouis Sautier <sbraz@gentoo.org>2020-02-11 13:03:16 +0100
commit17f398a363f8b5f0078c7f9046f3c2f5bc9b9741 (patch)
treeec732ce1e6ac477ec7af08f96825aa7294e63b69
parentdev-python/pip: works on ~arm (diff)
downloadgentoo-17f398a3.tar.gz
gentoo-17f398a3.tar.bz2
gentoo-17f398a3.zip
app-admin/supervisor: remove old versions and Python 2 support
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--app-admin/supervisor/Manifest3
-rw-r--r--app-admin/supervisor/supervisor-3.1.4.ebuild47
-rw-r--r--app-admin/supervisor/supervisor-3.3.5.ebuild82
-rw-r--r--app-admin/supervisor/supervisor-4.0.3.ebuild76
4 files changed, 0 insertions, 208 deletions
diff --git a/app-admin/supervisor/Manifest b/app-admin/supervisor/Manifest
index f05c7faf4531..1c7ee90462b7 100644
--- a/app-admin/supervisor/Manifest
+++ b/app-admin/supervisor/Manifest
@@ -1,4 +1 @@
-DIST supervisor-3.1.4.tar.gz 392321 BLAKE2B 316789fae200f02242a90d3a22a3c6486576f74dbab81b95efc72768a89c54999a370625f9589afe1edff08351840fbe27a7ef8674e6f1e3bbdd4237f3227df6 SHA512 7182db4169d37aa8f7a2a4e1d57ce40f6dea21759ed73fb49286dd5ffb2bdede0fccdc71344e93c8f8c067a2cbc4e3cb0a9a50b22bacdb1b8bc1378581ed5f07
-DIST supervisor-3.3.5.tar.gz 421220 BLAKE2B 63e9db005596921c4a4426de361fc20992a27b67b67ee1256cd64fe6d385909682a5055e4797512410f36f6855592f53c9c5720c54a2dae967578691d05ff3fc SHA512 66c43d40c216e5c3120e083407c848295fa1e59d6d9da916a4bae5c37d4d13208c3bf7c0c8b8a5d570270eb44fac0b1bbcceddb2e84e4f3fc1b6241b43116af7
-DIST supervisor-4.0.3.tar.gz 435960 BLAKE2B 001f556b955311e2453fe1091e46696f3712751e20fad54437fd86c6020e844047ac6cd8983d46a07dd1830e6324d198c84c9d0c8fe301bb5ca568e4c7345d72 SHA512 09de52dca9f71409954fb4782d42099d19892bd82797d2b3dc7100b2693da292fe9822b5144eaf4dcbe295f4e227d62601c8791016e1bcd5c253d99c89f59368
DIST supervisor-4.0.4.tar.gz 437708 BLAKE2B 211726da07ce31c00da0d6edba57942d78ee5d2757927b22afe569364c29aaf55375d4895b381f06071bc6b6c39a926ca2073e8fcb8e0ea9673a89aafd08b346 SHA512 22a38f759b0584310f5e16acbfc7b0c4cc59f3206fbfaf6295bd40a826d50ad02c8b0093821362c5038dd987a6599879d82dcefe948a2eda702b89e9f92e471e
diff --git a/app-admin/supervisor/supervisor-3.1.4.ebuild b/app-admin/supervisor/supervisor-3.1.4.ebuild
deleted file mode 100644
index 7eb4c5a33259..000000000000
--- a/app-admin/supervisor/supervisor-3.1.4.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-PYTHON_COMPAT=( python2_7 ) # py2 only
-# xml.etree.ElementTree module required.
-PYTHON_REQ_USE="xml"
-
-inherit distutils-r1
-
-MY_PV="${PV/_beta/b}"
-
-DESCRIPTION="A system for controlling process state under UNIX"
-HOMEPAGE="http://supervisord.org/ https://pypi.org/project/supervisor/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
-
-LICENSE="repoze ZPL BSD HPND GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-# ALL versions of meld3 match to >=meld3-0.6.5
-RDEPEND="dev-python/meld3[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/mock[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-python_compile_all() {
- # Somehow the test phase is called and run on invoking a doc build; harmless
- use doc && emake -C docs html
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- newinitd "${FILESDIR}/init.d-r1" supervisord
- newconfd "${FILESDIR}/conf.d" supervisord
- use doc && local HTML_DOCS=( docs/.build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/app-admin/supervisor/supervisor-3.3.5.ebuild b/app-admin/supervisor/supervisor-3.3.5.ebuild
deleted file mode 100644
index 3abc9b5b4158..000000000000
--- a/app-admin/supervisor/supervisor-3.3.5.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 ) # py2 only
-# xml.etree.ElementTree module required.
-PYTHON_REQ_USE="xml"
-
-inherit distutils-r1 systemd user
-
-MY_PV="${PV/_beta/b}"
-
-DESCRIPTION="A system for controlling process state under UNIX"
-HOMEPAGE="http://supervisord.org/ https://pypi.org/project/supervisor/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
-
-LICENSE="repoze ZPL BSD HPND GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/meld3[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- ${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-python_prepare_all() {
- # https://wiki.gentoo.org/wiki/Project:Python/Namespace_packages
- sed -i '/namespace_packages=/d' setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- emake -C docs html
- HTML_DOCS=( docs/.build/html/. )
- fi
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- newinitd "${FILESDIR}/init.d-r2" supervisord
- newconfd "${FILESDIR}/conf.d-r1" supervisord
- dodoc supervisor/skel/sample.conf
- keepdir /etc/supervisord.d
- insinto /etc
- doins "${FILESDIR}/supervisord.conf"
- keepdir /var/log/supervisor
- systemd_dounit "${FILESDIR}/supervisord.service"
-}
-
-pkg_preinst() {
- enewgroup supervisor
- fowners :supervisor /var/log/supervisor
- fperms 750 /var/log/supervisor
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- # This is a new installation
- elog "You may install your configuration files in ${EROOT}/etc/supervisord.d"
- elog "For config examples, see ${EROOT}/usr/share/doc/${PF}/sample.conf.bz2"
- elog ""
- elog "By default, only members of the supervisor group can run supervisorctl."
- fi
-}
diff --git a/app-admin/supervisor/supervisor-4.0.3.ebuild b/app-admin/supervisor/supervisor-4.0.3.ebuild
deleted file mode 100644
index f71315bfc37b..000000000000
--- a/app-admin/supervisor/supervisor-4.0.3.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_{6,7}} )
-# xml.etree.ElementTree module required.
-PYTHON_REQ_USE="xml(+)"
-
-inherit distutils-r1 systemd user
-
-MY_PV="${PV/_beta/b}"
-
-DESCRIPTION="A system for controlling process state under UNIX"
-HOMEPAGE="http://supervisord.org/ https://pypi.org/project/supervisor/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
-
-LICENSE="repoze ZPL BSD HPND GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/meld3-1.0.0[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- ${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-python_compile_all() {
- if use doc; then
- emake -C docs html
- HTML_DOCS=( docs/.build/html/. )
- fi
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- newinitd "${FILESDIR}/init.d-r2" supervisord
- newconfd "${FILESDIR}/conf.d-r1" supervisord
- dodoc supervisor/skel/sample.conf
- keepdir /etc/supervisord.d
- insinto /etc
- doins "${FILESDIR}/supervisord.conf"
- keepdir /var/log/supervisor
- systemd_dounit "${FILESDIR}/supervisord.service"
-}
-
-pkg_preinst() {
- enewgroup supervisor
- fowners :supervisor /var/log/supervisor
- fperms 750 /var/log/supervisor
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- # This is a new installation
- elog "You may install your configuration files in ${EROOT}/etc/supervisord.d"
- elog "For config examples, see ${EROOT}/usr/share/doc/${PF}/sample.conf.bz2"
- elog ""
- elog "By default, only members of the supervisor group can run supervisorctl."
- fi
-}