summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-06-04 09:51:41 -0700
committerZac Medico <zmedico@gentoo.org>2019-06-04 09:53:49 -0700
commit17f51b5ab0a29b1573c0a1c40ed175cac723e979 (patch)
treec6dc163cf6c86f8645c04c64707208f621c7d7b8
parentnet-misc/rdesktop: ppc64 stable wrt bug #687268 (diff)
downloadgentoo-17f51b5ab0a29b1573c0a1c40ed175cac723e979.tar.gz
gentoo-17f51b5ab0a29b1573c0a1c40ed175cac723e979.tar.bz2
gentoo-17f51b5ab0a29b1573c0a1c40ed175cac723e979.zip
app-emulation/buildah: Bump to version 1.8.3
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--app-emulation/buildah/Manifest1
-rw-r--r--app-emulation/buildah/buildah-1.8.3.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-emulation/buildah/Manifest b/app-emulation/buildah/Manifest
index ca61180fe77d..1c599c028c1a 100644
--- a/app-emulation/buildah/Manifest
+++ b/app-emulation/buildah/Manifest
@@ -1 +1,2 @@
DIST buildah-1.8.2.tar.gz 5102103 BLAKE2B 2e19f8af15e5f4a3c6488a44cc0f51592bc6f5201f217ea814daf4b08691f08170debfa2de01d39ae20c6289ed0915383b958cd5e59d8b598d867053ee990af2 SHA512 0cb8dc62c4139a5b500d4021b05344c70c1ec86ff9850bcca87011ad522fe95981d373d73b30b7899959876d78cd15e565e034cf136aa271a72fa4810ff34cae
+DIST buildah-1.8.3.tar.gz 5114332 BLAKE2B 55ef5e10e8a2a2b95ef8f8cd28a3ccdb3e734fc3ef64a890900e20a5b8994f92571e2cdec875813203fc4e98a8c4f09656d16bc4c6242194131a25713e054492 SHA512 f875c448f81ef272ad0b7be9c1579d6650983fed4e471095cd645ae1126b49d91ec15b55a072e722205154b681eefc0fb32f5a452d827e875eb0c4779f5d712b
diff --git a/app-emulation/buildah/buildah-1.8.3.ebuild b/app-emulation/buildah/buildah-1.8.3.ebuild
new file mode 100644
index 000000000000..0b435ee4967a
--- /dev/null
+++ b/app-emulation/buildah/buildah-1.8.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit bash-completion-r1 golang-vcs-snapshot
+
+KEYWORDS="~amd64"
+DESCRIPTION="A tool that facilitates building OCI images"
+HOMEPAGE="https://github.com/containers/buildah"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ostree selinux"
+EGO_PN="${HOMEPAGE#*//}"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="547bd9a"
+SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+RDEPEND="app-crypt/gpgme:=
+ app-emulation/skopeo
+ dev-libs/libgpg-error:=
+ dev-libs/libassuan:=
+ sys-fs/lvm2:=
+ sys-libs/libseccomp:=
+ selinux? ( sys-libs/libselinux:= )"
+DEPEND="${RDEPEND}"
+RESTRICT="test"
+REQUIRED_USE="!selinux? ( !ostree )"
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_prepare() {
+ default
+ sed -e 's|^\(GIT_COMMIT ?= \).*|\1'${GIT_COMMIT}'|' -i Makefile || die
+
+ [[ -f ostree_tag.sh ]] || die
+ use ostree || { echo -e "#!/bin/sh\necho containers_image_ostree_stub" > \
+ ostree_tag.sh || die; }
+
+ [[ -f selinux_tag.sh ]] || die
+ use selinux || { echo -e "#!/bin/sh\ntrue" > \
+ selinux_tag.sh || die; }
+}
+
+src_compile() {
+ export -n GOCACHE XDG_CACHE_HOME
+ GOPATH="${WORKDIR}/${P}" emake all
+}
+
+src_install() {
+ dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
+ doman docs/*.1
+ dodoc -r docs/tutorials
+ dobin ${PN} imgtype
+ dobashcomp contrib/completions/bash/buildah
+}
+
+src_test() {
+ GOPATH="${WORKDIR}/${P}" emake test-unit
+}