summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-04 02:51:43 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-04 03:00:12 +1200
commit17f5d4f29899261996e26b06aad3d4af4806bee1 (patch)
tree091755dd1ac75812eed08113b72bb6e1319e84c1
parentdev-perl/Bio-SamTools: -r bump for toolchain fixes (diff)
downloadgentoo-17f5d4f29899261996e26b06aad3d4af4806bee1.tar.gz
gentoo-17f5d4f29899261996e26b06aad3d4af4806bee1.tar.bz2
gentoo-17f5d4f29899261996e26b06aad3d4af4806bee1.zip
dev-perl/bareword-filehandles: -r bump for CFLAGS love
- Ensure CFLAGS passed through to make/compiler Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/bareword-filehandles/bareword-filehandles-0.7.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/bareword-filehandles/bareword-filehandles-0.7.0-r1.ebuild b/dev-perl/bareword-filehandles/bareword-filehandles-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..1e9f50c24c61
--- /dev/null
+++ b/dev-perl/bareword-filehandles/bareword-filehandles-0.7.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ILMARI
+DIST_VERSION=0.007
+inherit perl-module
+
+DESCRIPTION="Disables bareword filehandles"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Lexical::SealRequireHints only required with Perl < 5.12
+# We could add alternation here, but it would be work without benefit
+# which would complicate stabilization
+RDEPEND="
+ dev-perl/B-Hooks-OP-Check
+ virtual/perl-if
+ virtual/perl-XSLoader
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ dev-perl/ExtUtils-Depends
+ test? ( >=virtual/perl-Test-Simple-0.880.0 )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}